Transient Analysis (R&S FSW-K60)
Contents
  • Welcome to the Transient Analysis Application
  • About Transient Analysis
  • Measurement Basics
  • Measurement Results
  • Configuration
  • Analysis
  • How to Perform Transient Analysis
  • Measurement Examples
  • Optimizing and Troubleshooting
  • Remote Commands to Perform Transient Analysis
  • List of Commands
Top


Welcome to the Transient Analysis Application

Transient Analysis (R&S FSW-K60) > Welcome to the Transient Analysis Application
Welcome to the Transient Analysis Application

The R&S FSW-K60 is a firmware application that adds functionality to detect transient signal effects to the R&S FSW.

The R&S FSW-K60 features:

  • Analysis of transient effects
  • Quick analysis even before measurement end due to online transfer of captured and measured I/Q data
  • Easy analysis of user-defined regions within the captured data
  • Analysis of frequency hopping or chirped FM signals (with additional Transient Analysis options)

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage.

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the Transient Analysis Application
  • Understanding the Display Information


Starting the Transient Analysis Application

Transient Analysis (R&S FSW-K60) > Welcome to the Transient Analysis Application > Starting the Transient Analysis Application
Starting the Transient Analysis Application

The Transient Analysis application adds a new application to the R&S FSW.

To activate the Transient Analysis application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "Transient Analysis" item.

    The R&S FSW opens a new measurement channel for the Transient Analysis application.

For details see "Applications and Operating Modes" .

The measurement is started immediately with the default settings. It can be configured in the Transient "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").


Understanding the Display Information

Transient Analysis (R&S FSW-K60) > Welcome to the Transient Analysis Application > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during analyzer operation. All different information areas are labeled. They are explained in more detail in the following sections.

1 = Channel bar for firmware and measurement settings
2+3 = Window title bar with diagram-specific (trace) information
4 = Diagram area
5 = Diagram footer with diagram-specific information
6 = Instrument status bar with error messages, progress bar and date/time display
MSRA/MSRT operating mode

In MSRA and MSRT operating mode, additional tabs and elements are available. A colored background of the screen behind the measurement channel tabs indicates that you are in MSRA/MSRT operating mode.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

Channel bar information

In the Transient Analysis application, the R&S FSW shows the following settings:

Information displayed in the channel bar in the Transient Analysis application
Ref Level | Reference level
Att | RF attenuation
Freq | Center frequency for the RF signal
Meas BW | Measurement bandwidth
Meas Time | Measurement time (data acquisition time)
Sample Rate | Sample rate
Model | Signal model (hop, chirp or none)
SGL | The sweep is set to single sweep mode.

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer or trigger settings). This information is displayed only when applicable for the current measurement. For details see the R&S FSW Getting Started manual.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in the Pulse application
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
5 = Detector mode
6 = Trace mode
Diagram footer information

The diagram footer (beneath the diagram) contains the following information, depending on the evaluation:

Time domain:
  • Start and stop time of data acquisition
Frequency domain:
  • Center frequency
  • Measurement bandwidth
  • Bandwidth displayed per division
Spectrogram:
  • Selected frame number
Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


About Transient Analysis

Transient Analysis (R&S FSW-K60) > About Transient Analysis
About Transient Analysis

Transient analysis refers to signal effects which may appear briefly or change rapidly in time or frequency. Typical examples are spurious emissions or modulated signals using frequency-hopping techniques. Such signals often require analysis of a large bandwidth, if possible without gaps.

Ideally, such signals are analyzed in realtime mode, which employs special hardware in order to capture and process data simultaneously, and seamlessly. However, if a realtime analyzer is not available, the Transient Analysis application is a good choice.

Similarly to realtime mode, but without the special hardware, this application captures data and asynchronously - before data acquisition is completed - starts analyzing the available input and displays first results. Especially for large bandwidths or long measurement times, analysis becomes much more efficient and the complete measurement task can be sped up significantly. Although gaps may occur between successive measurements with large bandwidths, the results from each individual measurement are completely without gaps.

Thus, the Transient Analysis application supports you in analyzing time- and frequency-variant signals with large bandwidths.


Measurement Basics

Transient Analysis (R&S FSW-K60) > Measurement Basics
Measurement Basics

Some background knowledge on basic terms and principles used in analysis of transient signals is provided here for a better understanding of the required configuration settings.

Contents
  • Data Acquisition
  • Signal Processing
  • Signal Models
  • Basis of Evaluation
  • Analysis Region
  • Measurement Range
  • Trace Evaluation
  • Transient Analysis in MSRA/MSRT Mode


Data Acquisition

Transient Analysis (R&S FSW-K60) > Measurement Basics > Data Acquisition
Data Acquisition

The R&S FSW Transient Analysis application measures the power of the signal input over time. How much data is captured depends on the measurement bandwidth and the measurement time. These two values are interdependant and allow you to define the data to be measured using different methods:

  • By defining a bandwidth around the specified center frequency to be measured at a specified sample rate
  • By defining a time length during which a specified number of samples are measured at the specified center frequency


Signal Processing

Transient Analysis (R&S FSW-K60) > Measurement Basics > Signal Processing
Signal Processing

The R&S FSW Transient Analysis application measures the power of the signal input over time. In order to convert the time domain signal to a frequency spectrum, an FFT (Fast Fourier Transformation) is performed which converts a vector of input values into a discrete spectrum of frequencies.

The application calculates multiple FFTs per capture, by dividing one capture into several overlapping FFT frames. This is especially useful in conjunction with window functions since it enables a gap-free frequency analysis of the signal.

Using overlapping FFT frames leads to more individual results and improves detection of transient signal effects. However, it also extends the duration of the calculation. The size of the FFT frame depends on the number of input signal values (record length), the overlap factor, and the time resolution (time span used for each FFT calculation).

FFT window functions

Each FFT frame is multiplied with a specific window function after sampling in the time domain. Windowing helps minimize the discontinuities at the end of the measured signal interval and thus reduces the effect of spectral leakage, increasing the frequency resolution.

Additional filters can be applied after demodulation to filter out unwanted signals, or correct pre-emphasized input signals.

Asynchronous data processing

During a measurement in the R&S FSW Transient Analysis application, the data is captured and stored in the capture buffer until the defined measurement time has expired. As soon as a minimum amount of data is available, the first FFT calculation is performed. As soon as the required number of (overlapping) FFT results is available (defined by the "sweep count"), the detector function is applied to the data and the first frame is displayed in the Spectrogram (and any other active result displays).

Signal processing: calculating one spectrogram frame

Shortly after the measurement time is over, the final results are displayed and the measurement is complete. Due to this asynchronous processing, initial analysis results are available very quickly. At the same time, the data is captured over the full bandwidth entirely without gaps. The following figure illustrates how the capture and result display processes are performed asynchronously.

Asynchronous data processing
Multiple spectrograms

However, after each data acquisition, a short delay occurs before the next acquisition can be carried out. Thus, for measurements for which several spectrograms are required and the capturing process is repeated several times (defined by the "frame count"), a short gap in the results between spectrograms can be detected.

Signal processing: calculating several spectrograms
Resolution bandwidth

The resolution bandwidth (RBW) has an effect on how the spectrum is measured and displayed. It determines the frequency resolution of the measured spectrum and is directly coupled to the selected analysis bandwidth (ABW). The ABW can be the full measurement bandwidth, the bandwidth of the analysis region, or the length of the result range, depending on the evaluation basis of the result display (see "Basis of Evaluation"). If the ABW is changed, the resolution bandwidth is automatically adjusted. Which coupling ratios are available depends on the selected "FFT Window".

A small resolution bandwidth has several advantages. The smaller the resolution bandwidth, the better you can observe signals whose frequencies are close together and the less noise is displayed. However, a small resolution bandwidth also increases the required measurement time.

The resolution bandwidth parameters can be defined in the bandwidth configuration, see "Bandwidth Settings".

Time resolution

The time resolution determines the size of the bins used for each FFT calculation. The shorter the time span used for each FFT, the shorter the resulting span, and thus the higher the resolution in the spectrum becomes. The time resolution to be used for R&S FSW can be defined manually or automatically according to the data acquisition settings.


Signal Models

Transient Analysis (R&S FSW-K60) > Measurement Basics > Signal Models
Signal Models

If the additional firmware options R&S FSW-K60H or -K60C are installed, the R&S FSW Transient Analysis application supports different signal models for which similar parameters are characteristic.

Contents
  • Frequency Hopping
  • Frequency Chirping
  • Automatic vs. Manual Hop/Chirp State Detection


Frequency Hopping

Transient Analysis (R&S FSW-K60) > Measurement Basics > Signal Models > Frequency Hopping
Frequency Hopping

Some digital data transmission standards employ a frequency-hopping technique, in which a carrier signal is rapidly switched among many frequency channels. Discrete frequencies and continuous modulation are characteristic of this signal model.

Typical spectrogram of a frequency-hopping signal

Analyzing such signals includes the following challenges:

  • Detecting the currently used carrier frequency and a possible offset
  • Determining the duration the signal stays at one frequency and the time it takes to switch to another
  • Measuring the average power level
  • Demodulating the signal correctly

The R&S FSW Transient Analysis application (with the additional R&S FSW-K60H option installed) can automatically detect frequency hops in a measured signal and determine characteristic hop parameters. Both pulsed and continuous wave hopping signals can be analyzed.

Assuming a frequency-hopping signal model, the frequency bands in which the carrier can be expected are usually known in advance. Therefore, you can configure conditions that must apply to the measured signal in order to detect a frequency hop and distinguish it from random spurs or frequency distortions. Such conditions can be a frequency tolerance around a defined nominal value, for instance, or a minimum or maximum dwell time in which the frequency remains steady.

Parameters required to detect hops
Nominal Frequency Values (Hop States)

The (nominal) frequency values the carrier is expected to "hop" to are defined in advance. Each such level is considered to be a hop state. The hop states are defined as frequency offsets from the center frequency. A tolerance span can be defined to compensate for settling effects. As long as the deviation remains within the tolerance above or below the nominal frequency, the hop state is detected.

The nominal frequency levels are numbered consecutively in the "Hop States" table (see "Signal Detection (Signal States)"), starting at 0. The state index of the corresponding nominal frequency level is assigned to each detected hop in the measured signal results.

Dwell Time Conditions

The dwell time is the time the signal remains in the tolerance area of a nominal hop frequency, or in other words: the duration of a hop from beginning to end. In a default measurement, useful dwell times for the current measurement are determined automatically. However, you can define minimum or maximum dwell times, or both, manually, in order to detect only specific hops, for example.


Frequency Chirping

Transient Analysis (R&S FSW-K60) > Measurement Basics > Signal Models > Frequency Chirping
Frequency Chirping

Frequency chirping is similar to hopping, however, instead of switching to discrete frequencies, the frequency varies with time at a particular chirp rate. Transient analysis with the R&S FSW application (and the additional R&S FSW-K60C option) is restricted to the commonly used linear FM chirp signals. In this case, the nominal chirp switches to discrete values, referred to as the chirp states.

Typical spectrogram of a chirped signal

The R&S FSW Transient Analysis application can automatically detect chirps in a measured signal and determine characteristic chirp parameters. Both pulsed and continuous wave chirp signals can be analyzed.

Obviously, if you consider the chirps rather than the individual frequencies, the measured data from chirped signals is very similar to hopped signals, and thus the analysis tasks and the characteristic parameters are very similar, as well.

Parameters required to detect chirps

In the R&S FSW Transient Analysis application, for a chirp signal, the derivation of the captured signal data is calculated before further analysis. From there, processing is identical for both signal models.


Automatic vs. Manual Hop/Chirp State Detection

Transient Analysis (R&S FSW-K60) > Measurement Basics > Signal Models > Automatic vs. Manual Hop/Chirp State Detection
Automatic vs. Manual Hop/Chirp State Detection

By default, the R&S FSW Transient Analysis application automatically detects the existing hop/chirp states in a pre-measurement. For an initial overview of the signal at hand this detection is usually sufficient. For more accurate results, particularly if the input signal is known in advance, the nominal frequency or chirp values can be defined manually.


Basis of Evaluation

Transient Analysis (R&S FSW-K60) > Measurement Basics > Basis of Evaluation
Basis of Evaluation

Depending on the measurement task, not all of the measured data in the capture buffer may be of interest. In some cases it may be useful to restrict analysis to a specific user-definable region, or to a selected individual chirp or hop. This makes analysis more efficient and the display clearer.

Automatic detection of hops or chirps, for example, is always based on a restricted analysis region. Numeric results for characteristic parameters, as well as statistical results, are also calculated on this restricted basis.

For graphical displays, selecting an individual hop or chirp allows you to analyze or compare characteristic values in detail.

Which evaluation basis is available for which result display is indicated in table "Available evaluation methods and evaluation basis".

Detected hops/chirps are indicated by green bars along the x-axis in graphical result displays. The selected hop/chirp (see "Select Hop / Select Chirp") is indicated by a blue bar.


Analysis Region

Transient Analysis (R&S FSW-K60) > Measurement Basics > Analysis Region
Analysis Region

The analysis region determines which of the captured data is analyzed and displayed on the screen. By default, the entire capture buffer data is defined as the analysis region. However, you can select a specific frequency and time region which is of interest for analysis. The results can then be restricted to this region (see "Evaluation Basis").

Note, however, that only one analysis region can be defined. All result displays that are restricted to the analysis region thus have the same data basis.

Numeric results (displayed in the result or statistics tables) are always calculated based on the analysis region.

For graphical result displays based on the analysis region, the x-axis range corresponds to the analysis region length (see "Time Gate Length").

The analysis region is indicated by a yellow frame in the Full Spectrogram display.

Defining the analysis region
There are two different methods of defining the analysis region:
  • absolute definition: by defining an absolute frequency span and an absolute time gate
    The frequency span is defined by an offset from the center frequency and an analysis bandwidth.
    The time gate is defined by a starting point after measurement begin and the gate length.
  • relative definition: by linking the analysis region to the full capture buffer and defining a percentage of the full bandwidth and measurement time
    The specified frequency offset or time gate start are also considered for relative values.

Both methods can be combined, for example by defining an absolute frequency span and a relative time gate.

Visualization of absolute analysis region parameters
Processing data in the analysis region - data zoom

In result displays restricted to the analysis region, only the data measured for the specified frequency range and within the defined time gate is considered. Furthermore, the analysis region data is taken only from the latest data acquisition, that is, only data that is still in the capture buffer is analyzed.

Restricting the results to an analysis region has the same effect as a data zoom: the results are recalculated for a restricted data base. The data in the capture buffer is filtered by the defined time gate; the measured data within that time span then passes a bandpass filter, so only the frequency range of interest is analyzed. Depending on the selected result display, the data is then demodulated, if necessary, and distributed among the trace points using a detector. The time span displayed per division of the diagram is much smaller compared to the initial full data analysis. Thus, the results of the analysis range become more precise.

Data zoom - full result vs. analysis region result


Measurement Range

Transient Analysis (R&S FSW-K60) > Measurement Basics > Measurement Range
Measurement Range

In order to calculate frequency or power results in frequency hopping or chirped signals more accurately, it may be useful not to take the entire dwell time of the hop (or length of the chirp) into consideration, but only a certain range within the dwell time/length. Thus, it is possible to eliminate settling effects, for instance. For such cases, a measurement range can be defined for power and frequency results, in relation to specific hop or chirp characteristics.

Measurement range parameters for hopped signals

Similarly, for chirped signals, a measurement range can be defined for the corresponding parameters.

Measurement range parameters for chirped signals

Each range is defined by a reference point, an offset, and the range length. The reference point can be either the center or either edge of the hop/chirp, or a point defined by an offset to one of these characteristic points. The range is then centered around this reference point.

Example:

In figure "Measurement range parameters for hopped signals", the indicated measurement range could be defined by the following parameters, for example:

  • "Reference": Hop End
  • "Offset":-x
  • "Alignment": right
  • "Length": L
Measurement range vs result range

While the measurement range defines which part of the hop/chirp is used for individual calculations, the result range determines which part is displayed on the screen in the form of AM, FM or PM vs. time traces (see also "Result Range").


Trace Evaluation

Transient Analysis (R&S FSW-K60) > Measurement Basics > Trace Evaluation
Trace Evaluation

Traces in graphical result displays based on the defined result range (see "Result Range") can be configured, for example to perform statistical evaluations over the selected hop/chirp or all hops/chirps.

You can configure up to 6 individual traces for the following result displays (see "Evaluation Methods for Transient Analysis"):
  • "RF Power Time Domain"
  • "FM Time Domain"
  • "Frequency Deviation Time Domain"
  • "PM Time Domain"
  • "PM Time Domain (Wrapped)"
  • "Chirp Rate Time Domain"

Find out more about trace evaluation:

Contents
  • Mapping Samples to Measurement Points with the Trace Detector
  • Analyzing Several Traces - Trace Mode
  • Trace Statistics


Mapping Samples to Measurement Points with the Trace Detector

Transient Analysis (R&S FSW-K60) > Measurement Basics > Trace Evaluation > Mapping Samples to Measurement Points with the Trace Detector
Mapping Samples to Measurement Points with the Trace Detector

A trace displays the values measured at the measurement points. The number of samples taken during a measurement is much larger than the number of measurement points that are displayed in the measurement trace.

Obviously, a data reduction must be performed to determine which of the samples are displayed for each measurement point. This is the trace detector's task.

The trace detector can analyze the measured data using various methods:

The detector activated for the specific trace is indicated in the corresponding trace information by an abbreviation.

Detector types

Detector

Abbrev.

Description

Positive Peak

Pk

Determines the largest of all positive peak values of the levels measured at the individual frequencies which are displayed in one sample point

Negative Peak

Mi

Determines the smallest of all negative peak values of the levels measured at the individual frequencies which are displayed in one sample point

Auto Peak

Ap

Combines the peak detectors; determines the maximum and the minimum value of the levels measured at the individual frequencies which are displayed in one sample point

RMS

Rm

Calculates the root mean square of all samples contained in a measurement point.

The RMS detector supplies the power of the signal irrespective of the waveform (CW carrier, modulated carrier, white noise or impulsive signal). Correction factors as needed for other detectors to measure the power of the different signal classes are not required.

Average

Av

Calculates the linear average of all samples contained in a measurement point.

To this effect, R&S FSW uses the linear voltage after envelope detection. The sampled linear values are summed up and the sum is divided by the number of samples (= linear average value). For logarithmic display the logarithm is formed from the average value. For linear display the average value is displayed. Each measurement point thus corresponds to the average of the measured values summed up in the measurement point.

The average detector supplies the average value of the signal irrespective of the waveform (CW carrier, modulated carrier, white noise or impulsive signal).

Sample

Sa

Selects the last measured value of the levels measured at the individual frequencies which are displayed in one sample point; all other measured values for the frequency range are ignored

The result obtained from the selected detector for a measurement point is displayed as the value at this x-axis point in the trace.

The trace detector for the individual traces can be selected manually by the user or set automatically by the R&S FSW.

The detectors of the R&S FSW are implemented as pure digital devices. All detectors work in parallel in the background, which means that the measurement speed is independent of the detector combination used for different traces.

Auto detector

If the R&S FSW is set to define the appropriate detector automatically, the detector is set depending on the selected trace mode:

Trace mode | Detector
Clear Write | Auto Peak
Max Hold | Positive Peak
Min Hold | Negative Peak
Average | Sample Peak
View | –
Blank | –


Analyzing Several Traces - Trace Mode

Transient Analysis (R&S FSW-K60) > Measurement Basics > Trace Evaluation > Analyzing Several Traces - Trace Mode
Analyzing Several Traces - Trace Mode

If several measurements are performed one after the other, or continuous measurements are performed, the trace mode determines how the data for subsequent traces is processed. After each measurement, the trace mode determines whether:

  • the data is frozen (View)
  • the data is hidden (Blank)
  • the data is replaced by new values (Clear Write)
  • the data is replaced selectively (Max Hold, Min Hold, Average)

Each time the trace mode is changed, the selected trace memory is cleared.

The trace mode also determines the detector type if the detector is set automatically, see "Mapping Samples to Measurement Points with the Trace Detector".

The R&S FSW offers the following trace modes:

Overview of available trace modes

Trace Mode

Description

Blank

Hides the selected trace.

Clear Write

Overwrite mode: the trace is overwritten by each measurement. This is the default setting.

All available detectors can be selected.

Max Hold

The maximum value is determined over several measurements and displayed. The R&S FSW saves the measurement result in the trace memory only if the new value is greater than the previous one.

This mode is especially useful with modulated or pulsed signals. The signal spectrum is filled up upon each measurement until all signal components are detected in a kind of envelope.

Min Hold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the measurement result in the trace memory only if the new value is lower than the previous one.

This mode is useful e.g. for making an unmodulated carrier in a composite signal visible. Noise, interference signals or modulated signals are suppressed, whereas a CW signal is recognized by its constant level.

Average

The average is formed over several measurements and displayed. The "Sweep/Average Count" determines the number of averaging procedures.

(See also "Trace Statistics".)

View

The current contents of the trace memory are frozen and displayed.

If a trace is frozen ("View" mode), the instrument settings, apart from level range and reference level (see below), can be changed without impact on the displayed trace. The fact that the displayed trace no longer matches the current instrument setting is indicated by the [image] icon on the tab label.

If the level range or reference level is changed, the R&S FSW automatically adapts the trace data to the changed display range. This allows an amplitude zoom to be made after the measurement in order to show details of the trace.


Trace Statistics

Transient Analysis (R&S FSW-K60) > Measurement Basics > Trace Evaluation > Trace Statistics
Trace Statistics

Each trace represents an analysis of the data measured in one result range. As described in "Analyzing Several Traces - Trace Mode", statistical evaluations can be performed over several traces, that is, result ranges. Which ranges and how many are evaluated depends on the configuration settings.

Selected hop/chirp vs all hops/chirps

The "Sweep/Average Count" determines how many measurements are evaluated.

For each measurement, in turn, either the selected hop/chirp only (that is: one result range), or all detected hops/chirps (that is: possibly several result ranges) can be included in the statistical evaluation.

Thus, the overall number of averaging steps depends on the "Sweep/Average Count" and the statistical evaluation mode.

Trace statistics - number of averaging steps


Transient Analysis in MSRA/MSRT Mode

Transient Analysis (R&S FSW-K60) > Measurement Basics > Transient Analysis in MSRA/MSRT Mode
Transient Analysis in MSRA/MSRT Mode

The R&S FSW Transient Analysis application can also be used to analyze data in MSRA or MSRT operating mode. The main difference between the two modes is that in MSRA mode, an I/Q analyzer performs data acquisition, while in MSRT mode, a realtime measurement is performed to capture data.

In MSRA/MSRT operating mode, only the MSRA/MSRT Master actually captures data; the MSRA/MSRT applications receive an extract of the captured data for analysis, referred to as the application data. For the R&S FSW Transient Analysis application in MSRA/MSRT operating mode, the application data range is defined by the same settings used to define the signal capture in Signal and Spectrum Analyzer mode. In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the application data for transient analysis. The "Capture Buffer" displays show the application data of the R&S FSW Transient Analysis application in MSRA/MSRT mode.

Data acquisition in MSRT mode

By default, the R&S FSW Transient Analysis application uses the largest possible measurement bandwidth. Depending on which bandwidth extension options are installed (if any), this may be up to 500 MHz. However, in MSRT mode a maximum of 160 MHz bandwidth is available. Thus, you must ensure the measurement bandwidth for Transient Analysis is available in MSRT mode. Otherwise you will not obtain useful results.

Data coverage for each active application

Generally, if a signal contains multiple data channels for multiple standards, separate applications are used to analyze each data channel. Thus, it is of interest to know which application is analyzing which data channel. The MSRA/MSRT Master display indicates the data covered by each application by vertical blue lines labeled with the application name.

Analysis interval

However, the individual result displays of the application need not analyze the complete data range. The data range that is actually analyzed by the individual result display is referred to as the analysis interval.

In the R&S FSW Transient Analysis application the analysis interval is automatically determined according to the analysis region settings, as in Signal and Spectrum Analyzer mode. The currently used analysis interval (in seconds, related to capture buffer start) is indicated in the window header for each result display.

Analysis line

A frequent question when analyzing multi-standard signals is how each data channel is correlated (in time) to others. Thus, an analysis line has been introduced. The analysis line is a common time marker for all MSRA applications. It can be positioned in any MSRA application or the MSRA Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations.

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, slot or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether or not the analysis line lies within the analysis interval or not:

  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval
Analysis line in R&S FSW Transient Analysis application

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .


Measurement Results

Transient Analysis (R&S FSW-K60) > Measurement Results
Measurement Results

The data that was measured by the R&S FSW can be evaluated using various different methods.

Basis of evaluation
For some displays you can define whether the results are calculated for:
  • the entire capture buffer
  • the selected analysis region
  • a selected individual chirp or hop (for options R&S FSW-K60C/-K60H)
Example for different data sources for the same result display (Spectrogram)

The data source for each result display is selected in the MEAS menu. It is indicated in the description of the individual result displays.

For details on the analysis region see "Analysis Region".

Measurement range vs result range

The measurement range defines which part of a hop/chirp is used for calculation (for example for frequency estimation), whereas the result range determines which data is displayed on the screen in the form of AM, FM or PM vs. time traces.

Exporting Table Results to an ASCII File

Measurement result tables can be exported to an ASCII file for further evaluation in other (external) applications.

For step-by-step instructions on how to export a table, see "How to Export Table Data".

Contents
  • Hop Parameters
  • Chirp Parameters
  • Evaluation Methods for Transient Analysis


Hop Parameters

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters
Hop Parameters

If the R&S FSW-K60H option is installed, various hop parameters can be determined during transient analysis.

The hop parameters to be measured are based primarily on the IEEE 181 Standard 181-2003. For detailed descriptions refer to the standard documentation ("IEEE Standard on Transitions, hops, and Related Waveforms", from the IEEE Instrumentation and Measurement (I&M) Society, 7 July 2003).

The following graphic illustrates the main hop parameters and characteristic values. (For a definition of the values used to determine the measured hop parameters see "Frequency Hopping".)

Definition of the main hop parameters and characteristic values

In order to obtain these results, select the corresponding parameter in the result configuration (see "Table Configuration") or apply the required SCPI parameter to the remote command (see "Table Configuration" and "Retrieving Information on Detected Hops").

Hop ID and Hop number

Each individual hop can be identified by a timestamp which corresponds to the absolute time the beginning of the hop was detected. In addition, each hop is provided with a consecutive number, which starts at 1 for each new measurement. This is useful to distinguish hops in a measurement quickly.

Remote command:

[SENSe:​]HOP:​ID?

[SENSe:​]HOP:​NUMBer?

└ State Index
└ Hop Begin
└ Dwell Time
└ Switching Time
└ Average Frequency
└ Hop State Deviation
└ Frequency Deviation (Peak)
└ Frequency Deviation (RMS)
└ Frequency Deviation (Average)
└ Average Power


State Index

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters > State Index
State Index

The nominal frequency levels are numbered consecutively in the "Hop States" table (see "Signal Detection (Signal States)"), starting at 0. The state of a detected hop is defined as the index of the corresponding nominal frequency.

Remote command:

CALCulate:​HOPDetection:​TABLe:​RESults?

[SENSe:​]HOP:​STATe?


Hop Begin

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters > Hop Begin
Hop Begin

The relative time (in ms) from the capture start at which the signal first enters the tolerance area of a nominal hop (within the analysis region). The tolerance area is defined by the settling tolerance above and below the defined nominal hop frequencies.

Remote command:

CALCulate:​HOPDetection:​TABLe:​RESults?

[SENSe:​]HOP:​TIMing:​BEGin?


Dwell Time

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters > Dwell Time
Dwell Time

The duration of a hop from begin to end, that is, the time the signal remains in the tolerance area of a nominal hop frequency.

Remote command:

CALCulate:​HOPDetection:​TABLe:​RESults?

[SENSe:​]HOP:​TIMing:​DWELl?


Switching Time

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters > Switching Time
Switching Time

The time the signal requires to "hop" from one level to the next. It is defined as the time between a hop end and the following hop begin. The first switching time result can only be determined after the first hop has been detected.

Remote command:

CALCulate:​HOPDetection:​TABLe:​RESults?

[SENSe:​]HOP:​TIMing:​SWITching?


Average Frequency

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters > Average Frequency
Average Frequency

Average frequency measured within the frequency measurement range of the hop (see "Hop / Chirp Measurement Settings ").

Remote command:

CALCulate:​HOPDetection:​TABLe:​RESults?

[SENSe:​]HOP:​FREQuency:​FREQuency?


Hop State Deviation

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters > Hop State Deviation
Hop State Deviation

Deviation of the hop frequency from the nominal hop state frequency

Remote command:

CALCulate:​HOPDetection:​TABLe:​RESults?

[SENSe:​]HOP:​FREQuency:​FMERror?


Frequency Deviation (Peak)

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters > Frequency Deviation (Peak)
Frequency Deviation (Peak)

Maximum of Frequency Deviation vs Time trace

The deviation is calculated within the frequency measurement range of the chirp (see "Hop / Chirp Measurement Settings ").

Remote command:

CALCulate:​HOPDetection:​TABLe:​RESults?

[SENSe:​]HOP:​FREQuency:​MAXFm?


Frequency Deviation (RMS)

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters > Frequency Deviation (RMS)
Frequency Deviation (RMS)

RMS of Frequency Deviation vs Time trace

Remote command:

CALCulate:​HOPDetection:​TABLe:​RESults?

[SENSe:​]HOP:​FREQuency:​RMSFm?


Frequency Deviation (Average)

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters > Frequency Deviation (Average)
Frequency Deviation (Average)

Average of Frequency Deviation vs Time trace

Remote command:

CALCulate:​HOPDetection:​TABLe:​RESults?

[SENSe:​]HOP:​FREQuency:​AVGFm?


Average Power

Transient Analysis (R&S FSW-K60) > Measurement Results > Hop Parameters > Average Power
Average Power

Average power level measured during a hop. Which part of the hop precisely is used for calculation depends on the power parameters in the "Power" measurement range settings (see "Hop / Chirp Measurement Settings ").

Remote command:

CALCulate:​HOPDetection:​TABLe:​RESults?

[SENSe:​]HOP:​POWer:​AVEPower?


Chirp Parameters

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters
Chirp Parameters

If the additional option R&S FSW-K60C is installed, various chirp parameters can be determined during transient analysis.

The chirp parameters to be measured are very similar to the hop parameters; however, some values are based on the chirp rather than a frequency, so the resulting unit is Hz/μs.

The following graphic illustrates the main chirp parameters and characteristic values. (For a definition of the values used to determine the measured chirp parameters see "Frequency Chirping".)

Definition of the main chirp parameters and characteristic values

In order to obtain these results, select the corresponding parameter in the result configuration (see "Table Configuration") or apply the required SCPI parameter to the remote command (see "Table Configuration" and "Retrieving Information on Detected Hops").

Chirp ID and Chirp number

Each individual chirp can be identified by a timestamp which corresponds to the absolute time the beginning of the chirp was detected. In addition, each chirp is provided with a consecutive number, which starts at 1 for each new measurement. This is useful to distinguish chirps in a measurement quickly.

Remote commands:

[SENSe:​]CHIRp:​ID?

[SENSe:​]CHIRp:​NUMBer?

└ State Index
└ Chirp Begin
└ Chirp Length
└ Chirp Rate
└ Chirp State Deviation
└ Average Frequency
└ Frequency Deviation (Peak)
└ Frequency Deviation (RMS)
└ Frequency Deviation (Average)
└ Average Power


State Index

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters > State Index
State Index

The nominal chirps are numbered consecutively in the "Chirp States" table (see "Signal Detection (Signal States)"), starting at 0. The state of a detected chirp is defined as the index of the corresponding nominal chirp frequency.

Remote command:

CALCulate:​CHRDetection:​TABLe:​RESults?

[SENSe:​]CHIRp:​STATe?


Chirp Begin

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters > Chirp Begin
Chirp Begin

Time offset from the analyis region start at which the signal first enters the tolerance area of a nominal chirp. The tolerance area is defined by the settling tolerance above and below the defined nominal chirps.

Remote command:

CALCulate:​CHRDetection:​TABLe:​RESults?

[SENSe:​]CHIRp:​TIMing:​BEGin?


Chirp Length

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters > Chirp Length
Chirp Length

The duration of a chirp from begin to end, that is, the time the signal remains in the tolerance area of a nominal chirp.

Remote command:

CALCulate:​CHRDetection:​TABLe:​RESults?

[SENSe:​]CHIRp:​TIMing:​LENGth?


Chirp Rate

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters > Chirp Rate
Chirp Rate

Derivative of the FM vs time trace within the frequency measurement range (see "Hop / Chirp Measurement Settings ").

Remote command:

CALCulate:​CHRDetection:​TABLe:​RESults?

[SENSe:​]CHIRp:​TIMing:​RATE?


Chirp State Deviation

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters > Chirp State Deviation
Chirp State Deviation

Deviation of the detected chirp rate from the nominal chirp state (in kHz/us).

Remote command:

CALCulate:​CHRDetection:​TABLe:​RESults?

[SENSe:​]CHIRp:​FREQuency:​CHERror?


Average Frequency

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters > Average Frequency
Average Frequency

Average frequency measured within the frequency measurement range of the chirp (see "Hop / Chirp Measurement Settings ").

Remote command:

CALCulate:​CHRDetection:​TABLe:​RESults?

[SENSe:​]CHIRp:​FREQuency:​FREQuency?


Frequency Deviation (Peak)

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters > Frequency Deviation (Peak)
Frequency Deviation (Peak)

Maximum of Frequency Deviation vs Time trace.

The deviation is calculated within the frequency measurement range of the chirp (see "Hop / Chirp Measurement Settings ").

Remote command:

CALCulate:​CHRDetection:​TABLe:​RESults?

[SENSe:​]CHIRp:​FREQuency:​MAXFm?


Frequency Deviation (RMS)

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters > Frequency Deviation (RMS)
Frequency Deviation (RMS)

RMS of Frequency Deviation vs Time trace. The deviation is calculated within the frequency measurement range of the chirp (see "Hop / Chirp Measurement Settings ").

Remote command:

CALCulate:​CHRDetection:​TABLe:​RESults?

[SENSe:​]CHIRp:​FREQuency:​RMSFm?


Frequency Deviation (Average)

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters > Frequency Deviation (Average)
Frequency Deviation (Average)

Average of Frequency Deviation vs Time trace. The deviation is calculated within the frequency measurement range of the chirp (see "Hop / Chirp Measurement Settings ").

Remote command:

CALCulate:​CHRDetection:​TABLe:​RESults?

[SENSe:​]CHIRp:​FREQuency:​AVGFm?


Average Power

Transient Analysis (R&S FSW-K60) > Measurement Results > Chirp Parameters > Average Power
Average Power

Average power level measured during a chirp. Which part of the chirp precisely is used for calculation depends on the power parameters in the "Power" measurement range configuration (see "Hop / Chirp Measurement Settings ").

Remote command:

CALCulate:​CHRDetection:​TABLe:​RESults?

[SENSe:​]CHIRp:​POWer:​AVEPower?


Evaluation Methods for Transient Analysis

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis
Evaluation Methods for Transient Analysis

The data that was measured by the R&S FSW can be evaluated using various different methods, depending on the measurement task.

Available evaluation methods and evaluation basis
Measurement task | Evaluation | Evaluation basis
Frequency domain analysis | "RF Spectrum" | Full capture buffer Analysis region Individual hop / chirp*)
Time domain analysis | "RF Power Time Domain" "PM Time Domain" "FM Time Domain" "PM Time Domain (Wrapped)" chirp vs. time | Full capture buffer Analysis region Individual hop / chirp*)
Joint time / frequency analysis | "Spectrogram" | Full capture buffer Analysis region Individual hop / chirp *)
Demodulation quality analysis | "Frequency Deviation Time Domain" *) | Analysis region Individual hop / chirp
Signal characteristics | "Hop/Chirp Results Table" *) "Hop/Chirp Statistics Table" *) | Analysis region
Online I/Q data transfer analysis | "RF Spectrum" "Spectrogram" "RF Power Time Domain" "PM Time Domain" "FM Time Domain" "PM Time Domain (Wrapped)" | Full capture buffer
*) requires additional option R&S FSW-K60C/-K60H

All evaluation modes available for Transient Analysis are displayed in the selection bar in SmartGrid mode.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

By default, the Transient Analysis results are displayed in the following windows:

  • RF Spectrum (full capture buffer)
  • FM Time Domain (analysis region)
  • Spectrogram (full capture buffer)
  • RF Power Time Domain (analysis region)
If the additional options R&S FSW-K60C/-K60H are installed, the default result displays are:
  • RF Spectrum (full capture buffer)
  • FM Time Domain (analysis region)
  • Spectrogram (full capture buffer)
  • Frequency Deviation Time Domain (hop/chirp)
  • Hop/Chirp Result Table (analysis region)

The following evaluation methods are available for Transient Analysis:

└ RF Spectrum
└ Spectrogram
└ RF Power Time Domain
└ FM Time Domain
└ Frequency Deviation Time Domain
└ PM Time Domain
└ PM Time Domain (Wrapped)
└ Marker Table
└ Chirp Rate Time Domain
└ Hop/Chirp Results Table
└ Hop/Chirp Statistics Table


RF Spectrum

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > RF Spectrum
RF Spectrum

The RF Spectrum diagram displays the measured power levels for the detected hops/chirps. The displayed data corresponds to one particular frame in the spectrogram. During a running measurement, the most recently captured frame is always displayed. During analysis, which frame is displayed depends on the selected frame in the spectrogram configuration (see "Selecting a frame to display") or the marker position in the spectrogram (see "Frame").

Thus, the RF Spectrum is useful to analyze the input signal measured at a specific time in more detail.

Remote command:

LAY:ADD? '1',RIGH, RFSP, see LAYout:​ADD[:​WINDow]?


Spectrogram

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > Spectrogram
Spectrogram

The spectrogram is a way of displaying multiple consecutive spectra over time. The power, or more exactly the power level, which is usually displayed over frequency, is displayed over frequency and time. Thus, joint analysis in the time and frequency domain is possible.

Graphically, time and frequency represent the vertical and horizontal axes of the diagram. Each coordinate (frequency f, time t) of the diagram is filled with a color representing the level for the respective frequency and time.

At the beginning of a measurement, the diagram is empty. As the measurement advances, the graph is filled line by line from top to bottom. Lines in the spectrogram are called frames, as each frame represents one spectrum.

As the graph fills from top to bottom, the latest spectrum is always the topmost line, whereas older frames move towards the bottom. However, older frames that have disappeared from the visible display area can be returned to view by selecting a particular frame or timestamp.

Spectrogram of a frequency hopper

Spectrograms are highly configurable. In particular, the number of frames and the colors used to display the power levels can be defined by the user.

Spectrograms are particularly useful in combination with a spectrum display. In this case, the spectogram provides an overview of events over time, whereas the spectrum provides details for a specific frame.

For more information on working with spectrograms see "Measurement Basics".

Remote command:

LAY:ADD? '1',RIGH, SGR, see LAYout:​ADD[:​WINDow]?


RF Power Time Domain

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > RF Power Time Domain
RF Power Time Domain

Displays the RF power (in dBm) versus time. Detected hops are indicated by green bars along the x-axis. The currently selected hop/chirp is highlighted in blue.

The RF Power Time Domain trace is determined as follows:

Remote command:

LAY:ADD? '1',RIGH,RFPT, see LAYout:​ADD[:​WINDow]?)


FM Time Domain

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > FM Time Domain
FM Time Domain

Displays the frequency of the demodulated FM signal versus time.

The FM time domain trace is determined as follows:

Remote command:

LAY:ADD? '1',RIGH,FMT, see LAYout:​ADD[:​WINDow]?)


Frequency Deviation Time Domain

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > Frequency Deviation Time Domain
Frequency Deviation Time Domain

Displays the frequency error of the demodulated FM signal versus time.

This display requires additional option R&S FSW-K60C/-K60H.

Note: The frequency error is calculated for complete hops/chirps only. Thus, where no (complete) hops/chirps are available, gaps will occur in the error display.

Frequency Deviation Time Domain display with gaps where no (complete) chirps are detected

The Frequency Deviation for the analysis region in the hop model is calculated as follows:

In the chirp model it is calculated as:

For an individual hop/chirp, k ∈ Result Range

Remote command:

LAY:ADD? '1',RIGH,FMER, see LAYout:​ADD[:​WINDow]?


PM Time Domain

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > PM Time Domain
PM Time Domain

Displays the phase deviations of the demodulated PM signal (in rad or °) versus time.

The PM time domain trace is determined as follows:

Remote command:

LAY:ADD? '1',RIGH,PMT, see LAYout:​ADD[:​WINDow]?)


PM Time Domain (Wrapped)

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > PM Time Domain (Wrapped)
PM Time Domain (Wrapped)

Displays the phase deviations of the wrapped demodulated PM signal (in rad or °) versus time.

Remote command:

LAY:ADD? '1',RIGH,PMWR, see LAYout:​ADD[:​WINDow]?


Marker Table

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Chirp Rate Time Domain

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > Chirp Rate Time Domain
Chirp Rate Time Domain

Displays the chirp rate versus time. This display requires additional option R&S FSW-K60C/-K60H.

The chirp rate time domain trace is determined as follows:

Remote command:

LAY:ADD? '1',RIGH,CRT, see LAYout:​ADD[:​WINDow]?


Hop/Chirp Results Table

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > Hop/Chirp Results Table
Hop/Chirp Results Table

Displays the automatically detected hop/chirp parameters in a table of results. This display requires additional option R&S FSW-K60C/-K60H.

Which parameters are displayed depends on the "Result Configuration" (see "Table Configuration"). The currently selected hop/chirp is highlighted blue. The hops/chirps contained in the current capture buffer are highlighted green.

For details on the individual parameters see "Hop Parameters" or "Chirp Parameters".

Remote command:

LAY:ADD:WIND '2',RIGH,RTAB see LAYout:​ADD[:​WINDow]?


Hop/Chirp Statistics Table

Transient Analysis (R&S FSW-K60) > Measurement Results > Evaluation Methods for Transient Analysis > Hop/Chirp Statistics Table
Hop/Chirp Statistics Table

Displays statistical values (minimum, maximum, average, standard deviation) for the measured hop/chirp parameters in a table of results. This display requires additional option R&S FSW-K60C/-K60H.

Both the current capture buffer data and the cummulated captured data from a series of measurements are evaluated. The statistics computed only from hops/chirps within the current capture buffer are highlighted green. For reference, the measured parameters from the "Select Hop / Select Chirp" are also shown, highlighted blue. The displayed parameters are the same as in the Hop/Chirp Results Table and can be configured in the "Result Configuration" (see "Table Configuration").

For details on the individual parameters see "Hop Parameters" or "Chirp Parameters".

Remote command:

LAY:ADD:WIND '2',RIGH,STAB see LAYout:​ADD[:​WINDow]?


Configuration

Transient Analysis (R&S FSW-K60) > Configuration
Configuration

Transient analysis requires a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you switch a measurement channel to the Transient Analysis application the first time, a set of parameters is passed on from the currently active application (see "Default Settings for Transient Analysis"). After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Transient Analysis in MSRT mode

When you switch to MSRT mode, the Sequencer is automatically activated in Continuous Sequence mode. Since the default trigger mode is "Free Run" and "Auto Rearm", the MSRT Master continuously performs a realtime measurement until it is stopped. During this time, the Sequencer never passes the data on to other MSRT applications and no evaluation is performed in those result displays.

Thus, it is important that you configure a trigger for the MSRT Master, or stop the Sequencer and switch between the Master and the application tabs manually. In this case, the continuous measurement is stopped when you switch tabs. However, you will have to update the subsequent application displays manually, using the "Refresh" functions (see "Refresh"/"Refresh All" ).

For details see "Configuring and Performing Measurements in MSRT Mode" .

When you activate a measurement channel in the Transient Analysis application, a Transient measurement for the input signal is started automatically with the default configuration. The "Meas Config" menu is displayed and provides access to the most important configuration functions.

For a description see
  • "Data Acquisition and Analysis Region"
  • "Signal Detection (Signal States)"
  • "Signal Detection (Signal States)"
  • "FM Video Bandwidth"
  • "Spectrogram Settings"
  • "Result Configuration"
  • "Select Hop / Select Chirp"
  • "Display Configuration"

The MARKER FUNCT and LINES menu are currently not used.

Automatic refresh of preview and visualization in dialog boxes after configuration changes

The R&S FSW supports you in finding the correct measurement settings quickly and easily - after each change in settings in dialog boxes, the preview and visualization areas are updated immediately and automatically to reflect the changes. Thus, you can see if the setting is appropriate or not before closing the dialog.

Contents
  • Default Settings for Transient Analysis
  • Configuration Overview
  • Signal Description
  • Input, Output and Frontend Settings
  • Trigger Settings
  • Data Acquisition and Analysis Region
  • Bandwidth Settings
  • Hop / Chirp Measurement Settings
  • FM Video Bandwidth
  • Hop / Chirp Selection
  • Sweep Settings
  • Adjusting Settings Automatically


Default Settings for Transient Analysis

Transient Analysis (R&S FSW-K60) > Configuration > Default Settings for Transient Analysis
Default Settings for Transient Analysis

When you switch a measurement channel to the Transient Analysis application the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • input coupling
  • YIG filter state

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after a measurement channel has been set to the Transient Analysis application, or after a "Preset Channel":

Default settings for Transient channels
Parameter | Value
Sweep mode | CONTINUOUS
Trigger settings | FREE RUN
Trigger offset | 0
Signal model | none
Measurement bandwidth | maximum possible (depends on installed bandwidth options)
Measurement time | 350 μs
Sample rate | maximum possible (depends on installed bandwidth options)
Analysis region | Entire capture buffer
Evaluations | Window 1: RF Power Time Domain (full capture buffer) Window 2: Spectrogram (full capture buffer)


Configuration Overview

Transient Analysis (R&S FSW-K60) > Configuration > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Signal Description

    See "Signal Description".

  2. Input and frontend settings

    See "Input, Output and Frontend Settings"

  3. Triggering

    See "Trigger Settings"

  4. Data acquisition

    See "Data Acquisition and Analysis Region"

  5. Measurement settings

    See "Hop / Chirp Measurement Settings "

  6. Analysis

    See "Analysis"

  7. Result configuration

    See "Result Configuration"

  8. Display configuration

    See "Display Configuration"

The main configuration settings and dialog boxes are also available via the "Meas Config" menu which is displayed when you press the MEAS CONFIG key.

See also
  • "Signal Description"
  • "Input, Output and Frontend Settings"
  • "Data Acquisition and Analysis Region"
  • "Hop / Chirp Measurement Settings "
  • "Spectrogram Settings"
  • "Result Configuration"
  • "Selecting a frame to display"
  • "Select Hop / Select Chirp"
  • "Display Configuration"
To configure settings
►

Select any button to open the corresponding dialog box.

For step-by-step instructions on configuring a measurement for Transient Analysis, see "How to Perform Transient Analysis".

└ Preset Channel
└ Specifics for


Preset Channel

Transient Analysis (R&S FSW-K60) > Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

For details see "Default Settings for Transient Analysis".

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Specifics for

Transient Analysis (R&S FSW-K60) > Configuration > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Signal Description

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description
Signal Description

The "Signal Description" settings provide information on the expected signal which can improve measurement and analysis.

Contents
  • Signal Model
  • Signal Detection (Signal States)


Signal Model

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Model
Signal Model

The signal model defines which type of signal to expect (if known), thus determining the analysis method. These settings are only available if at least one of the additional options R&S FSW-K60C/-K60H are installed.

└ Hop Model / Chirp Model


Hop Model / Chirp Model

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Model > Hop Model / Chirp Model
Hop Model / Chirp Model

Defines which type of signal to expect (if known), thus determining the analysis method.

These settings are only available if the additional options R&S FSW-K60C/-K60H are installed.

For more information see "Signal Models".

"Hop Model" | Signals "hop" between random carrier frequencies in short intervals
"Chirp Model" | The carrier frequency is either increased or decreased linearly over time.
Remote command:

[SENSe:​]SIGNal:​MODel


Signal Detection (Signal States)

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States)
Signal Detection (Signal States)

The signal detection settings define the conditions under which a hop/chirp is detected within the input signal. These settings are only available if at least one of the additional options R&S FSW-K60C/-K60H are installed.

The (nominal) frequencies or chirps the signal is expected to switch to are defined in advance in the "Signal State" table. Each possible frequency/chirp is considered to be a hop state/chirp state.

The "Signal State" table is available when you do one of the following:
  • From the "Overview", select "Measurement", then switch to the "Signal Detection" tab.
  • From the MEAS CONFIG menu, select "Hop/Chirp Detection Config".

Measurement range settings for frequency and power calculations are described in "Hop / Chirp Measurement Settings ".

For details on the individual parameters see "Frequency Hopping".

└ Auto Mode
└ Hop / Chirp State Index
└ Frequency Offset / Chirp Rate
└ Tolerance
└ Inserting a signal state
└ Deleting a signal state
└ Clearing the signal state table
└ Saving the signal state table
└ Timing
└ Auto Mode
└ Minimum / Maximum


Auto Mode

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Auto Mode
Auto Mode

By default, the R&S FSW Transient Analysis application performs an automatic hop/chirp detection according to the measured data. For an initial overview of the signal at hand this detection is usually sufficient. For more accurate results, particularly if the input signal is known in advance, the signal detection settings can be adapted as required.

For details see "Automatic vs. Manual Hop/Chirp State Detection".

Remote command:

CALCulate:​CHRDetection:​STATes:​AUTO

CALCulate:​HOPDetection:​STATes:​AUTO


Hop / Chirp State Index

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Hop / Chirp State Index
Hop / Chirp State Index

The nominal frequency levels are numbered consecutively in the "Hop States"/"Chirp States" table, starting at 0. The state index of the corresponding nominal frequency level is assigned to each detected hop/chirp in the measured signal.


Frequency Offset / Chirp Rate

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Frequency Offset / Chirp Rate
Frequency Offset / Chirp Rate

The hop states are defined as frequency offsets from the center frequency. Hops are only detected at these frequencies.

Chirp states are defined as a (linear) chirp rate. Chirps are only detected at these chirp rates.

Remote command:

CALCulate:​CHRDetection:​STATes[:​DATA]

CALCulate:​HOPDetection:​STATes[:​DATA]


Tolerance

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Tolerance
Tolerance

A tolerance span can be defined to compensate for settling effects in the signal after switching the frequency. As long as the deviation remains within the tolerance above or below the nominal frequency, the signal state is detected.

Remote command:

CALCulate:​CHRDetection:​STATes[:​DATA]

CALCulate:​HOPDetection:​STATes[:​DATA]


Inserting a signal state

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Inserting a signal state
Inserting a signal state

Inserts an additional signal state before the currently selected state.


Deleting a signal state

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Deleting a signal state
Deleting a signal state

Deletes the currently selected signal state.


Clearing the signal state table

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Clearing the signal state table
Clearing the signal state table

Deletes all signal states in the signal state table.


Saving the signal state table

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Saving the signal state table
Saving the signal state table

Saves the current signal state table configuration.


Timing

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Timing
Timing

The dwell time is the time the signal remains in the tolerance area of a nominal hop frequency, that is, the duration of a hop from beginning to end. A hop is only detected if its dwell time lies within the defined minimum and maximum values.

└ Auto Mode
└ Minimum / Maximum


Auto Mode

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Timing > Auto Mode
Auto Mode

If "Auto Mode" is enabled (default), useful dwell time/chirp length limits for the current measurement are defined automatically.

Otherwise, the manually defined "Minimum / Maximum" values apply.

Remote command:

CALCulate:​CHRDetection:​LENGth:​AUTO

CALCulate:​HOPDetection:​DWELl:​AUTO


Minimum / Maximum

Transient Analysis (R&S FSW-K60) > Configuration > Signal Description > Signal Detection (Signal States) > Timing > Minimum / Maximum
Minimum / Maximum

If "Auto Mode" is disabled, you can define minimum or maximum dwell times, or both, manually, in order to detect only specific hops, for example.

Remote command:

CALCulate:​CHRDetection:​LENGth:​MAXimum

CALCulate:​CHRDetection:​LENGth:​MINimum

CALCulate:​HOPDetection:​DWELl:​MAXimum

CALCulate:​HOPDetection:​DWELl:​MINimum


Input, Output and Frontend Settings

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings
Input, Output and Frontend Settings

The R&S FSW can evaluate signals from different input sources and provide various types of output (such as noise or trigger signals).

The frequency and amplitude settings represent the "frontend" of the measurement setup.

Contents
  • Input Settings
  • Frequency Settings
  • Amplitude Settings
  • Output Settings


Input Settings

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings
Input Settings
Input settings can be configured by doing one of the following:
  • Press the INPUT/OUTPUT key, then select "Input Source Config".
  • In the "Overview", select "Input / Frontend".

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Contents
  • Radio Frequency Input
  • External Mixer Settings


Radio Frequency Input

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is the radio frequency. If no additional options are installed, this is the only available input source.

└ Radio Frequency State
└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector


Radio Frequency State

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input > Radio Frequency State
Radio Frequency State

Activates input from the RF INPUT connector.

Remote command:

INPut:​SELect


Input Coupling

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Remote command:

INPut:​FILTer:​YIG[:​STATe]


External Mixer Settings

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings
External Mixer Settings

The external mixer is configured in the "External Mixer" tab of the "Input" dialog box which is available when you do one of the following, if the R&S FSW-B21 option is installed:

  • Press the INPUT/OUTPUT key, then select the "External Mixer Config" softkey.
  • From the "Overview", select "Input", then switch to the "External Mixer" tab under "Input Source".

Note that external mixers are not supported in MSRA/MSRT mode.

Contents
  • Mixer Settings
  • Basic Settings
  • Managing Conversion Loss Tables
  • Creating and Editing Conversion Loss Tables


Mixer Settings

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings
Mixer Settings

In this tab you configure the band and specific mixer settings.

└ External Mixer State
└ RF Start / RF Stop
└ Handover Freq.
└ Band
└ RF Overrange
└ Preset Band
└ Mixer Type
└ Mixer Settings (Harmonics Configuration)
└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


External Mixer State

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


RF Start / RF Stop

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > RF Start / RF Stop
RF Start / RF Stop

Displays the start and stop frequency of the selected band (read-only).

The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

For details on available frequency ranges see table " Frequency ranges for pre-defined bands".

Remote command:

[SENSe:​]MIXer:​FREQuency:​STARt?

[SENSe:​]MIXer:​FREQuency:​STOP?


Handover Freq.

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Handover Freq.
Handover Freq.

Defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency can be selected freely within the overlapping frequency range.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​FREQuency:​HANDover


Band

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Band
Band

Defines the waveguide band or user-defined band to be used by the mixer.

The start and stop frequencies of the selected band are displayed in the "RF Start" and "RF Stop" fields.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

The mixer settings for the user-defined band can be selected freely. The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND[:​VALue]


RF Overrange

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > RF Overrange
RF Overrange

If enabled, the frequency range is not restricted by the band limits ("RF Start" and "RF Stop"). In this case, the full LO range of the selected harmonics is used.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​RFOVerrange[:​STATe]


Preset Band

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Preset Band
Preset Band

Restores the presettings for the selected band.

Note: changes to the band and mixer settings are maintained even after using the PRESET function. This function allows you to restore the original band settings.

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND:​PRESet


Mixer Type

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Type
Mixer Type

The R&S FSW option B21 supports the following external mixer types:

(See also "Two-port and Three-port Mixers" )

"2 Port" | LO and IF data use the same port
"3 Port" | LO and IF data use separate ports
Remote command:

[SENSe:​]MIXer:​PORTs


Mixer Settings (Harmonics Configuration)

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration)
Mixer Settings (Harmonics Configuration)

The harmonics configuration determines the frequency range for user-defined bands (see "Band").

See also "Frequency Ranges" .

└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


Harmonic Type

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Type
Harmonic Type

Defines if only even, only odd, or even and odd harmonics can be used for conversion. Depending on this selection, the order of harmonic to be used for conversion changes (see "Harmonic Order"). Which harmonics are supported depends on the mixer type.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​TYPE


Range 1/2

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Range 1/2
Range 1/2

Enables the use of a second harmonic to cover the band's frequency range.

For each range you can define which harmonic to use and how the "Conversion loss" is handled.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​HIGH:​STATe


Harmonic Order

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Order
Harmonic Order

Defines which of the available harmonic orders of the LO is used to cover the frequency range.

By default, the lowest order of the specified harmonic type is selected that allows conversion of input signals in the whole band. If due to the LO frequency the conversion is not possible using one harmonic, the band is split.

For the band "USER", the order of harmonic is defined by the user. The order of harmonic can be between 2 and 61, the lowest usable frequency being 26.5 GHz.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic[:​LOW]

[SENSe:​]MIXer:​HARMonic:​HIGH[:​VALue]


Conversion loss

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Conversion loss
Conversion loss

Defines how the conversion loss is handled. The following methods are available:

"Average"

Defines the average conversion loss for the entire range in dB.

"Table"

Defines the conversion loss via the table selected from the list. Predefined conversion loss tables are often provided with the external mixer and can be imported to the R&S FSW. Alternatively, you can define your own conversion loss tables. Imported tables are checked for compatibility with the current settings before being assigned.

Conversion loss tables are configured and managed in the "Managing Conversion Loss Tables" tab.

For details on conversion loss tables, see "Conversion Loss Tables" .

For details on importing tables, see "Import Table".

Remote command:

Average for range 1:

[SENSe:​]MIXer:​LOSS[:​LOW]

Table for range 1:

[SENSe:​]MIXer:​LOSS:​TABLe[:​LOW]

Average for range 2:

[SENSe:​]MIXer:​LOSS:​HIGH

Table for range 2:

[SENSe:​]MIXer:​LOSS:​TABLe:​HIGH


Basic Settings

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings
Basic Settings

The basic settings concern general use of an external mixer. They are only available if the "External Mixer State" is "On".

└ External Mixer State
└ LO Level
└ Signal ID
└ Auto ID
└ Auto ID Threshold
└ Bias Settings
└ Write to <CVL table name>


External Mixer State

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


LO Level

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > LO Level
LO Level

Defines the LO level of the external mixer's LO port. Possible values are from 13.0 dBm to 17.0 dBm in 0.1 dB steps. Default value is 15.5 dB.

Remote command:

[SENSe:​]MIXer:​LOPower


Signal ID

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > Signal ID
Signal ID

Activates or deactivates visual signal identification. Two sweeps are performed alternately. Trace 1 shows the trace measured on the upper side band (USB) of the LO (the test sweep), trace 2 shows the trace measured on the lower side band (LSB), i.e. the reference sweep.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

(See also "Automatic Signal Identification" ).

Mathematical functions with traces and trace copy cannot be used with the Signal ID function.

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > Auto ID
Auto ID

Activates or deactivates automatic signal identification.

Auto ID basically functions like "Signal ID". However, the test and reference sweeps are converted into a single trace by a comparison of maximum peak values of each sweep point. The result of this comparison is displayed in trace 3 if "Signal ID" is active at the same time. If "Signal ID" is not active, the result can be displayed in any of the traces 1 to 3. Unwanted mixer products are suppressed in this calculated trace.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID Threshold

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > Auto ID Threshold
Auto ID Threshold

Defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison ("Auto ID" function). The input range is between 0.1 dB and 100 dB. Values of about 10 dB (i.e. default setting) generally yield satisfactory results.

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​THReshold


Bias Settings

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > Bias Settings
Bias Settings

Define the bias current for each range, which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

The trace is adapted to the settings immediately so you can check the results. To store the bias setting in the currently selected conversion loss table, select the "Write to <CVL table name>" button.

Remote command:

[SENSe:​]MIXer:​BIAS[:​LOW]

[SENSe:​]MIXer:​BIAS:​HIGH

└ Write to <CVL table name>


Write to <CVL table name>

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > Bias Settings > Write to <CVL table name>
Write to <CVL table name>

Stores the bias setting in the currently selected "Conversion loss table" for the range (see "Managing Conversion Loss Tables"). If no conversion loss table is selected yet, this function is not available ("CVL Table not selected").

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Managing Conversion Loss Tables

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables
Managing Conversion Loss Tables

In this tab you configure and manage conversion loss tables. Conversion loss tables consist of value pairs that describe the correction values for conversion loss at certain frequencies. The correction values for frequencies between the reference points are obtained via interpolation.

The currently selected table for each range is displayed at the top of the dialog box. All conversion loss tables found in the instrument's C:\r_s\instr\user\cvl\ directory are listed in the "Modify Tables" list.

└ External Mixer State
└ New Table
└ Edit Table
└ Delete Table
└ Import Table


External Mixer State

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


New Table

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables > New Table
New Table

Opens the "Edit Conversion loss table" dialog box to configure a new conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Edit Table

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables > Edit Table
Edit Table

Opens the "Edit Conversion loss table" dialog box to edit the selected conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Delete Table

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables > Delete Table
Delete Table

Deletes the currently selected conversion loss table after you confirm the action.

Remote command:

[SENSe:​]CORRection:​CVL:​CLEAr


Import Table

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables > Import Table
Import Table

Imports a stored conversion loss table from any directory and copies it to the instrument's C:\r_s\instr\user\cvl\ directory. It can then be assigned for use for a specific frequency range (see "Conversion loss").

For details see "Conversion Loss Tables" .


Creating and Editing Conversion Loss Tables

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables
Creating and Editing Conversion Loss Tables

Conversion loss tables can be defined and edited in the "Edit conversion loss table" dialog box which is displayed when you select the "New Table" button in the "External Mixer > Conversion loss table" settings.

A preview pane displays the current configuration of the conversion loss function as described by the position/value entries.

└ File Name
└ Comment
└ Band
└ Harmonic Order
└ Bias
└ Mixer Name
└ Mixer S/N
└ Mixer Type
└ Position/Value
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


File Name

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > File Name
File Name

Defines the name under which the table is stored in the C:\r_s\instr\user\cvl\ directory on the instrument. The name of the table is identical with the name of the file (without extension) in which the table is stored. This setting is mandatory. The .ACL extension is automatically appended during storage.

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Comment

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Comment
Comment

An optional comment that describes the conversion loss table. The comment can be freely defined by the user.

Remote command:

[SENSe:​]CORRection:​CVL:​COMMent


Band

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Band
Band

The waveguide or user-defined band for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

Remote command:

[SENSe:​]CORRection:​CVL:​BAND


Harmonic Order

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Harmonic Order
Harmonic Order

The harmonic order of the range for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​HARMonic


Bias

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Bias
Bias

The bias current which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

Tip: You can also define the bias interactively while a preview of the trace with the changed setting is displayed, see "Bias Settings".

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Mixer Name

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Name
Mixer Name

Specifies the name of the external mixer for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​MIXer


Mixer S/N

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer S/N
Mixer S/N

Specifies the serial number of the external mixer for which the table is to be applied.

This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​SNUMber


Mixer Type

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Type
Mixer Type

Specifies whether the external mixer for which the table is to be applied is a two-port or three-port type. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​PORTs


Position/Value

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Position/Value
Position/Value

Each position/value pair defines the correction value for conversion loss for a specific frequency. The reference values must be entered in order of increasing frequencies. A maximum of 50 reference values can be entered. To enter a new value pair, select the "Position/Value" table, or select the "Insert Value" button.

Correction values for frequencies between the reference values are obtained by interpolation. Linear interpolation is performed if the table contains only two values. If it contains more than two reference values, spline interpolation is carried out. Outside the frequency range covered by the table the conversion loss is assumed to be the same as that for the first and last reference value.

(See "Conversion Loss Tables" .)

The current configuration of the conversion loss function as described by the position/value entries is displayed in the preview pane to the right of the table.

Remote command:

[SENSe:​]CORRection:​CVL:​DATA


Insert Value

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Insert Value
Insert Value

Inserts a new position/value entry in the table.

If the table is empty, a new entry at 0 Hz is inserted.

If entries already exist, a new entry is inserted above the selected entry. The position of the new entry is selected such that it divides the span to the previous entry in half.


Delete Value

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Delete Value
Delete Value

Deletes the currently selected position/value entry.


Shift x

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift x
Shift x

Shifts all positions in the table by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the x-axis.


Shift y

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift y
Shift y

Shifts all conversion loss values by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the y-axis.


Save

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Save
Save

The conversion loss table is stored under the specified name in the C:\r_s\instr\user\cvl\ directory of the instrument.


Frequency Settings

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Frequency Settings
Frequency Settings

Frequency settings for the input signal can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
  • Select the "Frequency" tab in the "Input Settings" dialog box
└ Center frequency
└ Center Frequency Stepsize
└ Frequency Offset
└ Delta Frequency


Center frequency

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Frequency Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Center Frequency Stepsize

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Note: In MSRA/MSRT mode, this function is only available for the MSRA/MSRT Master.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Delta Frequency

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Frequency Settings > Delta Frequency
Delta Frequency

Defines the center of the frequency span for the analysis region. It is defined as an offset from the center frequency.

See "Analysis Region" for details.

Remote command:

CALCulate:​AR:​FREQuency:​DELTa


Amplitude Settings

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Amplitude Settings
Amplitude Settings

Amplitude settings affect the signal power or error levels.

To configure the amplitude settings do one of the following:

  • Select "Input/Frontend" from the "Overview", then switch to the "Amplitude" tab.
  • Select the AMPT key and then the "Amplitude Config" softkey.

The scaling settings are described in "Y-Axis Scaling".

The unit settings are described in "Units".

Note that amplitude settings are not window-specific, as opposed to the scaling and unit settings.

└ Reference Level
└ Shifting the Display (Offset)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling


Reference Level

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Amplitude Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display.

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)


Shifting the Display (Offset)

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


RF Attenuation

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the mechanical attenuation for RF input.

└ Attenuation Mode / Value


Attenuation Mode / Value

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Amplitude Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling


Preamplifier (option B24)

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Output Settings

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Noise Source

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Trigger 2/3

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Output Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Output Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Output Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Output Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

Transient Analysis (R&S FSW-K60) > Configuration > Input, Output and Frontend Settings > Output Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Trigger Settings

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured.

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. Thus, no trigger settings are available in the Transient Analysis application in MSRA/MSRT operating mode. However, a capture offset can be defined with a similar effect as a trigger offset. It defines an offset from the start of the captured data (from the MSRA/MSRT Master) to the start of the application data for transient analysis. (See "Capture Offset".)

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

└ Trigger Settings
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ IF Power
└ I/Q Power
└ RF Power
└ Trigger Level
└ Drop-Out Time
└ Trigger Offset
└ Slope
└ Hysteresis
└ Trigger Holdoff
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger
└ Capture Offset


Trigger Settings

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings
Trigger Settings

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ IF Power
└ I/Q Power
└ RF Power
└ Trigger Level
└ Drop-Out Time
└ Trigger Offset
└ Slope
└ Hysteresis
└ Trigger Holdoff


Trigger Source

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Note: When triggering is activated, the squelch function is automatically disabled.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ IF Power
└ I/Q Power
└ RF Power


Free Run

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)" ).

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel.
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel.
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


IF Power

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Trigger Source > IF Power
IF Power

The R&S FSW starts capturing data as soon as the trigger level is exceeded around the third intermediate frequency.

This trigger source is only available for RF input.

For frequency sweeps, the third IF represents the start frequency. The trigger bandwidth at the third IF depends on the RBW and sweep type.

For measurements on a fixed frequency (e.g. zero span or I/Q measurements), the third IF represents the center frequency.

The available trigger levels depend on the RF attenuation and preamplification. A reference level offset, if defined, is also considered.

For details on available trigger levels and trigger bandwidths see the data sheet.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce


I/Q Power

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Trigger Source > I/Q Power
I/Q Power

This trigger source is not available if the optional Digital Baseband Interface (R&S FSW-B17) or Analog Baseband Interface (R&S FSW-B71) is used for input. It is also not available for analysis bandwidths ≥ 160 MHz.

Triggers the measurement when the magnitude of the sampled I/Q data exceeds the trigger threshold.

Remote command:

TRIG:SOUR IQP, see TRIGger[:​SEQuence]:​SOURce


RF Power

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Trigger Source > RF Power
RF Power

Defines triggering of the measurement via signals which are outside the displayed measurement range.

For this purpose the instrument uses a level detector at the first intermediate frequency. The input signal must be in the frequency range between 500 MHz and 8 GHz.

The resulting trigger level at the RF input depends on the RF attenuation and preamplification. For details on available trigger levels see the data sheet.

Note: If the input signal contains frequencies outside of this range (e.g. for fullspan measurements), the sweep may be aborted and a message indicating the allowed input frequencies is displayed in the status bar.

A "Trigger Offset", "Trigger Polarity" and "Trigger Holdoff" (to improve the trigger stability) can be defined for the RF trigger, but no "Hysteresis".

Remote command:

TRIG:SOUR RFP, see TRIGger[:​SEQuence]:​SOURce


Trigger Level

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Trigger Level
Trigger Level

Defines the trigger level for the specified trigger source.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]


Drop-Out Time

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Trigger Offset

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

Note: In MSRA/MSRT mode, the trigger offset defines the start of the sweep only for the MSRA/MSRT Master. For MSRA/MSRT applications, use the "Capture Offset" instead.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger)
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Slope

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Hysteresis

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Trigger Settings > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Capture Offset

Transient Analysis (R&S FSW-K60) > Configuration > Trigger Settings > Capture Offset
Capture Offset

This setting is only available for applications in MSRA or MSRT operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

In MSRT mode, the offset may be negative if a pretrigger time is defined.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Remote command:

[SENSe:​]MSRA:​CAPTure:​OFFSet

[SENSe:​]RTMS:​CAPTure:​OFFSet


Data Acquisition and Analysis Region

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region
Data Acquisition and Analysis Region

You must define how much and how data is captured from the input signal, and which part of the captured data is to be analyzed.

For details see "Data Acquisition".

The hop detection settings are described in "Signal Detection (Signal States)".

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. The data acquisition settings for Transient Analysis in MSRA/MSRT mode define the application data extract and analysis interval.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

The settings in this dialog box are available when you do one of the following:
  • Select the "Data Acquisition" button from the "Overview".
  • Press the MEAS CONFIG key, then the "Data Acquisition Config" softkey.
└ Measurement Bandwidth
└ Sample Rate
└ Measurement Time
└ Record Length
└ Analysis Region
└ Analysis Bandwidth
└ Delta Frequency
└ Time Gate Length
└ Time Gate Start
└ Linked analysis bandwidth
└ Linked analysis time span
└ Visualizing the Analysis Region Parameters (Show Diagram)


Measurement Bandwidth

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Measurement Bandwidth
Measurement Bandwidth

The measurement bandwidth and "Sample Rate" are interdependent and define the range of data to be captured. For information on supported sample rates and bandwidths see the data sheet.

For details see "Data Acquisition".

Note: Data acquisition in MSRT mode. By default, the R&S FSW Transient Analysis application uses the largest possible measurement bandwidth. Depending on which bandwidth extension options are installed (if any), this may be up to 500 MHz. However, in MSRT mode a maximum of 160 MHz bandwidth is available. Thus, you must ensure the measurement bandwidth for Transient Analysis is available in MSRT mode. Otherwise you will not obtain useful results.

Remote command:

[SENSe:​]BANDwidth|BWIDth:​DEMod


Sample Rate

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Sample Rate
Sample Rate

The "Measurement Bandwidth" and sample rate are interdependent and define the range of data to be captured. For information on supported sample rates and bandwidths see the data sheet.

For details see "Data Acquisition".

Remote command:

[SENSe:​]SRATe


Measurement Time

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Measurement Time
Measurement Time

The measurement time and "Record Length" are interdependent and define the amount of data to be captured.

For details see "Data Acquisition".

The maximum measurement time in the R&S FSW Transient application is limited only by the available memory ("memory limit reached" message is shown in status bar). Note, however, that increasing the measurement time (and thus reducing the available memory space) may restrict the number of measurement channels that can be activated simultaneously on the R&S FSW.

Remote command:

[SENSe:​]MTIMe


Record Length

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Record Length
Record Length

The "Measurement Time" and record length are interdependent and define the amount of data to be captured.

For details see "Data Acquisition".

The maximum record length in the R&S FSW Transient application is limited only by the available memory ("memory limit reached" message is shown in status bar). Note, however, that increasing the record length (and thus reducing the available memory space) may restrict the number of measurement channels that can be activated simultaneously on the R&S FSW.

Remote command:

[SENSe:​]RLENgth


Analysis Region

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Analysis Region
Analysis Region

The analysis region determines which data is displayed on the screen (see also "Analysis Region").

The region is defined by a frequency span and a time gate for which the results are displayed. The time and frequency spans can be defined either as absolute values or relative to the full capture buffer.

Both methods can be combined, for example by defining an absolute frequency span and a relative time gate.

└ Analysis Bandwidth
└ Delta Frequency
└ Time Gate Length
└ Time Gate Start
└ Linked analysis bandwidth
└ Linked analysis time span
└ Visualizing the Analysis Region Parameters (Show Diagram)


Analysis Bandwidth

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Analysis Region > Analysis Bandwidth
Analysis Bandwidth

Defines the absolute width of the frequency span for the analysis region. It is centered around the point defined by the "Delta Frequency".

See "Analysis Region" for details.

Remote command:

CALCulate:​AR:​FREQuency:​BANDwidth


Time Gate Length

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Analysis Region > Time Gate Length
Time Gate Length

Defines the absolute length of the time gate, that is, the duration (or height) of the analysis region.

See "Analysis Region" for details.

Remote command:

CALCulate:​AR:​TIME:​LENGth


Time Gate Start

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Analysis Region > Time Gate Start
Time Gate Start

Defines the starting point of the time span for the analysis region. The starting point is defined as a time offset from the capture start time.

See "Analysis Region" for details.

Remote command:

CALCulate:​AR:​TIME:​STARt


Linked analysis bandwidth

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Analysis Region > Linked analysis bandwidth
Linked analysis bandwidth

If activated, the width of the frequency span for the analysis region is defined as a percentage of the full capture buffer. It is centered around the point defined by the "Delta Frequency".

See "Analysis Region" for details.

Remote command:

CALCulate:​AR:​FREQuency:​PERCent

CALCulate:​AR:​FREQuency:​PERCent:​STATe


Linked analysis time span

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Analysis Region > Linked analysis time span
Linked analysis time span

If activated, the length of the time gate, that is, the duration (or height) of the analysis region, is defined as a percentage of the full measurement time. The time gate start is the start of the capture buffer plus an offset defined by the "Time Gate Start".

See "Analysis Region" for details.

Remote command:

CALCulate:​AR:​TIME:​PERCent

CALCulate:​AR:​TIME:​PERCent:​STATe


Visualizing the Analysis Region Parameters (Show Diagram)

Transient Analysis (R&S FSW-K60) > Configuration > Data Acquisition and Analysis Region > Analysis Region > Visualizing the Analysis Region Parameters (Show Diagram)
Visualizing the Analysis Region Parameters (Show Diagram)

If enabled, the "Data Acquisition / Analysis Region" dialog box shows a visualization of the parameters that define the analysis region (as shown in figure "Visualization of absolute analysis region parameters").


Bandwidth Settings

Transient Analysis (R&S FSW-K60) > Configuration > Bandwidth Settings
Bandwidth Settings

The bandwidth settings are available when you select the BW or SPAN key.

Some of these settings are also available in the ""Data Acquisition and Analysis Region"" dialog box.

└ RBW
└ ABW / RBW
└ FFT Window
└ Measurement Bandwidth
└ FM Video Bandwidth
└ Time Resolution
└ Measurement Time


RBW

Transient Analysis (R&S FSW-K60) > Configuration > Bandwidth Settings > RBW
RBW

Defines the resolution bandwidth. Numeric input is always rounded to the nearest possible bandwidth.

The resolution bandwidth is coupled to the selected span (see "ABW / RBW").

For more information see "Resolution bandwidth".

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​WINDow<n>]:​RESolution


ABW / RBW

Transient Analysis (R&S FSW-K60) > Configuration > Bandwidth Settings > ABW / RBW
ABW / RBW

The resolution bandwidth is coupled to the selected analysis bandwidth (ABW). The ABW can be the full measurement bandwidth, the bandwidth of the analysis region, or the length of the result range, depending on the evaluation basis of the result display. If the ABW is changed, the resolution bandwidth is automatically adjusted. This setting defines the coupling ratio. Which coupling ratios are available depends on the selected "FFT Window".

For more information see "Resolution bandwidth".

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​WINDow<n>]:​RATio


FFT Window

Transient Analysis (R&S FSW-K60) > Configuration > Bandwidth Settings > FFT Window
FFT Window

In the Transient Analysis application you can select one of several FFT window types.

The following window types are available:
  • Blackman-Harris
  • Flattop
  • Gauss
  • Rectangular
  • Hanning
  • Hamming
  • Chebyshev
Remote command:

[SENSe:​]SWEep:​FFT:​WINDow:​TYPE


FM Video Bandwidth

Transient Analysis (R&S FSW-K60) > Configuration > Bandwidth Settings > FM Video Bandwidth
FM Video Bandwidth

Additional filters applied after demodulation help filter out unwanted signals, or correct pre-emphasized input signals.

  • Relative low pass filters:
    Relative filters (3 dB) can be selected in % of the analysis (demodulation) bandwidth. The filters are designed as 5th-order Butterworth filters (30 dB/octave) and active for all demodulation bandwidths.
  • "None" deactivates the FM video bandwidth (default).
Remote command:

[SENSe:​][DEMod:​]FMVF:​TYPE


Time Resolution

Transient Analysis (R&S FSW-K60) > Configuration > Bandwidth Settings > Time Resolution
Time Resolution

The time resolution determines the size of the bins used for each FFT calculation. The shorter the time span used for each FFT, the shorter the resulting span, and thus the higher the resolution in the spectrum becomes.

In "Auto" mode, the optimal resolution is determined automatically according to the data acquisition settings.

In "Manual" mode, you must define the time resolution in seconds.

For details on the FFT calculation see "Signal Processing".

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​TRESolution:​AUTO

CALCulate<n>:​SGRam|SPECtrogram:​TRESolution


Hop / Chirp Measurement Settings

Transient Analysis (R&S FSW-K60) > Configuration > Hop / Chirp Measurement Settings
Hop / Chirp Measurement Settings

For some frequency or power calculations, it may be useful not to take the entire dwell time of the hop or length of the chirp into consideration, but only a certain range within the dwell time/length. Thus, it is possible to eliminate settling effects, for instance. For such cases, a measurement range can be defined for power and frequency results, in relation to specific hop or chirp characteristics.

These settings are only available if at least one of the additional options R&S FSW-K60C/-K60H are installed.

The "Power" settings, for example, determine which part of the hop/chirp is used to calculate the average power in one hop/chirp. The "Frequency" settings determine which part of the hop/chirp is used to calculate the average frequency in one hop/chirp.

The ranges for both frequency and power measurements are defined by a reference point, an offset from the reference point, and the range length.

For details on the measurement range parameters see "Measurement Range".

└ Reference
└ Length
└ Offset Begin / Offset End


Reference

Transient Analysis (R&S FSW-K60) > Configuration > Hop / Chirp Measurement Settings > Reference
Reference

Defines the reference point for positioning the frequency/power measurement range. The "Offset Begin / Offset End" is given with respect to this value.

For details on the measurement range parameters see "Measurement Range".

"Edge" | The measurement range is defined in reference to the rising or falling edge.
"Center" | The measurement range is defined in reference to the center of the hop/chirp.
Remote command:

CALCulate:​CHRDetection:​FREQuency:​REFerence

CALCulate:​CHRDetection:​POWer:​REFerence

CALCulate:​HOPDetection:​FREQuency:​REFerence

CALCulate:​HOPDetection:​POWer:​REFerence


Length

Transient Analysis (R&S FSW-K60) > Configuration > Hop / Chirp Measurement Settings > Length
Length

Defines the length or duration of the frequency/power measurement range.

For details on the measurement range parameters see "Measurement Range".

Remote command:

CALCulate:​CHRDetection:​FREQuency:​LENGth

CALCulate:​CHRDetection:​POWer:​LENGth

CALCulate:​HOPDetection:​FREQuency:​LENGth

CALCulate:​HOPDetection:​POWer:​LENGth


Offset Begin / Offset End

Transient Analysis (R&S FSW-K60) > Configuration > Hop / Chirp Measurement Settings > Offset Begin / Offset End
Offset Begin / Offset End

The offset in seconds from the beginning or end of the "Reference".

For details on the measurement range parameters see "Measurement Range".

Remote command:

CALCulate:​CHRDetection:​FREQuency:​OFFSet:​BEGin

CALCulate:​CHRDetection:​FREQuency:​OFFSet:​END

CALCulate:​CHRDetection:​POWer:​OFFSet:​BEGin

CALCulate:​CHRDetection:​POWer:​OFFSet:​END

CALCulate:​HOPDetection:​FREQuency:​OFFSet:​BEGin

CALCulate:​HOPDetection:​FREQuency:​OFFSet:​END

CALCulate:​HOPDetection:​POWer:​OFFSet:​BEGin

CALCulate:​HOPDetection:​POWer:​OFFSet:​END


FM Video Bandwidth

Transient Analysis (R&S FSW-K60) > Configuration > FM Video Bandwidth
FM Video Bandwidth

A video filter applied during demodulation can filter out unwanted signals.

The video filter settings are available when you select "FM Video BW" from the MEAS CONFIG menu.

└ FM Video Bandwidth


Hop / Chirp Selection

Transient Analysis (R&S FSW-K60) > Configuration > Hop / Chirp Selection
Hop / Chirp Selection

For some results, an individual hop or chirp can be selected for analysis.

These settings are only available if at least one of the additional options R&S FSW-K60C/-K60H are installed.

└ Select Hop / Select Chirp


Select Hop / Select Chirp

Transient Analysis (R&S FSW-K60) > Configuration > Hop / Chirp Selection > Select Hop / Select Chirp
Select Hop / Select Chirp

Defines the individual hop or chirp for which results are calculated and displayed.

These settings are only available if at least one of the additional options R&S FSW-K60C/-K60H are installed.

Remote command:

CALCulate:​CHRDetection:​SELected

CALCulate:​HOPDetection:​SELected


Sweep Settings

Transient Analysis (R&S FSW-K60) > Configuration > Sweep Settings
Sweep Settings

The sweep settings define how often data from the input signal is acquired and then evaluated. They are configured via the SWEEP key.

└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep
└ Refresh
└ Measurement Time
└ Sweep/Average Count
└ Selecting a frame to display


Continuous Sweep/RUN CONT

Transient Analysis (R&S FSW-K60) > Configuration > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active, the "Continuous Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in continuous sweep mode is swept repeatedly.
Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

Transient Analysis (R&S FSW-K60) > Configuration > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]

CALCulate:​SGRam|SPECtrogram:​CONT


Continue Single Sweep

Transient Analysis (R&S FSW-K60) > Configuration > Sweep Settings > Continue Single Sweep
Continue Single Sweep

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Refresh

Transient Analysis (R&S FSW-K60) > Configuration > Sweep Settings > Refresh
Refresh

This function is only available if the Sequencer is deactivated and only for MSRA or MSRT applications.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

This is useful, for example, after evaluation changes have been made or if a new sweep was performed from another application; in this case, only that application is updated automatically after data acquisition.

Note: To update all active applications at once, use the "Refresh all" function in the "Sequencer" menu.
(See "Refresh All" ).

Remote command:

INITiate:​REFResh


Sweep/Average Count

Transient Analysis (R&S FSW-K60) > Configuration > Sweep Settings > Sweep/Average Count
Sweep/Average Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one sweep is performed.

For more information see "How Much Data is Measured: Sweep Points and Sweep Count" .

Remote command:

[SENSe:​]SWEep:​COUNt


Selecting a frame to display

Transient Analysis (R&S FSW-K60) > Configuration > Sweep Settings > Selecting a frame to display
Selecting a frame to display

Selects a specific frame, loads the corresponding trace from the memory, and displays it in the Spectrum window.

Note that activating a marker or changing the position of the active marker automatically selects the frame that belongs to that marker.

This function is only available in single sweep mode or if the sweep is stopped, and only if a spectrogram is selected.

The most recent frame is number 0, all previous frames have a negative number.

For more information see "Measurement Basics".

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​FRAMe:​SELect


Adjusting Settings Automatically

Transient Analysis (R&S FSW-K60) > Configuration > Adjusting Settings Automatically
Adjusting Settings Automatically

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings. In order to do so, a measurement is performed. The duration of this measurement can be defined automatically or manually.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

└ Setting the Reference Level Automatically (Auto Level)


Setting the Reference Level Automatically (Auto Level)

Transient Analysis (R&S FSW-K60) > Configuration > Adjusting Settings Automatically > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​LEVel


Analysis

Transient Analysis (R&S FSW-K60) > Analysis
Analysis

General result analysis settings concerning the trace, markers, windows etc. can be configured via the "Analysis" button in the "Overview". They are identical to the analysis functions in the base unit except for the special window functions.

Contents
  • Display Configuration
  • Result Configuration
  • Evaluation Basis
  • Trace Settings
  • Trace / Data Export Configuration
  • Spectrogram Settings
  • Export Functions
  • Marker Settings
  • Zoom Functions
  • Analysis in MSRA/MSRT Mode


Display Configuration

Transient Analysis (R&S FSW-K60) > Analysis > Display Configuration
Display Configuration

The captured signal can be displayed using various evaluation methods. All evaluation methods available for the Transient Analysis application are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the "Overview".
  • Press the MEAS key.
  • Select the "Display Config" softkey in the main TA Meas menu.

Up to six evaluation methods can be displayed simultaneously in separate windows. The evaluation methods available for Transient Analysis are described in "Evaluation Methods for Transient Analysis".

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .


Result Configuration

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration
Result Configuration

Some evaluation methods require or allow for additional settings to configure the result display. Note that the available settings depend on the selected window (see "Specifics for").

The "Result Configuration" dialog box is available by selecting the "Result Config" softkey or the "Result Config" button in the Overview.

Contents
  • Result Range
  • Table Configuration
  • Y-Axis Scaling
  • Units


Result Range

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Result Range
Result Range

The result range determines which data is displayed on the screen (see also "Measurement range vs result range"). This range applies to the pulse magnitude, frequency and phase vs time displays.

These settings are only available if at least one of the additional options R&S FSW-K60C/-K60H are installed.

The range is defined by a reference point, alignment and the range length.

└ Automatic Range Scaling
└ Result Range Reference Point
└ Offset
└ Alignment
└ Length


Automatic Range Scaling

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Result Range > Automatic Range Scaling
Automatic Range Scaling

Defines whether the result range length is determined automatically according to the width of the selected hop/chirp (see "Select Hop / Select Chirp").

"OFF" | Switches automatic range scaling off
"ON" | Switches automatic range scaling on
Remote command:

CALCulate:​RESult:​RANGe:​AUTO


Result Range Reference Point

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Result Range > Result Range Reference Point
Result Range Reference Point

Defines the reference point for positioning the result range. The "Offset" is given with respect to this value.

"Rise" | The result range is defined in reference to the rising edge.
"Center" | The result range is defined in reference to the center of the pulse top.
"Fall" | The result range is defined in reference to the falling edge.
Remote command:

CALCulate:​RESult:​REFerence


Offset

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Result Range > Offset
Offset

The offset in seconds from the pulse edge or center at which the result range reference point occurs.

Remote command:

CALCulate:​RESult:​OFFSet


Alignment

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Result Range > Alignment
Alignment

Defines the alignment of the result range in relation to the selected "Result Range Reference Point".

"Left" | The result range starts at the pulse center or selected edge.
"Center" | The result range is centered around the pulse center or selected edge.
"Right" | The result range ends at the pulse center or selected edge.
Remote command:

CALCulate:​RESult:​ALIGnment


Length

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Result Range > Length
Length

Defines the length or duration of the result range.

Remote command:

CALCulate:​RESult:​LENGth


Table Configuration

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Table Configuration
Table Configuration

During each measurement, a large number of statistical and characteristic values are determined. The "Hop/Chirp Statistics" and "Hop/Chirp Results" tables display an overview of the parameters selected here. Note that the table configuration applies to both result tables, it is not window-specific.

These settings are only available if at least one of the additional options R&S FSW-K60C/-K60H are installed.

Select the parameters to be included in the table, and the required unit scaling, if available. For a description of the individual parameters see "Hop Parameters"/ "Chirp Parameters".

Remote command:

CALCulate:​CHRDetection:​TABLe:​COLumn

CALCulate:​HOPDetection:​TABLe:​COLumn

Contents
  • Table Export Settings


Table Export Settings

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Table Configuration > Table Export Settings
Table Export Settings

Table results can be exported to an ASCII file for further evaluation in other (external) applications. Table export settings can be configured in the "Result Configuration" dialog box, in the "Table Configuration" tab, in the vertical "Table Export" tab.

The settings are window-specific and only available for result tables.

The result tables can be exported either directly in the settings dialog box or via the "Export" function in the "Save/Recall" menu (via the toolbar).

For step-by-step instructions on how to export a trace, see "How to Export Trace Data and Numerical Results" .

└ Columns to Export
└ Decimal Separator
└ Export Table to ASCII File


Columns to Export

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Table Configuration > Table Export Settings > Columns to Export
Columns to Export

Defines which of the result table columns are to be included in the export file.

"Visible" | Only the currently visible columns in the result display are exported.
"All" | All columns, including currently hidden ones, for the result display are exported.
Remote command:

MMEMory:​STORe<n>:​TABLe


Decimal Separator

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Table Configuration > Table Export Settings > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Export Table to ASCII File

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Table Configuration > Table Export Settings > Export Table to ASCII File
Export Table to ASCII File

Opens a file selection dialog box and saves the selected result table in ASCII format (.DAT) to the specified file and directory.

Note: To store the measurement results for all traces and tables in all windows, use the "Export Trace to ASCII File" command in the "Save/Recall" > "Export" menu. (See also "Trace / Data Export Configuration".)

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Remote command:

MMEMory:​STORe<n>:​TABLe


Y-Axis Scaling

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling
Y-Axis Scaling

The scaling for the vertical axis is highly configurable, using either absolute or relative values. These settings are described here.

To display this dialog box, do one of the following:

  • Press the AMPT key, then select the "Scale Config" softkey.
  • From the "Overview", select "Result Configuration", then switch to the "Y-Scaling" tab.
└ Automatic Grid Scaling
└ Auto Scale Once
└ Absolute Scaling (Min/Max Values)
└ Relative Scaling (Reference/ per Division)
└ Per Division
└ Ref Position
└ Ref Value
└ Spectrogram y-scaling
└ Range
└ Ref Level Position


Automatic Grid Scaling

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling > Automatic Grid Scaling
Automatic Grid Scaling

The y-axis is scaled automatically according to the current measurement settings and results (continuously).

Note: Tip: To update the scaling automatically once when this setting for continuous scaling is off, use the "Auto Scale Once" button or the softkey in the AUTO SET menu.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO


Auto Scale Once

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling > Auto Scale Once
Auto Scale Once

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings.

The display is only set once; it is not adapted further if the measurement settings are changed again.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO


Absolute Scaling (Min/Max Values)

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling > Absolute Scaling (Min/Max Values)
Absolute Scaling (Min/Max Values)

Define the scaling using absolute minimum and maximum values.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MAXimum

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MINimum


Relative Scaling (Reference/ per Division)

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling > Relative Scaling (Reference/ per Division)
Relative Scaling (Reference/ per Division)

Define the scaling relative to a reference value, with a specified value range per division.

└ Per Division
└ Ref Position
└ Ref Value


Per Division

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling > Relative Scaling (Reference/ per Division) > Per Division
Per Division

Defines the value range to be displayed per division of the diagram (1/10 of total range).

Note: The value defined per division refers to the default display of 10 divisions on the y-axis. If fewer divisions are displayed (e.g. because the window is reduced in height), the range per division is increased in order to display the same result range in the smaller window. In this case, the per division value does not correspond to the actual display.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​PDIVision


Ref Position

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling > Relative Scaling (Reference/ per Division) > Ref Position
Ref Position

Defines the position of the reference value in percent of the total y-axis range.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Ref Value

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling > Relative Scaling (Reference/ per Division) > Ref Value
Ref Value

Defines the reference value to be displayed at the specified reference position.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RVALue


Spectrogram y-scaling

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling > Spectrogram y-scaling
Spectrogram y-scaling

For spectrograms, the displayed y-levels are defined as a range below the reference level.

└ Range
└ Ref Level Position


Range

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling > Spectrogram y-scaling > Range
Range

Defines the full value span in dB that can be displayed by the color map. Note that the span actually used for the color map definition may be restricted (see "Start / Stop").

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]


Ref Level Position

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Y-Axis Scaling > Spectrogram y-scaling > Ref Level Position
Ref Level Position

Defines the reference level position, i.e. the position of the maximum AD converter value on the level axis in %, where 0 % corresponds to the lower and 100 % to the upper limit of the diagram.

For spectrograms, this value defines the position of the reference level value within the span covered by the color map. In this case, the value is given in %, where 0 % corresponds to the maximum (right end) and 100 % to the minimum (left end) of the color map.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Units

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Units
Units

The unit for phase display is configurable. This setting is described here.

└ Phase Unit


Phase Unit

Transient Analysis (R&S FSW-K60) > Analysis > Result Configuration > Units > Phase Unit
Phase Unit

Defines the unit in which phases are displayed (degree or rad).

Remote command:

CALCulate<n>:​UNIT:​ANGLe


Evaluation Basis

Transient Analysis (R&S FSW-K60) > Analysis > Evaluation Basis
Evaluation Basis

Depending on the measurement task, not all of the measured data in the capture buffer may be of interest. In some cases it may be useful to restrict analysis to a specific user-definable region, or to a selected individual chirp rate or hop.

Which evaluation basis is available for which result display is indicated in table "Available evaluation methods and evaluation basis".

Some of these settings are only available if at least one of the additional options R&S FSW-K60C/-K60H are installed.

└ Full Capture / Region Analysis / Hop / Chirp
└ Selecting a frame to display
└ Select Hop / Select Chirp


Full Capture / Region Analysis / Hop / Chirp

Transient Analysis (R&S FSW-K60) > Analysis > Evaluation Basis > Full Capture / Region Analysis / Hop / Chirp
Full Capture / Region Analysis / Hop / Chirp
For some result displays you can select the basis used for analysis:
  • the full capture buffer
  • the selected "Analysis Region"
  • an individual selected hop / chirp (only available if at least one of the additional options R&S FSW-K60C/-K60H are installed)

To select a hop / chirp for the latter case, select the "Selected Hop"/"Selected Chirp" softkey in the "Meas Config" menu (see "Select Hop / Select Chirp").

The currently selected hop / chirp is highlighted blue in the "Result Table" and "Statistic Table" displays.

As soon as a new hop / chirp is selected, all hop/chirp-specific displays are automatically updated.

Remote command:

DISPlay:​[WINDow<n>:​]EVAL


Trace Settings

Transient Analysis (R&S FSW-K60) > Analysis > Trace Settings
Trace Settings

The trace settings determine how the measured data is analyzed and displayed in the window. Depending on the result display, between 1 and 6 traces may be displayed.

Trace settings can be configured via the TRACE key, in the "Traces" dialog box, or in the vertical "Traces" tab of the "Analysis" dialog box.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box (see "Specifics for").

Trace data can also be exported to an ASCII file for further analysis. For details see "Trace / Data Export Configuration".

└ Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
└ Mode
└ Detector
└ Hold
└ Statistical Evaluation
└ Selected Hop / Selected Chirp vs All Hops / All Chirps
└ Sweep/Average Count
└ Maximum number of trace points
└ Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)


Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

Transient Analysis (R&S FSW-K60) > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

Selects the corresponding trace for configuration. The currently selected trace is highlighted orange.

For details see "How to Configure a Standard Trace" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]

Selected via numeric suffix of TRACe<t> commands


Mode

Transient Analysis (R&S FSW-K60) > Analysis > Trace Settings > Mode
Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode".

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Detector

Transient Analysis (R&S FSW-K60) > Analysis > Trace Settings > Detector
Detector

Defines the trace detector to be used for trace analysis.

Detectors perform a data reduction from the swept values to the displayed trace points. The detector type determines which of the samples are displayed for each trace point.

Note: The detector activated for the specific trace is indicated in the corresponding trace information in the window title bar by an abbreviation.

The trace detector can analyze the measured data using various methods:

"Auto"

Selects the optimum detector for the selected trace and filter mode. This is the default setting.

"Positive Peak"

Determines the largest of all positive peak values from the levels measured at the individual x-values which are displayed in one trace point

"Negative Peak"

Determines the smallest of all negative peak values from the levels measured at the individual x-values which are displayed in one trace point

"Average"

Calculates the linear average of all samples contained in a sweep point.

To this effect, R&S FSW uses the linear voltage after envelope detection. The sampled linear values are summed up and the sum is divided by the number of samples (= linear average value). Each sweep point thus corresponds to the average of the measured values summed up in the sweep point.

The average detector supplies the average value of the signal irrespective of the waveform (CW carrier, modulated carrier, white noise or impulsive signal).

"Sample"

Selects the last measured value of the levels measured at the individual x-values which are displayed in one trace point; all other measured values for the x-axis range are ignored

Remote command:

[SENSe:​][WINDow<n>:​]DETector<t>[:​FUNCtion]:​AUTO


Hold

Transient Analysis (R&S FSW-K60) > Analysis > Trace Settings > Hold
Hold

If activated, traces in "Min Hold", "Max Hold" and "Average" mode are not reset after specific parameter changes have been made.

Normally, the measurement is started anew after parameter changes, before the measurement results are analyzed (e.g. using a marker). In all cases that require a new measurement after parameter changes, the trace is reset automatically to avoid false results (e.g. with span changes). For applications that require no reset after parameter changes, the automatic reset can be switched off.

The default setting is off.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE:​HCONtinuous


Statistical Evaluation

Transient Analysis (R&S FSW-K60) > Analysis > Trace Settings > Statistical Evaluation
Statistical Evaluation

If the trace modes "Average", "Max Hold" or "Min Hold" are set, you can define how many hops or chirp rates are included in the statistical evaluation.

For details see "Trace Statistics".

└ Selected Hop / Selected Chirp vs All Hops / All Chirps
└ Sweep/Average Count
└ Maximum number of trace points


Selected Hop / Selected Chirp vs All Hops / All Chirps

Transient Analysis (R&S FSW-K60) > Analysis > Trace Settings > Statistical Evaluation > Selected Hop / Selected Chirp vs All Hops / All Chirps
Selected Hop / Selected Chirp vs All Hops / All Chirps

Defines which hops/chirps are included in the statistical evaluation.

For details see "Trace Statistics".

"Selected hop/chirp" | Only the selected hop/chirp from each sweep (capture) is included in the statistical evaluation.
"All Hops/Chirps" | All measured hops/chirps from each sweep (capture) are included in the statistical evaluation.
Remote command:

[SENSe:​]STATistic:​TYPE


Maximum number of trace points

Transient Analysis (R&S FSW-K60) > Analysis > Trace Settings > Statistical Evaluation > Maximum number of trace points
Maximum number of trace points

If the number of samples within the result range (see "Result Range") is larger than this value, the trace data is reduced to the defined maximum number of trace points using the selected detector.

For details see also "Mapping Samples to Measurement Points with the Trace Detector".

Restricting this value can improve performance during statistical evaulation of large result range lengths.

Remote command:

[SENSe:​]MEASure:​POINts


Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Transient Analysis (R&S FSW-K60) > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Displays the "Traces" settings and focuses the "Mode" list for the selected trace.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]


Trace / Data Export Configuration

Transient Analysis (R&S FSW-K60) > Analysis > Trace / Data Export Configuration
Trace / Data Export Configuration

The R&S FSW provides various evaluation methods for the results of the performed measurements. However, you may want to evaluate the data with other, external applications. In this case, you can export the measurement data to a standard format file (ASCII or CSV).

The standard data management functions (e.g. saving or loading instrument settings) that are available for all R&S FSW applications are not described here.

See "Data Management" for a description of the standard functions.

Alternatively, they are available in the "Save/Recall" menu (> "Export" softkey) which is displayed when you select the "Save" or "Open" icon in the toolbar.

For step-by-step instructions on how to export a trace, see "How to Export Trace Data" .

└ Export all Traces and all Table Results
└ Include Instrument Measurement Settings
└ Trace to Export
└ Decimal Separator
└ Export Trace to ASCII File


Export all Traces and all Table Results

Transient Analysis (R&S FSW-K60) > Analysis > Trace / Data Export Configuration > Export all Traces and all Table Results
Export all Traces and all Table Results

Selects all displayed traces and result tables (e.g. Result Summary, marker table etc.) in the current application for export to an ASCII file.

Alternatively, you can select one specific trace only for export (see "Trace to Export").

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Remote command:

FORMat:​DEXPort:​TRACes


Include Instrument Measurement Settings

Transient Analysis (R&S FSW-K60) > Analysis > Trace / Data Export Configuration > Include Instrument Measurement Settings
Include Instrument Measurement Settings

Includes additional instrument and measurement settings in the header of the export file for result data.

Remote command:

FORMat:​DEXPort:​HEADer


Trace to Export

Transient Analysis (R&S FSW-K60) > Analysis > Trace / Data Export Configuration > Trace to Export
Trace to Export

Defines an individual trace that will be exported to a file.

This setting is not available if "Export all Traces and all Table Results" is selected.


Decimal Separator

Transient Analysis (R&S FSW-K60) > Analysis > Trace / Data Export Configuration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Export Trace to ASCII File

Transient Analysis (R&S FSW-K60) > Analysis > Trace / Data Export Configuration > Export Trace to ASCII File
Export Trace to ASCII File

Opens a file selection dialog box and saves the selected trace in ASCII format (.dat) to the specified file and directory.

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

If the spectrogram display is selected when you perform this function, the entire histogram buffer with all frames is exported to a file. The data corresponding to a particular frame begins with information about the frame number and the time that frame was recorded. For large history buffers the export operation may take some time.

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Remote command:

MMEMory:​STORe<n>:​TRACe


Spectrogram Settings

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings
Spectrogram Settings

The individual settings available for spectrogram display are described here. For settings on color mapping, see "Color Map Settings".

Contents
  • General Spectrogram Settings
  • Color Map Settings


General Spectrogram Settings

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > General Spectrogram Settings
General Spectrogram Settings

This section describes general settings for spectrogram display. They are available when you press the MEAS CONFIG key and then select the "Spectrogram Config" softkey.

The FFT analysis used to create the spectrogram is configurable, in order to improve detection of transient signal effects or minimize the duration of the calculation. For details on FFT calculation see "Signal Processing".

└ Selecting a frame to display
└ Time Resolution
└ History Depth
└ Timestamp
└ Color Mapping
└ Clear Spectrogram
└ Detector
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE


History Depth

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > General Spectrogram Settings > History Depth
History Depth

Sets the number of frames that the R&S FSW stores in its memory.

If the memory is full, the R&S FSW deletes the oldest frames stored in the memory and replaces them with the new data.

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​HDEPth


Timestamp

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > General Spectrogram Settings > Timestamp
Timestamp

Activates and deactivates the timestamp. The timestamp shows the system time while the measurement is running. In single sweep mode or if the measurement is stopped, the timestamp shows the time and date of the end of the measurement.

When active, the timestamp replaces the display of the frame number.

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​TSTamp[:​STATe]

CALCulate<n>:​SGRam|SPECtrogram:​TSTamp:​DATA?


Color Mapping

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > General Spectrogram Settings > Color Mapping
Color Mapping

Opens the "Color Map" dialog.

For details see "Color Maps" .


Clear Spectrogram

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > General Spectrogram Settings > Clear Spectrogram
Clear Spectrogram

Resets the spectrogram result display and clears the history buffer.

This function is only available if a spectrogram is selected.

Remote command:

CALCulate<n>:​SGRam:​CLEar


Detector

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > General Spectrogram Settings > Detector
Detector

Defines the detector used to combine overlapping FFT frames for the spectrogram result display.

"Sum" | Calculates the sum of all values in one sample point
"Average" | Calculates the linear average of all values in one sample point
"RMS" | Calculates the RMS of all values in one sample point
"Maximum" | Determines the largest of all values in one sample point
"Minimum" | Determines the minimum of all values in one sample point
"Sample" | Selects the last measured value for each sample point
Remote command:

[SENSe:​][WINDow<n>:​]SGRam|SPECtrogram:​DETector:​FUNCtion


Color Map Settings

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > Color Map Settings
Color Map Settings

The settings for color mapping are displayed in the "Color Mapping" dialog box that is displayed when you press the "Color Mapping" softkey in the "Spectrogram" menu, or select the color map in the spectrogram display.

For more information on color maps see "Color Maps" .

For details on changing color mapping settings see "How to Configure the Color Mapping" .

In addition to the available color settings, the dialog box displays the current color map and provides a preview of the display with the current settings.

Color Mapping dialog box
1 = Color map: shows the current color distribution
2 = Preview pane: shows a preview of the spectrogram with any changes that you make to the color scheme
3 = Color curve pane: graphical representation of all settings available to customize the color scheme
4/5 = Color range start and stop sliders: define the range of the color map or amplitudes for the spectrogram
6 = Color curve slider: adjusts the focus of the color curve
7 = Histogram: shows the distribution of measured values
8 = Scale of the horizontal axis (value range)
└ Start / Stop
└ Shape
└ Hot/Cold/Radar/Grayscale
└ Auto
└ Set to Default


Start / Stop

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > Color Map Settings > Start / Stop
Start / Stop

Defines the lower and upper boundaries of the value range of the spectrogram.

For details see "Color Maps" .

Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​LOWer

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​UPPer


Shape

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > Color Map Settings > Shape
Shape

Defines the shape and focus of the color curve for the spectrogram result display.

For details see "Color Maps" .

"-1 to <0" | More colors are distributed among the lower values
"0" | Colors are distributed linearly among the values
">0 to 1" | More colors are distributed among the higher values
Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​SHAPe


Hot/Cold/Radar/Grayscale

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > Color Map Settings > Hot/Cold/Radar/Grayscale
Hot/Cold/Radar/Grayscale

Sets the color scheme for the spectrogram.

For details see "Color Maps" .

Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor[:​STYLe]


Auto

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > Color Map Settings > Auto
Auto

Defines the color range automatically according to the existing measured values for optimized display.


Set to Default

Transient Analysis (R&S FSW-K60) > Analysis > Spectrogram Settings > Color Map Settings > Set to Default
Set to Default

Sets the color mapping to the default settings.

Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​DEFault


Export Functions

Transient Analysis (R&S FSW-K60) > Analysis > Export Functions
Export Functions

The following export functions are available via softkeys in the "Export" menu which is displayed when you select the "Save" icon in the toolbar and then "Export".

The standard data management functions (e.g. saving or loading instrument settings) that are available for all R&S FSW applications are not described here.

See "Data Management" for a description of the standard functions.

└ Export Table to ASCII File
└ Table Export Configuration
└ Columns to Export
└ Decimal Separator
└ Export Table to ASCII File
└ Export Trace to ASCII File
└ Trace Export Configuration
└ I/Q Export


Table Export Configuration

Transient Analysis (R&S FSW-K60) > Analysis > Export Functions > Table Export Configuration
Table Export Configuration

Table results can be exported to an ASCII file for further evaluation in other (external) applications. Table export settings can be configured in the "Result Configuration" dialog box, in the "Table configuration" tab, in the vertical "Table Export" tab.

The settings are window-specific and only available for result tables.

└ Columns to Export
└ Decimal Separator
└ Export Table to ASCII File


Columns to Export

Transient Analysis (R&S FSW-K60) > Analysis > Export Functions > Table Export Configuration > Columns to Export
Columns to Export

Defines which of the result table columns are to be included in the export file.

"Visible" | Only the currently visible columns in the result display are exported.
"All" | All columns, including currently hidden ones, for the result display are exported.
Remote command:

MMEMory:​STORe<n>:​TABLe


Decimal Separator

Transient Analysis (R&S FSW-K60) > Analysis > Export Functions > Table Export Configuration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Trace Export Configuration

Transient Analysis (R&S FSW-K60) > Analysis > Export Functions > Trace Export Configuration
Trace Export Configuration

Opens the "Traces" dialog box to configure the trace and data export settings. See "Trace / Data Export Configuration".


I/Q Export

Transient Analysis (R&S FSW-K60) > Analysis > Export Functions > I/Q Export
I/Q Export

Opens a file selection dialog box to select an export file to which the IQ data will be stored. This function is only available in single sweep mode, and only in applications that process I/Q data, such as the I/Q Analyzer or optional applications.

For details see "I/Q Data Import and Export" .

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .


Marker Settings

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings
Marker Settings

Marker settings can be configured via the MARKER key or in the "Marker" dialog box. To display the "Marker" dialog box, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab.

The marker "Search" settings are described in "Marker Search Settings and Positioning Functions" .

Contents
  • Individual Marker Setup
  • General Marker Settings
  • Marker Search Settings and Positioning Functions


Individual Marker Setup

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup
Individual Marker Setup

Up to 17 markers or delta markers can be activated for each window simultaneously. Initial marker setup is performed using the "Marker" dialog box.

The markers are distributed among 3 tabs for a better overview. By default, the first marker is defined as a normal marker, whereas all others are defined as delta markers with reference to the first marker. All markers are assigned to trace 1, but only the first marker is active.

└ Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
└ Selected Marker
└ Marker State
└ Marker Position (X-value)
└ Frame
└ Marker Type
└ Reference Marker
└ Assigning the Marker to a Trace
└ Select Marker
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup > Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 16 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings" .

Note: If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative?

CALCulate<n>:​DELTamarker<m>:​Y?

In spectrogram display:

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​FRAMe

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​FRAMe


Selected Marker

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Marker Position (X-value)

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup > Marker Position (X-value)
Marker Position (X-value)

Defines the position (x-value) of the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>:​X


Frame

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup > Frame
Frame

Spectrogram frame number the marker is assigned to. The most recently swept frame is number 0, all previous frames have negative numbers.

Remote command:

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​FRAMe


Marker Type

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Reference Marker

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup > Reference Marker
Reference Marker

Defines a marker as the reference marker which is used to determine relative analysis results (delta marker values).

Remote command:

CALCulate<n>:​DELTamarker<m>:​MREF


Assigning the Marker to a Trace

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


Select Marker

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup > Select Marker
Select Marker

Opens a dialog box to select and activate or deactivate one or more markers quickly.

Remote command:

Marker selected via suffix <m> in remote commands.


All Markers Off

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Individual Marker Setup > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > General Marker Settings
General Marker Settings

Some general marker settings allow you to influence the marker behavior for all markers.

These settings are located in the "Marker Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab. Then select the horizontal "Marker Settings" tab.
└ Marker Table Display
└ Linked Markers
└ Show Marker Legend in Spectrogram


Marker Table Display

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
"Auto" | (Default) Up to two markers are displayed in the diagram area. If more markers are active, the marker table is displayed automatically.
Remote command:

DISPlay:​MTABle


Linked Markers

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > General Marker Settings > Linked Markers
Linked Markers

If enabled, the markers in all diagrams are linked, i.e. when you move a marker in one window, the markers in all other windows are moved to the same x-value.

Remote command:

CALCulate<n>:​MARKer:​LINK


Show Marker Legend in Spectrogram

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > General Marker Settings > Show Marker Legend in Spectrogram
Show Marker Legend in Spectrogram

Hides or shows marker information within the spectrogram diagram area (as opposed to the separate marker table, see also "Marker Table Display"). This setting only takes effect if a marker is active.


Marker Search Settings and Positioning Functions

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions
Marker Search Settings and Positioning Functions

Several functions are available to set the marker to a specific position very quickly and easily, or to use the current marker position to define another characteristic value. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

For more information on searching for signal peaks see "Searching for Signal Peaks" .

Contents
  • Marker Search Settings
  • Positioning Functions


Marker Search Settings

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings
Marker Search Settings

Spectrograms show not only the current sweep results, but also the sweep history. Thus, when searching for peaks, you must define the search settings within a single time frame (x-direction) and within several time frames (y-direction).

These settings are are available in the "Search Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search Settings" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search Settings" tab.
└ Search Mode for Next Peak
└ Peak Excursion


Search Mode for Next Peak

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Mode for Next Peak
Search Mode for Next Peak

Selects the search mode for the next peak search.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Peak Excursion

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Peak Excursion
Peak Excursion

Defines the minimum level value by which a signal must rise or fall so that it will be identified as a maximum or a minimum by the search functions.

For more information see "Searching for Signal Peaks" .

Remote command:

CALCulate<n>:​MARKer:​PEXCursion


Positioning Functions

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions
Positioning Functions

The following functions set the currently selected marker to the result of a peak search or set other characteristic values to the current marker value. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key.

└ Select Marker
└ Peak Search
└ Search Next Peak
└ Search Minimum
└ Search Next Minimum


Peak Search

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Next Peak

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Minimum

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Search Next Minimum

Transient Analysis (R&S FSW-K60) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Zoom Functions

Transient Analysis (R&S FSW-K60) > Analysis > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom" .

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

Transient Analysis (R&S FSW-K60) > Analysis > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

Transient Analysis (R&S FSW-K60) > Analysis > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

Transient Analysis (R&S FSW-K60) > Analysis > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

Transient Analysis (R&S FSW-K60) > Analysis > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Analysis in MSRA/MSRT Mode

Transient Analysis (R&S FSW-K60) > Analysis > Analysis in MSRA/MSRT Mode
Analysis in MSRA/MSRT Mode

The data that was captured by the MSRA/MSRT Master can be analyzed in the Transient Analysis application.

The analysis settings and functions available in MSRA/MSRT mode are those described for common Signal and Spectrum Analyzer mode.

See "Analysis".

Analysis line settings

In addition, an analysis line can be positioned. The analysis line is a common time marker for all MSRA/MSRT applications.

To hide or show and position the analysis line, a dialog box is available. To display the "Analysis Line" dialog box, tap the "AL" icon in the toolbar (only available in MSRA/MSRT mode). The current position of the analysis line is indicated on the icon.

└ Position
└ Show Line


Position

Transient Analysis (R&S FSW-K60) > Analysis > Analysis in MSRA/MSRT Mode > Position
Position

Defines the position of the analysis line in the time domain. The position must lie within the measurement time of the multistandard measurement.

Remote command:

CALCulate:​MSRA:​ALINe[:​VALue]

CALCulate:​RTMS:​ALINe[:​VALue]


Show Line

Transient Analysis (R&S FSW-K60) > Analysis > Analysis in MSRA/MSRT Mode > Show Line
Show Line

Hides or displays the analysis line in the time-based windows. By default, the line is displayed.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Remote command:

CALCulate:​MSRA:​ALINe:​SHOW

CALCulate:​RTMS:​ALINe:​SHOW


How to Perform Transient Analysis

Transient Analysis (R&S FSW-K60) > How to Perform Transient Analysis
How to Perform Transient Analysis

The following step-by-step instructions demonstrate how to analyze transient signal effects with the R&S FSW-K60 option.

To perform a basic transient analysis measurement

  1. Press the MODE key on the front panel and select the "Transient" application.

  2. Select the "Overview" softkey to display the "Overview" for Transient Analysis.

  3. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

  4. Select the "Data Acquisition" button and define the bandwidth parameters for the input signal:

    (In MSRA/MSRT mode, define the application data instead, see "Transient Analysis in MSRA/MSRT Mode").

    • "Measurement Bandwidth": the amount of signal bandwidth to be captured
    • "Measurement Time": how long the input signal is to be captured

  5. Select the "Measurement" button and in the "Analysis Region" tab, define the frequency range and time gate (within the captured data) which is to be analyzed (see "Analysis Region").

  6. If necessary, filter out unwanted signals using an FM video filter ("Demod Config" softkey).

  7. Select the "Result Config" button and configure the data basis for evaluation and display.

    • In the "Scale" and "Units" tabs, configure the value range for the y-axis in the individual result displays. (See "Y-Axis Scaling".)

  8. Select the "Display Config" button and select the displays that are of interest to you (up to 16, see "Display Configuration").

    Arrange them on the display to suit your preferences.

  9. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  10. Select the "Analysis" button in the "Overview" to make use of the advanced analysis functions in the displays.

    • Configure a trace to display the average over a series of sweeps (on the "Traces" tab, see "Trace Settings").
    • Configure markers and delta markers to determine deviations and offsets within the signal (on the "Marker" tab, see "Marker Settings").
    • Configure the Spectrogram display or FFT parameters (on the "Spectrogram" tab, see "Spectrogram Settings").

  11. Optionally, export the trace data of the demodulated signal to a file.

    1. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    2. Select "Export Trace to ASCII File".

    3. Define a file name and storage location and select "OK".

To detect hops in a transient measurement

This procedure requires the additional option R&S FSW-K60H to be installed.

  1. Press the MODE key on the front panel and select the "Transient" application.

  2. Select the "Overview" softkey to display the "Overview" for Transient Analysis.

  3. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

  4. Select the "Data Acquisition" button and define the bandwidth parameters for the input signal:

    (In MSRA/MSRT mode, define the application data instead, see "Transient Analysis in MSRA/MSRT Mode").

    • "Measurement Bandwidth": the amount of signal bandwidth to be captured
    • "Measurement Time": how long the input signal is to be captured

  5. Select the "Measurement" button and configure the expected signal characteristics.

    • In the "Signal Model" tab, select the "Hop" signal model.
    • In the "Signal Detection" tab, define the known hop states and the conditions for detection. (See "Signal Detection (Signal States)")
      In the "Frequency" and "Power" subtabs, define which parts of the hop will be considered when calculating frequency and power parameters.
    • In the "Analysis Region" tab, define the frequency range and time gate (within the captured data) which is to be analyzed, that is, which hops are to be detected. (See "Analysis Region".)

  6. If necessary, filter out unwanted signals using an FM video filter ("Demod Config" softkey).

  7. Select the "Result Config" button and configure the data basis for evaluation and display.

    • In the "Result Range" tab, define the area of the hop to be analyzed in the result display. Define the area by a reference point, a length, and its alignment in relation to the hop's center or edges. (See "Result Range".)
    • In the "Table Config" tab, define which parameters are to be displayed in the hop result tables.
    • In the "Scale" and "Units" tabs, configure the value range for the y-axis in the individual result displays. (See "Y-Axis Scaling".)

  8. Select the "Display Config" button and select the displays that are of interest to you (up to 16, see "Display Configuration").

    Arrange them on the display to suit your preferences.

  9. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  10. Select the "Analysis" button in the "Overview" to make use of the advanced analysis functions in the displays.

    • Configure a trace to display the average over a series of sweeps or calculate hop statistics (on the "Traces" tab, see "Trace Settings").
    • Configure markers and delta markers to determine deviations and offsets within the signal (on the "Marker" tab, see "Marker Settings").
    • Configure the Spectrogram display or FFT parameters (on the "Spectrogram" tab, see "Spectrogram Settings").

  11. Optionally, export the trace data of the demodulated signal to a file.

    1. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    2. Select "Export Trace to ASCII File".

    3. Define a file name and storage location and select "OK".

To detect chirps in a transient measurement

This procedure requires the additional option R&S FSW-K60C to be installed.

  1. Press the MODE key on the front panel and select the "Transient" application.

  2. Select the "Overview" softkey to display the "Overview" for Transient Analysis.

  3. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

  4. Select the "Data Acquisition" button and define the bandwidth parameters for the input signal:

    (In MSRA/MSRT mode, define the application data instead, see "Transient Analysis in MSRA/MSRT Mode").

    • "Measurement Bandwidth": the amount of signal bandwidth to be captured
    • "Measurement Time": how long the input signal is to be captured

  5. Select the "Measurement" button and configure the expected signal characteristics.

    • In the "Signal Model" tab, select the "Chirp" signal model.
    • In the "Signal Detection" tab, define the known chirp states and the conditions for detection. (See "Signal Detection (Signal States)")
      In the "Frequency" and "Power" subtabs, define which parts of the chirp will be considered when calculating frequency and power parameters.
    • In the "Analysis Region" tab, define the frequency range and time gate (within the captured data) which is to be analyzed, that is, which chirps are to be detected. (See "Analysis Region".)

  6. If necessary, filter out unwanted signals using an FM video filter ("Demod Config" softkey).

  7. Select the "Result Config" button and configure the data basis for evaluation and display.

    • In the "Result Range" tab, define the area of the chirp to be analyzed in the result display. Define the area by a reference point, a length, and its alignment in relation to the chirp's center or edges. (See "Result Range".)
    • In the "Table Config" tab, define which parameters are to be displayed in the chirp result tables.
    • In the "Scale" and "Units" tabs, configure the value range for the y-axis in the individual result displays. (See "Y-Axis Scaling".)

  8. Select the "Display Config" button and select the displays that are of interest to you (up to 16, see "Display Configuration").

    Arrange them on the display to suit your preferences.

  9. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  10. Select the "Analysis" button in the "Overview" to make use of the advanced analysis functions in the displays.

    • Configure a trace to display the average over a series of sweeps or calculate chirp statistics (on the "Traces" tab, see "Trace Settings").
    • Configure markers and delta markers to determine deviations and offsets within the signal (on the "Marker" tab, see "Marker Settings").
    • Configure the Spectrogram display or FFT parameters (on the "Spectrogram" tab, see "Spectrogram Settings").

  11. Optionally, export the trace data of the demodulated signal to a file.

    1. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    2. Select "Export Trace to ASCII File".

    3. Define a file name and storage location and select "OK".

Contents
  • How to Export Table Data


How to Export Table Data

Transient Analysis (R&S FSW-K60) > How to Perform Transient Analysis > How to Export Table Data
How to Export Table Data

The measured result table data can be exported to an ASCII file. For each parameter, the measured values are output.

For details on the storage format see "Reference: ASCII File Export Format".

Table data can be exported either from the "Result Configuration" dialog box, or from the "Save/Recall" menu.

To export from the "Save/Recall" menu

  1. Select an active result table whose data you want to export.

  2. Select the [image] "Save" icon in the toolbar.

  3. Select the "Export" softkey.

  4. If necessary, change the decimal separator to be used for the ASCII export file.

  5. Select the "ASCII Table Export" softkey.

  6. In the file selection dialog box, select the storage location and file name for the export file.

  7. Select "Save" to close the dialog box and export the table data to the file.

To export from the "Result configuration" dialog box

  1. Press the "Overview" softkey.

  2. Select the "Result Config" button.

  3. Select the window that contains the result table in the "Specifics for" selection box.

  4. Select the "Table Config" tab.

  5. Select the vertical "Table Export" tab.

  6. Select whether you want to export all columns or only the currently visible columns of the table.

  7. If necessary, change the decimal separator to be used for the ASCII export file.

  8. Select the "Export Table to ASCII File" button.

  9. In the file selection dialog box, select the storage location and file name for the export file.

  10. Select "Save" to close the dialog box and export the table data to the file.


Measurement Examples

Transient Analysis (R&S FSW-K60) > Measurement Examples
Measurement Examples

The following measurement examples demonstrate some basic functions and measurement tasks, assuming the additional options R&S FSW-K60C/-K60H are installed.

Contents
  • Example: Hopped FM Signal
  • Example: Chirped FM Signal


Example: Hopped FM Signal

Transient Analysis (R&S FSW-K60) > Measurement Examples > Example: Hopped FM Signal
Example: Hopped FM Signal

A practical example for a basic transient analysis measurement is provided here. It demonstrates how to identify a hopped signal, how to detect hops, and how to analyze an individual hop.

The measurement is performed using the following devices:

  • An R&S FSW with application firmware R&S FSW-K60: Transient Analysis+ K60H (Hopped Transient Analysis) and bandwidth extension option R&S FSW-B160
  • A vector signal generator, e.g. R&S SMBV100A
Test setup
Signal generator settings (e.g. R&S SMBV100A):
Frequency: | 4 GHz
Level: | -30 dBm
Channels | CW-Hopping channel: 0 dB DC carrier: +20 dB
Hops | 20.0 / 20.2 / 20.4 / 20.6 / 20.8 / 21.0 MHz
Dwell time | 200 μs
Sample rate | 100 MHz
Settings in the R&S FSW Transient Analysis application
To identify a hopped FM signal

  1. Preset the R&S FSW.

  2. Set the center frequency to 4 GHz.

  3. Set the reference level to -30 dBm.

  4. Select the MODE key and then the "Transient Analysis" button.

  5. Select the signal model Hop.

  6. Set the measurement time to 5 ms.

  7. Set the measurement bandwidth to 160 MHz.

  8. The RF Spectrum and Full Spectrogram displays are dominated by the DC carrier. Define an analysis region to extract the hopped FM signal. Make sure that a sufficient number of hops are inside the analysis region. A second spectrogram showing the analysis region helps with fine tuning.

    Configuring an analysis region for a hopped FM signal

    1. From the "Meas Config" menu, select "Display Config".

    2. Drag a second spectrogram display to the right of the existing one on the screen.

    3. Exit the SmartGrid mode.

    4. Press the MEAS key, then select "Region" to restrict the Spectrogram display to the analysis region.

      By default, the analysis region corresponds to the entire capture buffer.

  9. From the "Meas Config" menu, select "Analysis Region Config".

    1. Define the starting point of the frequency range as an offset from the center frequency ("Delta").

    2. Define the width of the frequency range as a "Bandwidth". Be sure to include several hops in the frequency range.

    3. Define the starting point and the length of the time gate. Again, be sure to include several hops in the time gate.

  10. Since the signal model is set to "Hop", the hops are detected automatically. The detected hop states are listed in the order of their occurrence in the "Hop Detection Config" dialog box. From the "Meas Config" menu, select "Hop Detection Config" to check them.

    Detected hop states
To analyze an individual hop

All detected hops are indicated in the Hop Results Table. To analyze an individual hop in detail, open a Frequency Deviation display and reduce the spectrogram to a single hop.

  1. From the "Meas Config" menu, select "Display Config".

  2. Replace the Full Spectrogram display by a Frequency Deviation Time Domain display.

  3. Exit the SmartGrid mode.

  4. Select the Spectrogram display.

  5. Press the MEAS key, then select "Hop" to restrict the Spectrogram display to a single hop.

  6. Select "Select hop" and enter 7 to show the results for the hop number 7.

    Results for a single hop

    By default, both the Frequency Deviation and the Spectrogram displays show 100 % of the dwell time of the selected hop.

To analyze settling effects using a VBW filter

One possibility to remove noise from the Frequency Deviation trace is using a video filter with a smaller VBW.

  1. From the "Bandwidth" menu, select "FM Video BW".

  2. As the "FM Video Bandwidth", select Low Pass 1% BW.

    Note the impact on the Frequency Deviation trace. Settling effects on the hop FM are now clearly visible.

    Effect of the FM video bandwidth
To analyze settling effects by defining a result range

Another possibility to analyze the settling effects is by defining a result range. Move the result range to the hop begin to see the settling in more detail.

  1. From the "Meas Config" menu, select "Result Config".

  2. In the "Result Range" tab, set "Automatic Range Scaling" to Off.

  3. Set the reference point of the result range to Rise.

  4. Set the result range "Length" to 100 μs.

    Note that fewer spectrogram frames may be calculated as the result range length gets smaller.

    Hop displays for a result range at the beginning of the hop


Example: Chirped FM Signal

Transient Analysis (R&S FSW-K60) > Measurement Examples > Example: Chirped FM Signal
Example: Chirped FM Signal

The following example demonstrates how to detect chirps and how to analyze an individual chirp.

The measurement is performed using the following devices:

  • An R&S FSW with application firmware R&S FSW-K60: Transient Analysis +K60C (Chirped Transient Analysis) and bandwidth extension option R&S FSW-B160
  • A vector signal generator, e.g. R&S SMF
Test setup
Signal generator settings (e.g. R&S SMF):
Frequency: | 4 GHz
Level: | -30 dBm
Channels | Linear FM up/down chirp channel:±40 MHz (trapezoidal shape) Sinusoidal interference on FM with 10 kHz deviation and FM spike in up-chirp with 1 MHz deviation
Chirp length | 100 μs (= chirp rate 800 kHz/μs)
Sample rate | 100 MHz
R&S® SMF frequency modulation configuration for chirped FM signal example
Settings in the R&S FSW Transient Analysis application
To detect chirps in an FM signal

  1. Preset the R&S FSW.

  2. Set the center frequency to 4 GHz.

  3. Set the reference level to -30 dBm.

  4. Select the MODE key and then the "Transient Analysis" button.

  5. Select "Signal Description > Signal Model" and select the signal model Chirp.

  6. Set the measurement time to 1 ms.

  7. Set the measurement bandwidth to 160 MHz.

  8. Define an analysis region to extract the chirped FM signal. Make sure that a sufficient number of chirps are inside the analysis region.

    Configuring an analysis region for a chirped FM signal

    1. From the "Meas Config" menu, select "Analysis Region Config".

    2. Define the starting point of the frequency range as an offset from the center frequency ("Delta").

    3. Define the width of the frequency range as a "Bandwidth". Be sure to include several chirps in the frequency range.

    4. Define the starting point and the length of the time gate. Again, be sure to include several chirps in the time gate.

  9. The chirps are detected automatically. The detected chirp states are listed in the order of their occurrence in the "Chirp Detection Config" dialog box. From the "Meas Config" menu, select "Chirp Detection Config" to check them.

    Detected chirp states
To analyze the chirp results

All detected chirps are indicated in the Results Table.

Detected chirps

Note that the up-chirp is split up into two smaller chirps for some reason.

►

Increase the detection tolerance for the up-chirp and note the impact on the detected chirp length in the Results Table.

  1. From the "Meas Config" menu, select "Signal Description > Signal States".

  2. Set the "Auto Mode" for the Chirp States to Off.

  3. Select the "Tolerance" for the state index 0 and enter 200 kHz.

To analyze FM linearity

For radar systems using chirped FM signals, FM linearity is an important measurement.

The FM Time Domain and the Frequency Deviation Time Domain displays are useful to investigate interference of the chirp FM.

Typical display arrangement for FM linearity measurement

The Frequency Deviation display is dominated by noise, but a spike in the up-chirp is already clearly visible (this spike caused the up-chirp to be detected as two individual chirps).

To remove noise using trace averaging

Noise can be removed by averaging the Frequency Deviation Time Domain trace over multiple chirps.

  1. To restrict trace statistics to the up-chirp, discard all down-chirps by deleting the corresponding chirp state from the chirp state list.

    1. From the "Meas Config" menu, select "Signal Description > Signal States".

    2. Select the state index 1.

    3. Select "Delete".

  2. Restrict the Frequency Deviation Time Domain display to a single chirp.

    1. Select the Frequency Deviation Time Domain display.

    2. Press the MEAS key, then select "Chirp" to restrict the Frequency Deviation Time Domain display to a single chirp.

  3. Enable trace averaging for the Frequency Deviation Time Domain display.

    1. Press the TRACE key, then select "Trace Config".

    2. For trace 1, select the "Mode": Max Hold.

    3. For trace 2, select the "Mode": Average.

    4. For trace 3, select the "Mode": Min Hold.

    5. Define an average count of 1000.

    The display now shows the trace statistics as output of an auto peak detector of one chirp.

  4. For statistics over multiple chirps you must define a common result range to make sure that statistics are calculated over time intervals of a constant length.

    1. From the "Meas Config" menu, select "Result Config".

    2. In the "Result Range" tab, set "Automatic Range Scaling" to Off.

    3. Set the result range "Alignment" to the Center of the chirp.

    4. Set the result range "Length" to 90 μs.

    After averaging 1000 chirps, you see not only the the FM spike on the max trace, but also a sinusoidal interference on the average trace.

    Min/average/max traces for chirp Frequency Deviation
To limit the noise bandwidth using a video filter

The noise bandwidth can be reduced using a video filter.

  1. Disable trace averaging for the Frequency Deviation Time Domain display.

    1. Press the TRACE key, then select "Trace Config".

    2. For trace 1, select the "Mode": Clr/Write.

    3. For trace 2 and 3, select the "Mode": Blank.

  2. From the "Bandwidth" menu, select "FM Video Bandwidth".

  3. As the "FM Video Bandwidth", select Low Pass 1% BW.

    Note the different behavior of limiting the noise bandwidth by VBW filtering and trace averaging.

    Chirp Frequency Deviation clear/write trace with 1% VBW filter
    Chirp Frequency Deviation average trace (statistic count = 1000)


Optimizing and Troubleshooting

Transient Analysis (R&S FSW-K60) > Optimizing and Troubleshooting
Optimizing and Troubleshooting

If the results do not meet your expectations, or if problems occur during measurement, try the following solutions.

└ Too many hop/chirp states have been detected in auto mode
└ The desired hop/chirp states are not detected
└ Instead of one hop/chirp, several shorter hop/chirps of the same hop/chirp state are detected
└ Instead of one hop/chirp, several shorter hop/chirps of a different hop/chirp state are detected
└ One or more shorter hops/chirps are detected directly before or after the desired hop/chirp
└ Spectrogram of a selected hop/chirp is empty


Too many hop/chirp states have been detected in auto mode

Transient Analysis (R&S FSW-K60) > Optimizing and Troubleshooting > Too many hop/chirp states have been detected in auto mode
Too many hop/chirp states have been detected in auto mode

Switch auto mode off and edit hop/chirp state table manually (see "Signal Detection (Signal States)").

Usually, these unwanted hop/chirp states will not appear in the Results Table.


The desired hop/chirp states are not detected

Transient Analysis (R&S FSW-K60) > Optimizing and Troubleshooting > The desired hop/chirp states are not detected
The desired hop/chirp states are not detected

Make sure that a sufficient number of hops/chirps are inside the analysis region (see "Analysis Region").


Instead of one hop/chirp, several shorter hop/chirps of the same hop/chirp state are detected

Transient Analysis (R&S FSW-K60) > Optimizing and Troubleshooting > Instead of one hop/chirp, several shorter hop/chirps of the same hop/chirp state are detected
Instead of one hop/chirp, several shorter hop/chirps of the same hop/chirp state are detected

Increase the detection tolerance of the corresponding hop/chirp state (see "Tolerance").

Use a video filter with a smaller VBW (see "FM Video Bandwidth").


Instead of one hop/chirp, several shorter hop/chirps of a different hop/chirp state are detected

Transient Analysis (R&S FSW-K60) > Optimizing and Troubleshooting > Instead of one hop/chirp, several shorter hop/chirps of a different hop/chirp state are detected
Instead of one hop/chirp, several shorter hop/chirps of a different hop/chirp state are detected

Adjust the detection tolerance of the corresponding hop/chirp states to make sure that tolerance ranges do not overlap (see "Tolerance").

Use a video filter with a smaller VBW (see "FM Video Bandwidth").


One or more shorter hops/chirps are detected directly before or after the desired hop/chirp

Transient Analysis (R&S FSW-K60) > Optimizing and Troubleshooting > One or more shorter hops/chirps are detected directly before or after the desired hop/chirp
One or more shorter hops/chirps are detected directly before or after the desired hop/chirp

Specify a minimum and maximum dwell time/chirp length corresponding to the desired hop/chirp (see "Length").


Spectrogram of a selected hop/chirp is empty

Transient Analysis (R&S FSW-K60) > Optimizing and Troubleshooting > Spectrogram of a selected hop/chirp is empty
Spectrogram of a selected hop/chirp is empty

Increase the result range length (see "Length").


Remote Commands to Perform Transient Analysis

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis
Remote Commands to Perform Transient Analysis

The following commands are required to perform measurements in the Transient Analysis application in a remote environment. It is assumed that the R&S FSW has already been set up for remote operation in a network as described in the R&S FSW User Manual.

(See "How to Set Up a Network and Remote Control" .)

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

The following tasks specific to the Transient Analysis application are described here:

Contents
  • Introduction
  • Common Suffixes
  • Activating Transient Analysis
  • Configuring Transient Analysis
  • Capturing Data and Performing Sweeps
  • Analyzing Transient Effects
  • Configuring an Analysis Interval and Line (MSRA mode only)
  • Configuring an Analysis Interval and Line (MSRT mode only)
  • Retrieving Results
  • Status Reporting System
  • Programming Examples


Introduction

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Common Suffixes
Common Suffixes

In the Transient Analysis application, the following common suffixes are used in remote commands:

Suffix | Value range | Description
<m> | 1..16 | Marker
<n> | 1..16 | Window or Evaluation
<t> | 1..6 | Trace


Activating Transient Analysis

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Activating Transient Analysis
Activating Transient Analysis

Transient Analysis requires a special application on the R&S FSW. A measurement is started immediately with the default settings.

List of Commands
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate[:NEW]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Activating Transient Analysis > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Activating Transient Analysis > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Activating Transient Analysis > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Activating Transient Analysis > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Activating Transient Analysis > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Activating Transient Analysis > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Parameters:
<ChannelType>
TA

Transient Analysis application, R&S FSW–K60


SYSTem:PRESet:CHANnel[:EXECute]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Activating Transient Analysis > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Configuring Transient Analysis

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis
Configuring Transient Analysis

The following commands are required to configure a measurement for transient analysis.

Contents
  • Input/Output Settings
  • Frequency
  • Amplitude Settings
  • Triggering
  • Data Acquisition
  • Bandwidth Settings
  • Selecting the Signal Model
  • Configuring Signal Detection
  • Configuring the Measurement Range
  • Configuring Demodulation
  • Selecting the Analysis Region
  • Adjusting Settings Automatically


Input/Output Settings

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings
Input/Output Settings

The R&S FSW can analyze signals from different input sources (such as RF, power sensors etc.) and provide various types of output (such as noise or trigger signals). The following commands are required to configure data input and output.

Contents
  • RF Input
  • Using External Mixers
  • Configuring the Outputs


RF Input

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:COUPling

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut:SELect

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Radio Frequency State"


Using External Mixers

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers
Using External Mixers

The commands required to work with external mixers in a remote environment are described here. Note that these commands require the R&S FSW-B21 option to be installed and an external mixer to be connected to the front panel of the R&S FSW. In MSRA/MSRT mode, external mixers are not supported.

For details on working with external mixers see "Basics on External Mixers" .

Contents
  • Basic Settings
  • Mixer Settings
  • Conversion Loss Table Settings
  • Programming Example: Working with an External Mixer


Basic Settings

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Basic Settings
Basic Settings

The basic settings concern general usage of an external mixer.

List of Commands
[SENSe:]MIXer[:STATe]
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold


[SENSe:]MIXer[:STATe]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer[:STATe]
[SENSe:]MIXer[:STATe] <State>

Activates or deactivates the use of a connected external mixer as input for the measurement. This command is only available if the R&S FSW-B21 option is installed and an external mixer is connected.

(See "How to Work with External Mixers" ).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX ON
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "External Mixer State"


[SENSe:]MIXer:BIAS:HIGH

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS:HIGH <BiasSetting>

This command defines the bias current for the high (second) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Manual operation: See "Bias Settings"


[SENSe:]MIXer:BIAS[:LOW]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:BIAS[:LOW] <BiasSetting>

This command defines the bias current for the low (first) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Bias Settings"


[SENSe:]MIXer:LOPower

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOPower <Level>

This command specifies the LO level of the external mixer's LO port.

Parameters:
<Level>
numeric value
Range: | 13.0 dBm to 17.0 dBm
Increment: | 0.1 dB
*RST: | 15.5 dBm
Example: MIX:LOP 16.0dBm
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "LO Level"


[SENSe:]MIXer:SIGNal

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:SIGNal
[SENSe:]MIXer:SIGNal <State>

This command specifies whether automatic signal detection is active or not.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

Parameters:
<State>
OFF | ON | AUTO | ALL
OFF

No automatic signal detection is active.

ON

Automatic signal detection (Signal ID) is active.

AUTO

Automatic signal detection (Auto ID) is active.

ALL

Both automatic signal detection functions (Signal ID+Auto ID) are active.

*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Signal ID"
See "Auto ID"


[SENSe:]MIXer:THReshold

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:THReshold
[SENSe:]MIXer:THReshold <Value>

This command defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison (see [SENSe:​]MIXer:​SIGNal).

Parameters:
<Value>
<numeric value>
Range: | 0.1 dB to 100 dB
*RST: | 10 dB
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer"

Manual operation: See "Auto ID Threshold"


Mixer Settings

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings
Mixer Settings

The following commands are required to configure the band and specific mixer settings.

List of Commands
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]


[SENSe:]MIXer:FREQuency:HANDover

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:HANDover <Frequency>

This command defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency for each band can be selected freely within the overlapping frequency range.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Frequency> | numeric value
Example: | MIX ON Activates the external mixer. MIX:FREQ:HAND 78.0299GHz Sets the handover frequency to 78.0299 GHz.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Handover Freq."


[SENSe:]MIXer:FREQuency:STARt?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STARt?

This command queries the frequency at which the external mixer band starts.

Example: | MIX:FREQ:STAR? Queries the start frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:FREQuency:STOP?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:FREQuency:STOP?

This command queries the frequency at which the external mixer band stops.

Example: | MIX:FREQ:STOP? Queries the stop frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:HARMonic:BAND:PRESet

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND:PRESet

This command restores the preset frequency ranges for the selected standard waveguide band.

Note:Changes to the band and mixer settings are maintained even after using the PRESET function. Use this command to restore the predefined band ranges.

Example: | MIX:HARM:BAND:PRES Presets the selected waveguide band.
Usage: | Event
Manual operation: | See "Preset Band"


[SENSe:]MIXer:HARMonic:BAND[:VALue]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:BAND[:VALue] <Band>

This command selects the external mixer band. The query returns the currently selected band.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Band> | KA | Q | U | V | E | W | F | D | G | Y | J | USER Standard waveguide band or user-defined band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Band"
Frequency ranges for pre-defined bands
Band | Frequency start [GHz] | Frequency stop [GHz]
KA (A) *) | 26.5 | 40.0
Q | 33.0 | 50.0
U | 40.0 | 60.0
V | 50.0 | 75.0
E | 60.0 | 90.0
W | 75.0 | 110.0
F | 90.0 | 140.0
D | 110.0 | 170.0
G | 140.0 | 220.0
J | 220.0 | 325.0
Y | 325.0 | 500.0
USER | 32.18 (default) | 68.22 (default)
*) The band formerly referred to as "A" is now named "KA".


[SENSe:]MIXer:HARMonic:HIGH:STATe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH:STATe <State>

This command specifies whether a second (high) harmonic is to be used to cover the band's frequency range.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX:HARM:HIGH:STAT ON
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Range 1/2"


[SENSe:]MIXer:HARMonic:HIGH[:VALue]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:HIGH[:VALue] <HarmOrder>

This command specifies the harmonic order to be used for the high (second) range.

Parameters:
<HarmOrder
numeric value
Range: 2 to 61 (USER band); for other bands: see band definition
Example: MIX:HARM:HIGH 2
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:HARMonic:TYPE

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic:TYPE <OddEven>

This command specifies whether the harmonic order to be used should be odd, even, or both.

Which harmonics are supported depends on the mixer type.

Parameters:
<OddEven>
ODD | EVEN | EODD
*RST: EVEN
Example: MIX:HARM:TYPE ODD
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Type"


[SENSe:]MIXer:HARMonic[:LOW]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:HARMonic[:LOW] <HarmOrder>

This command specifies the harmonic order to be used for the low (first) range.

Parameters:
<HarmOrder>
numeric value
Range: | 2 to 61 (USER band); for other bands: see band definition
*RST: | 2 (for band F)
Example: MIX:HARM 3
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:LOSS:HIGH

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:HIGH <Average>

This command defines the average conversion loss to be used for the entire high (second) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS:HIGH 20dB
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe:HIGH

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH <FileName>

This command defines the file name of the conversion loss table to be used for the high (second) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL:HIGH 'MyCVLTable'
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe[:LOW]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS:TABLe[:LOW] <FileName>

This command defines the file name of the conversion loss table to be used for the low (first) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL 'mix_1_4' Specifies the conversion loss table mix_1_4.
Example: | See "Configuring a conversion loss table for a user-defined band"
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS[:LOW]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:LOSS[:LOW] <Average>

This command defines the average conversion loss to be used for the entire low (first) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS 20dB
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:PORTs

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:PORTs
[SENSe:]MIXer:PORTs <PortType>

This command specifies whether the mixer is a 2-port or 3-port type.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Mixer Type"


[SENSe:]MIXer:RFOVerrange[:STATe]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:RFOVerrange[:STATe] <State>

If enabled, the band limits are extended beyond "RF Start" and "RF Stop" due to the capabilities of the used harmonics.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "RF Overrange"


Conversion Loss Table Settings

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings
Conversion Loss Table Settings

The following settings are required to configure and manage conversion loss tables.

List of Commands
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber


[SENSe:]CORRection:CVL:BAND

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BAND <Type>

This command defines the waveguide band for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Band>
K | A | KA | Q | U | V | E | W | F | D | G | Y | J | USER

Standard waveguide band or user-defined band.

Note: The band formerly referred to as "A" is now named "KA"; the input parameter "A" is still available and refers to the same band as "KA".

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

*RST: F (90 GHz - 140 GHz)
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BAND KA

Sets the band to KA (26.5 GHz - 40 GHz).

Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Band"


[SENSe:]CORRection:CVL:BIAS

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:BIAS <BiasSetting>

This command defines the bias setting to be used with the conversion loss table.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<BiasSetting>
numeric value
*RST: | 0.0 A
Default unit: | A
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BIAS 3A
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Write to <CVL table name>"
See "Bias"


[SENSe:]CORRection:CVL:CATAlog?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CATAlog?

This command queries all available conversion loss tables saved in the C:\r_s\instr\user\cvl\ directory on the instrument.

This command is only available with option B21 (External Mixer) installed.

Usage: Query only


[SENSe:]CORRection:CVL:CLEAr

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:CLEAr

This command deletes the selected conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:CLE
Usage: | Event
Manual operation: | See "Delete Table"


[SENSe:]CORRection:CVL:COMMent

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:COMMent <Text>

This command defines a comment for the conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Text> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:COMM 'Conversion loss table for FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Comment"


[SENSe:]CORRection:CVL:DATA

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:DATA <Freq>,<Level>

This command defines the reference values of the selected conversion loss tables. The values are entered as a set of frequency/level pairs. A maximum of 50 frequency/level pairs may be entered. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Freq> | numeric value The frequencies have to be sent in ascending order.
<Level> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:DATA 1MHZ,-30DB,2MHZ,-40DB
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Position/Value"


[SENSe:]CORRection:CVL:HARMonic

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:HARMonic <HarmOrder>

This command defines the harmonic order for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<HarmOrder>
numeric value
Range: 2 to 65
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:HARM 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]CORRection:CVL:MIXer

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:MIXer <Type>

This command defines the mixer name in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Type> | string Name of mixer with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX 'FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer Name"


[SENSe:]CORRection:CVL:PORTs

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:PORTs <PortNo>

This command defines the mixer type in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:PORT 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Mixer Type"


[SENSe:]CORRection:CVL:SELect

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SELect <FileName>

This command selects the conversion loss table with the specified file name. If <file_name> is not available, a new conversion loss table is created.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<FileName> | '<File name>'
Example: | CORR:CVL:SEL 'LOSS_TAB_4'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "New Table" See "Edit Table" See "File Name"


[SENSe:]CORRection:CVL:SNUMber

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:CVL:SNUMber <SerialNo>

This command defines the serial number of the mixer for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<SerialNo> | Serial number with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX '123.4567'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer S/N"


Programming Example: Working with an External Mixer

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Using External Mixers > Programming Example: Working with an External Mixer
Programming Example: Working with an External Mixer

This example demonstrates how to work with an external mixer in a remote environment. It is performed in the Spectrum application in the default layout configuration. Note that without a real input signal and connected mixer, this measurement will not return useful results.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//----------- Configuring basic mixer behavior -------------
//Set the LO level of the mixer's LO port to 15 dBm.
SENS:MIX:LOP 15dBm
//Set the bias current to -1 mA .
SENS:MIX:BIAS:LOW -1mA
//----------- Configuring the mixer and band settings -------------
//Use band "V" to full possible range extent for assigned harmonic (6).
SENS:MIX:HARM:BAND V
SENS:MIX:RFOV ON
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)
//Use a 3-port mixer type
SENS:MIX:PORT 3
//Split the frequency range into two ranges;
//range 1 covers 47.48 GHz GHz to 80 GHz; harmonic 6, average conv. loss of 20 dB
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:LOW  20dB
SENS:MIX:HARM:HIGH 8
SENS:MIX:LOSS:HIGH 30dB
//--------- Activating automatic signal identification functions -----------
//Activate both automatic signal identification functions.
SENS:MIX:SIGN ALL
//Use auto ID threshold of 8 dB.
SENS:MIX:THR 8dB

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data for the input signal without distortions
//(default screen configuration)
TRAC:DATA? TRACE3
Configuring a conversion loss table for a user-defined band
//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//--------------Configuring a new conversion loss table --------------
//Define cvl table for range 1 of band as described in previous example
// (extended V band)
SENS:CORR:CVL:SEL 'UserTable'
SENS:CORR:CVL:COMM 'User-defined conversion loss table for USER band'
SENS:CORR:CVL:BAND USER
SENS:CORR:CVL:HARM 6
SENS:CORR:CVL:BIAS -1mA
SENS:CORR:CVL:MIX 'FS_Z60'
SENS:CORR:CVL:SNUM '123.4567'
SENS:CORR:CVL:PORT 3
//Conversion loss is linear from 55 GHz to 75 GHz
SENS:CORR:CVL:DATA 55GHZ,-20DB,75GHZ,-30DB
//----------- Configuring the mixer and band settings -------------
//Use user-defined band and assign new cvl table.
SENS:MIX:HARM:BAND USER
//Define band by two ranges;
//range 1 covers 47.48 GHz to 80 GHz; harmonic 6, cvl table 'UserTable'
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:TABL:LOW 'UserTable'
SENS:MIX:HARM:HIGH 8

SENS:MIX:LOSS:HIGH 30dB
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data (default screen configuration)
TRAC:DATA? TRACe1


Configuring the Outputs

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF:IFFRequency


DIAGnostic:SERVice:NSOurce

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF:IFFRequency

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Input/Output Settings > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

Parameters:
<Frequency>
*RST: 50.0 MHz


Frequency

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Frequency
Frequency
List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:OFFSet


[SENSe:]FREQuency:CENTer

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:OFFSet

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

Note: In MSRA/MSRT mode, the setting command is only available for the MSRA/MSRT Master. For MSRA/MSRT applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Amplitude Settings

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Amplitude Settings
Amplitude Settings

The following commands are required to configure the amplitude settings in a remote environment.

Useful commands for amplitude settings described elsewhere:
  • INPut:​COUPling
  • INPut:​IMPedance
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO
Remote commands exclusive to amplitude settings:
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


INPut:GAIN:STATe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Amplitude Settings > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Amplitude Settings > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:ATTenuation

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Amplitude Settings > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Amplitude Settings > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Amplitude Settings > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Amplitude Settings > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Amplitude Settings > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Triggering

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering
Triggering

The following remote commands are required to configure a triggered measurement in a remote environment. More details are described for manual operation in "Trigger Settings".

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. Thus, no trigger settings are available in the Transient Analysis application in MSRA/MSRT operating mode. However, a capture offset can be defined with a similar effect as a trigger offset. It defines an offset from the start of the captured data (from the MSRA/MSRT Master) to the start of the application data for transient analysis. (See "Configuring an Analysis Interval and Line (MSRA mode only)".)

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

*OPC should be used after requesting data. This will hold off any subsequent changes to the selected trigger source, until after the sweep is completed and the data is returned.

Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output


Configuring the Triggering Conditions

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce


TRIGger[:SEQuence]:DTIMe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>
*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:IFPower

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .


TRIGger[:SEQuence]:LEVel:IQPower

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .


TRIGger[:SEQuence]:LEVel:RFPower

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm


TRIGger[:SEQuence]:SLOPe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

IFPower

Second intermediate frequency

IQPower

Magnitude of sampled I/Q data

For applications that process I/Q data, such as the I/Q Analyzer or optional applications.

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "IF Power"
See "I/Q Power"
See "RF Power"


Configuring the Trigger Output

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Data Acquisition

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Data Acquisition
Data Acquisition

You must define how much and how data is captured from the input signal.

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. The data acquisition settings for the Transient Analysis application in MSRA/MSRT mode define the application data extract and analysis interval.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

List of Commands
[SENSe:]BANDwidth|BWIDth:DEMod
[SENSe:]MTIMe
[SENSe:]RLENgth
[SENSe:]SRATe


[SENSe:]BANDwidth|BWIDth:DEMod

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Data Acquisition > [SENSe:]BANDwidth|BWIDth:DEMod
[SENSe:]BANDwidth|BWIDth:DEMod <Bandwidth>

Defines the measurement bandwidth in Hz.

Note that the sample rate and the measurement bandwidth are interdependent (see [SENSe:​]SRATe). For information on supported sample rates and bandwidths see the data sheet.

Parameters:
<Bandwidth>
Range: | 80 Hz to depends on options installed
*RST: | maximum allowed
Default unit: | HZ
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Measurement Bandwidth"


[SENSe:]MTIMe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Data Acquisition > [SENSe:]MTIMe
[SENSe:]MTIMe <MeasTime>

This command defines the time data is captured. Note that the record length and the measurement time are interdependent (see [SENSe:​]RLENgth).

Parameters:
<MeasTime>
Range: | 18.75 us to 1.298 ms
*RST: | 350 us
Default unit: | S
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Measurement Time"


[SENSe:]RLENgth

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Data Acquisition > [SENSe:]RLENgth
[SENSe:]RLENgth <SampleCount>

This command defines the record length (in samples) for the current measurement. Note that the record length and the measurement time are interdependent (see [SENSe:​]MTIMe).

Parameters:
<SampleCount>

The maximum record length is limited only by the available memory.

*RST: 140000
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Record Length"


[SENSe:]SRATe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Data Acquisition > [SENSe:]SRATe
[SENSe:]SRATe <SampleRate>

This command defines the sample rate for the current measurement.

Note that the sample rate and the measurement bandwidth are interdependent (see [SENSe:​]BANDwidth|BWIDth:​DEMod). For information on supported sample rates and bandwidths see the data sheet.

Parameters:
<SampleRate>
Range: | 100 Hz to depends on installed options
*RST: | maximum allowed
Example: SRATe 100e6
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Sample Rate"


Bandwidth Settings

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Bandwidth Settings
Bandwidth Settings
Useful commands for bandwidth settings described elsewhere:
  • [SENSe:​]SWEep:​FFT:​WINDow:​TYPE
  • CALCulate<n>:​SGRam|SPECtrogram:​TRESolution
  • CALCulate<n>:​SGRam|SPECtrogram:​TRESolution:​AUTO
  • [SENSe:​]MTIMe
  • [SENSe:​]BANDwidth|BWIDth:​DEMod
  • [SENSe:​][DEMod:​]FMVF:​TYPE
Remote commands exclusive to bandwidth settings:
List of Commands
[SENSe:]BANDwidth|BWIDth[:WINDow<n>]:RATio
[SENSe:]BANDwidth|BWIDth[:WINDow<n>]:RESolution


[SENSe:]BANDwidth|BWIDth[:WINDow<n>]:RATio

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Bandwidth Settings > [SENSe:]BANDwidth|BWIDth[:WINDow<n>]:RATio
[SENSe:]BANDwidth|BWIDth[:WINDow<n>]:RATio <Bandwidth Ratio>

This command sets the bandwidth ratio.

Parameters:
<Bandwidth Ratio> |
Manual operation: | See "ABW / RBW"


[SENSe:]BANDwidth|BWIDth[:WINDow<n>]:RESolution

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Bandwidth Settings > [SENSe:]BANDwidth|BWIDth[:WINDow<n>]:RESolution
[SENSe:]BANDwidth|BWIDth[:WINDow<n>]:RESolution <Bandwidth Resolution>

This command sets the bandwidth resolution in HZ.

Parameters:
<Bandwidth Resolution> |
Manual operation: | See "RBW"


Selecting the Signal Model

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Signal Model
Selecting the Signal Model

The signal model defines which type of signal to expect (if known), thus determining the analysis method. These settings are only available if the additional options R&S FSW-K60C/-K60H are installed.

List of Commands
[SENSe:]SIGNal:MODel


[SENSe:]SIGNal:MODel

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Signal Model > [SENSe:]SIGNal:MODel
[SENSe:]SIGNal:MODel <Signal>

Defines which type of signal to expect (if known), thus determining the analysis method.

This command is only required if the additional options R&S FSW-K60C/-K60H are installed.

Parameters:
<Signal> | HOP | CHIRp | NONE HOP Signals "hop" between random carrier frequencies in short intervals CHIRp The carrier frequency is either increased or decreased linearly over time NONE No specific signal model is used; this is the default setting if no additional options are installed
Example: | See "Programming Example: Performing a Chirp Detection Measurement".
Example: | See "Programming Example: Performing a Hop Detection Measurement".
Manual operation: | See "Hop Model / Chirp Model"


Configuring Signal Detection

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection
Configuring Signal Detection

The signal detection settings define the conditions under which a hop/chirp is detected within the input signal.

These commands are only available if the additional options R&S FSW-K60C/-K60H are installed.

List of Commands
CALCulate:CHRDetection:LENGth:AUTO
CALCulate:CHRDetection:LENGth:MAXimum
CALCulate:CHRDetection:LENGth:MINimum
CALCulate:CHRDetection:STATes:AUTO
CALCulate:CHRDetection:STATes[:DATA]
CALCulate:HOPDetection:DWELl:AUTO
CALCulate:HOPDetection:DWELl:MAXimum
CALCulate:HOPDetection:DWELl:MINimum
CALCulate:HOPDetection:STATes:AUTO
CALCulate:HOPDetection:STATes[:DATA]


CALCulate:CHRDetection:LENGth:AUTO

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection > CALCulate:CHRDetection:LENGth:AUTO
CALCulate:CHRDetection:LENGth:AUTO <State>

This command activates and deactivates the auto length setting for chirp detection.

Parameters:
<State>
ON | OFF
*RST: ON
Example: CALC:CHRD:LENG:AUTO ON
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Manual operation: See "Auto Mode"


CALCulate:CHRDetection:LENGth:MAXimum

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection > CALCulate:CHRDetection:LENGth:MAXimum
CALCulate:CHRDetection:LENGth:MAXimum <Time>

This command sets the maximum time for chirp detection. Note this command is only available for manual timing mode (see CALCulate:​CHRDetection:​LENGth:​AUTO).

Parameters:
<Time>
Range: | 0 to 0.00129822
*RST: | 0.00035
Default unit: | S
Example: CALC:CHRD:LENG:MAX 0.00035
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Manual operation: See "Minimum / Maximum"


CALCulate:CHRDetection:LENGth:MINimum

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection > CALCulate:CHRDetection:LENGth:MINimum
CALCulate:CHRDetection:LENGth:MINimum <Time>

Defines the minimum chirp length for detection.

Parameters:
<Time>
Range: | 0 to 0.00129822
*RST: | 0.000001
Default unit: | S
Example: CALC:CHRD:LENG:MIN 0.000001
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Manual operation: See "Minimum / Maximum"


CALCulate:CHRDetection:STATes:AUTO

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection > CALCulate:CHRDetection:STATes:AUTO
CALCulate:CHRDetection:STATes:AUTO <State>

This command activates and deactivates the auto chirp state detection. If deactivated, the states defined using CALCulate:​CHRDetection:​STATes[:​DATA] are used.

Parameters:
<State>
ON | OFF
*RST: ON
Example: CALC:CHRD:STAT:AUTO ON
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Manual operation: See "Auto Mode"


CALCulate:CHRDetection:STATes[:DATA]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection > CALCulate:CHRDetection:STATes[:DATA]
CALCulate:CHRDetection:STATes[:DATA] {<ChirpRate>, <Tolerance>}...

This command sets and queries the chirp state detection table. It consists of a comma separated list of value pairs, one for each possible chirp state.

Note that the state table can only be configured manually if CALCulate:​CHRDetection:​STATes:​AUTO is OFF.

Setting parameters:
<ChirpRate>
Default unit: HZ
<Tolerance>

Tolerance above or below the nominal chirp rate.

Default unit: HZ
Example: CALC:CHRD:STAT 1e6, 0.3, 1e5, 0.4
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Manual operation: See "Frequency Offset / Chirp Rate"
See "Tolerance"


CALCulate:HOPDetection:DWELl:AUTO

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection > CALCulate:HOPDetection:DWELl:AUTO
CALCulate:HOPDetection:DWELl:AUTO <State>

This command activates and deactivates the auto dwell setting for hop detection.

Parameters:
<State>
ON | OFF
*RST: ON
Example: CALC:HOPD:DWEL:AUTO ON
Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Auto Mode"


CALCulate:HOPDetection:DWELl:MAXimum

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection > CALCulate:HOPDetection:DWELl:MAXimum
CALCulate:HOPDetection:DWELl:MAXimum <Time>

This command sets the maximum time for hop detection. Note this command is only available for manual timing mode (see CALCulate:​HOPDetection:​DWELl:​AUTO).

Parameters:
<Time>
Range: | 0 to 0.00129822
*RST: | 0.00035
Default unit: | S
Example: CALC:HOPD:DWEL:MAX 0.00129822
Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Minimum / Maximum"


CALCulate:HOPDetection:DWELl:MINimum

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection > CALCulate:HOPDetection:DWELl:MINimum
CALCulate:HOPDetection:DWELl:MINimum <Time>

This command sets the minimum dwell time for hop detection. Note this command is only available for manual timing mode (see CALCulate:​HOPDetection:​DWELl:​AUTO).

Parameters:
<Time>
Range: | 0 to 0.00129822
*RST: | 0.000001
Default unit: | S
Example: CALC:HOPD:DWEL:MIN 0.000001
Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Minimum / Maximum"


CALCulate:HOPDetection:STATes:AUTO

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection > CALCulate:HOPDetection:STATes:AUTO
CALCulate:HOPDetection:STATes:AUTO <State>

This command activates and deactivates the auto hop state detection. If deactivated, the states defined using CALCulate:​HOPDetection:​STATes[:​DATA] are used.

Parameters:
<State>
ON | OFF
*RST: ON
Example: CALC:HOPD:STAT:AUTO ON
Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Auto Mode"


CALCulate:HOPDetection:STATes[:DATA]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Signal Detection > CALCulate:HOPDetection:STATes[:DATA]
CALCulate:HOPDetection:STATes[:DATA] {<FreqOffset>, <Tolerance>}...

This command sets and queries the hop state detection table. It consists of a comma separated list of value pairs, one for each possible hop state.

Note that the state table can only be configured manually if CALCulate:​HOPDetection:​STATes:​AUTO is OFF.

Setting parameters:
<FreqOffset>

Frequency offsets from the center frequency

Default unit: HZ
<Tolerance>

Tolerance above or below the nominal frequency.

Default unit: HZ
Example: CALC:HOPD:STAT 1e6, 0.3, 1e5, 0.4
Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Frequency Offset / Chirp Rate"
See "Tolerance"


Configuring the Measurement Range

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range
Configuring the Measurement Range

For some frequency or power calculations, it may be useful not to take the entire dwell time of the hop or length of the chirp into consideration, but only a certain range within the dwell time/length.

These settings are only available if the additional options R&S FSW-K60C/-K60H are installed.

List of Commands
CALCulate:CHRDetection:FREQuency:LENGth
CALCulate:CHRDetection:FREQuency:OFFSet:BEGin
CALCulate:CHRDetection:FREQuency:OFFSet:END
CALCulate:CHRDetection:FREQuency:REFerence
CALCulate:CHRDetection:POWer:LENGth
CALCulate:CHRDetection:POWer:OFFSet:BEGin
CALCulate:CHRDetection:POWer:OFFSet:END
CALCulate:CHRDetection:POWer:REFerence
CALCulate:HOPDetection:FREQuency:LENGth
CALCulate:HOPDetection:FREQuency:OFFSet:BEGin
CALCulate:HOPDetection:FREQuency:OFFSet:END
CALCulate:HOPDetection:FREQuency:REFerence
CALCulate:HOPDetection:POWer:LENGth
CALCulate:HOPDetection:POWer:OFFSet:BEGin
CALCulate:HOPDetection:POWer:OFFSet:END
CALCulate:HOPDetection:POWer:REFerence


CALCulate:CHRDetection:FREQuency:LENGth

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:CHRDetection:FREQuency:LENGth
CALCulate:CHRDetection:FREQuency:LENGth <Percent>

Defines the length of the measurement range for frequency results in percent of the chirp length. This command is only available if the reference is CENT (see CALCulate:​CHRDetection:​POWer:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Percent>

percent of the chirp length

Range: | 0 to 100
*RST: | 100
Example: CALC:CHRD:FREQ:LENG 10
Manual operation: See "Length"


CALCulate:CHRDetection:FREQuency:OFFSet:BEGin

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:CHRDetection:FREQuency:OFFSet:BEGin
CALCulate:CHRDetection:FREQuency:OFFSet:BEGin <Time>

Defines the beginning of the measurement range for power results as an offset in seconds from the chirp start. This command is only available if the reference is EDGE (see CALCulate:​CHRDetection:​FREQuency:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Time>
Default unit: S
Example: CALC:CHRD:FREQ:OFFS:BEG 3e-6
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Manual operation: See "Offset Begin / Offset End"


CALCulate:CHRDetection:FREQuency:OFFSet:END

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:CHRDetection:FREQuency:OFFSet:END
CALCulate:CHRDetection:FREQuency:OFFSet:END <Time>

Defines the end of the measurement range for frequency results as an offset in seconds from the chirp end. This command is only available if the reference is EDGE (see CALCulate:​CHRDetection:​FREQuency:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Time>
Default unit: S
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Manual operation: See "Offset Begin / Offset End"


CALCulate:CHRDetection:FREQuency:REFerence

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:CHRDetection:FREQuency:REFerence
CALCulate:CHRDetection:FREQuency:REFerence <Reference>

Defines the reference point for positioning the frequency measurement range.

For details on the measurement range parameters see "Measurement Range".

Setting parameters:
<Reference> | CENTer | EDGE EDGE The measurement range is defined in reference to the chirp's rising or falling edge (see CALCulate:​CHRDetection:​FREQuency:​OFFSet:​BEGin and CALCulate:​CHRDetection:​FREQuency:​OFFSet:​END). CENTer The measurement range is defined in reference to the center of the chirp.
Example: | CALC:CHRD:FREQ:REF CENTer
Example: | See "Programming Example: Performing a Chirp Detection Measurement".
Manual operation: | See "Reference"


CALCulate:CHRDetection:POWer:LENGth

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:CHRDetection:POWer:LENGth
CALCulate:CHRDetection:POWer:LENGth <Percent>

Defines the length of the measurement range for power results in percent of the chirp length. This command is only available if the reference is CENT (see CALCulate:​CHRDetection:​POWer:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Percent> | percent of the chirp length
Example: | CALC:CHRD:POW:LENG 2e-4
Example: | See "Programming Example: Performing a Chirp Detection Measurement".
Manual operation: | See "Length"


CALCulate:CHRDetection:POWer:OFFSet:BEGin

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:CHRDetection:POWer:OFFSet:BEGin
CALCulate:CHRDetection:POWer:OFFSet:BEGin <Time>

Defines the beginning of the measurement range for power results as an offset in seconds from the chirp start. This command is only available if the reference is EDGE (see CALCulate:​CHRDetection:​POWer:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Time>
Default unit: S
Example: CALC:CHRD:POW:OFFS 50
Manual operation: See "Offset Begin / Offset End"


CALCulate:CHRDetection:POWer:OFFSet:END

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:CHRDetection:POWer:OFFSet:END
CALCulate:CHRDetection:POWer:OFFSet:END <Time>

Defines the end of the measurement range for power results as an offset in seconds from the chirp end. This command is only available if the reference is EDGE (see CALCulate:​CHRDetection:​POWer:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Time>
Default unit: S
Example: CALC:CHRD:POW:OFFS 50
Manual operation: See "Offset Begin / Offset End"


CALCulate:CHRDetection:POWer:REFerence

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:CHRDetection:POWer:REFerence
CALCulate:CHRDetection:POWer:REFerence <Reference>

Defines the reference point for positioning the power measurement range.

For details on the measurement range parameters see "Measurement Range".

Setting parameters:
<Reference> | CENTer | EDGE EDGE The measurement range for power results is defined in reference to the chirp's rising or falling edge (see CALCulate:​CHRDetection:​POWer:​OFFSet:​BEGin and CALCulate:​CHRDetection:​POWer:​OFFSet:​END). CENTer The measurement range is defined in reference to the center of the chirp.
Example: | CALC:CHRD:POW:REF EDGE
Example: | See "Programming Example: Performing a Chirp Detection Measurement".
Manual operation: | See "Reference"


CALCulate:HOPDetection:FREQuency:LENGth

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:HOPDetection:FREQuency:LENGth
CALCulate:HOPDetection:FREQuency:LENGth <Percent>

Defines the length of the measurement range for frequency results in percent of the hop's dwell time. This command is only available if the reference is CENT (see CALCulate:​HOPDetection:​FREQuency:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Percent>

percent of the hop dwell time

Range: | 0 to 100
*RST: | 100
Example: CALC:HOPD:FREQ:LENG 10
Manual operation: See "Length"


CALCulate:HOPDetection:FREQuency:OFFSet:BEGin

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:HOPDetection:FREQuency:OFFSet:BEGin
CALCulate:HOPDetection:FREQuency:OFFSet:BEGin <time>

Defines the beginning of the measurement range for frequency results as an offset in seconds from the hop start. This command is only available if the reference is EDGE (see CALCulate:​HOPDetection:​FREQuency:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Time>
Default unit: S
Example: CALC:HOPD:FREQ:OFFS:BEG 3e-6
Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Offset Begin / Offset End"


CALCulate:HOPDetection:FREQuency:OFFSet:END

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:HOPDetection:FREQuency:OFFSet:END
CALCulate:HOPDetection:FREQuency:OFFSet:END <Time>

Defines the end of the measurement range for frequency results as an offset in seconds from the hop end. This command is only available if the reference is EDGE (see CALCulate:​HOPDetection:​FREQuency:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Time>
Default unit: S
Example: CALC:HOPD:FREQ:OFFS:END 3e-6
Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Offset Begin / Offset End"


CALCulate:HOPDetection:FREQuency:REFerence

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:HOPDetection:FREQuency:REFerence
CALCulate:HOPDetection:FREQuency:REFerence <Reference>

Defines the reference point for positioning the frequency measurement range.

For details on the measurement range parameters see "Measurement Range".

Setting parameters:
<Reference> | CENTer | EDGE EDGE The measurement range is defined in reference to the hop' rising or falling edge (see CALCulate:​HOPDetection:​FREQuency:​OFFSet:​BEGin and CALCulate:​HOPDetection:​FREQuency:​OFFSet:​END). CENTer The measurement range is defined in reference to the center of the hop.
Example: | CALC:HOPD:FREQ:REF CENTer
Example: | See "Programming Example: Performing a Hop Detection Measurement".
Manual operation: | See "Reference"


CALCulate:HOPDetection:POWer:LENGth

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:HOPDetection:POWer:LENGth
CALCulate:HOPDetection:POWer:LENGth <Percent>

Defines the length of the measurement range in percent of the dwell time. This command is only available if the reference is CENT (see CALCulate:​HOPDetection:​POWer:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Percent> |
Example: | CALC:HOPD:POW:LENG 2e-4
Example: | See "Programming Example: Performing a Hop Detection Measurement".
Manual operation: | See "Length"


CALCulate:HOPDetection:POWer:OFFSet:BEGin

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:HOPDetection:POWer:OFFSet:BEGin
CALCulate:HOPDetection:POWer:OFFSet:BEGin <Time>

Defines the beginning of the measurement range as an offset in seconds from the hop start. This command is only available if the reference is EDGE (see CALCulate:​HOPDetection:​POWer:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Time>
Default unit: S
Example: CALC:HOPD:POW:OFFS 50
Manual operation: See "Offset Begin / Offset End"


CALCulate:HOPDetection:POWer:OFFSet:END

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:HOPDetection:POWer:OFFSet:END
CALCulate:HOPDetection:POWer:OFFSet:END <time>

Defines the end of the measurement range as an offset in seconds from the hop end. This command is only available if the reference is EDGE (see CALCulate:​HOPDetection:​POWer:​REFerence).

For details on the measurement range parameters see "Measurement Range".

Parameters:
<Time>
Default unit: S
Example: CALC:HOPD:POW:OFFS 50
Manual operation: See "Offset Begin / Offset End"


CALCulate:HOPDetection:POWer:REFerence

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring the Measurement Range > CALCulate:HOPDetection:POWer:REFerence
CALCulate:HOPDetection:POWer:REFerence <Reference>

Defines the reference point for positioning the frequency/power measurement range.

For details on the measurement range parameters see "Measurement Range".

Setting parameters:
<Reference> | CENTer | EDGE EDGE The measurement range is defined in reference to the hop' rising or falling edge (see CALCulate:​HOPDetection:​POWer:​OFFSet:​BEGin and CALCulate:​HOPDetection:​POWer:​OFFSet:​END). CENTer The measurement range is defined in reference to the center of the hop.
Example: | CALC:HOPD:POW:REF EDGE
Example: | See "Programming Example: Performing a Hop Detection Measurement".
Manual operation: | See "Reference"


Configuring Demodulation

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Demodulation
Configuring Demodulation
List of Commands
[SENSe:][DEMod:]FMVF:TYPE


[SENSe:][DEMod:]FMVF:TYPE

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Configuring Demodulation > [SENSe:][DEMod:]FMVF:TYPE
[SENSe:][DEMod:]FMVF:TYPE <Filter>

Activates or deactivates additional filters applied after demodulation to filter out unwanted signals, or correct pre-emphasized input signals.

Parameters:
<Filter> | NONE | LP01 | LP1 | LP5 | LP10 | LP25 NONE No video filter applied LP01 Low pass filter 0.1 % bandwidth LP1 Low pass filter1 % bandwidth LP5 Low pass filter 5 % bandwidth LP10 Low pass filter 10 % bandwidth LP25 Low pass filter 25 % bandwidth
Example: | FMVF:TYPE LP01
Manual operation: | See "FM Video Bandwidth"


Selecting the Analysis Region

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Analysis Region
Selecting the Analysis Region

The analysis region determines which data is displayed on the screen (see also "Analysis Region").

List of Commands
CALCulate:AR:FREQuency:BANDwidth
CALCulate:AR:FREQuency:DELTa
CALCulate:AR:FREQuency:PERCent
CALCulate:AR:FREQuency:PERCent:STATe
CALCulate:AR:TIME:LENGth
CALCulate:AR:TIME:PERCent
CALCulate:AR:TIME:PERCent:STATe
CALCulate:AR:TIME:STARt


CALCulate:AR:FREQuency:BANDwidth

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Analysis Region > CALCulate:AR:FREQuency:BANDwidth
CALCulate:AR:FREQuency:BANDwidth <Frequency>

This command defines the analysis region's bandwidth.

Parameters:
<Frequency>
Default unit: HZ
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Analysis Bandwidth"


CALCulate:AR:FREQuency:DELTa

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Analysis Region > CALCulate:AR:FREQuency:DELTa
CALCulate:AR:FREQuency:DELTa <Frequency>

Defines the center of the frequency span for the analysis region. It is defined as an offset from the center frequency.

Parameters:
<Frequency>
Default unit: HZ
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Delta Frequency"


CALCulate:AR:FREQuency:PERCent

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Analysis Region > CALCulate:AR:FREQuency:PERCent
CALCulate:AR:FREQuency:PERCent <BWPercent>

For CALCulate:​AR:​FREQuency:​PERCent:​STATe TRUE, the width of the frequency span for the analysis region is defined as a percentage of the full capture buffer. It is centered around the point defined by CALCulate:​AR:​FREQuency:​DELTa.

Parameters:
<BWPercent> | percentage of the full analysis bandwidth
Manual operation: | See "Linked analysis bandwidth"


CALCulate:AR:FREQuency:PERCent:STATe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Analysis Region > CALCulate:AR:FREQuency:PERCent:STATe
CALCulate:AR:FREQuency:PERCent:STATe <State>

If activated, the width of the frequency span for the analysis region is defined as a percentage of the full capture buffer (using CALCulate:​AR:​FREQuency:​PERCent).

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Linked analysis bandwidth"


CALCulate:AR:TIME:LENGth

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Analysis Region > CALCulate:AR:TIME:LENGth
CALCulate:AR:TIME:LENGth <Length>

Defines the length of the time gate, that is, the duration (or height) of the analysis region.

Parameters:
<Length>
Default unit: S
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Time Gate Length"


CALCulate:AR:TIME:PERCent

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Analysis Region > CALCulate:AR:TIME:PERCent
CALCulate:AR:TIME:PERCent <TimePercent>

For CALCulate:​AR:​TIME:​PERCent:​STATe TRUE,the length of the time gate, that is, the duration (or height) of the analysis region, is defined as a percentage of the full measurement time. The time gate start is the start of the capture buffer plus an offset defined by CALCulate:​AR:​TIME:​STARt.

Parameters:
<TimePercent> | percentage of the full measurement time
Manual operation: | See "Linked analysis time span"


CALCulate:AR:TIME:PERCent:STATe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Analysis Region > CALCulate:AR:TIME:PERCent:STATe
CALCulate:AR:TIME:PERCent:STATe <State>

If activated, the length of the time gate, that is, the duration (or height) of the analysis region, is defined as a percentage of the full measurement time (using CALCulate:​AR:​TIME:​PERCent).

Parameters:
<ON|OFF>
<State>
ON | OFF
*RST: OFF
Manual operation: See "Linked analysis time span"


CALCulate:AR:TIME:STARt

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Selecting the Analysis Region > CALCulate:AR:TIME:STARt
CALCulate:AR:TIME:STARt <StartTime>

Defines the starting point of the time span for the analysis region. The starting point is defined as a time offset from the capture start time.

Parameters:
<StartTime>
Default unit: S
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Time Gate Start"


Adjusting Settings Automatically

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Adjusting Settings Automatically
Adjusting Settings Automatically

The following remote commands are required to adjust settings automatically in a remote environment.

List of Commands
[SENSe:]ADJust:LEVel


[SENSe:]ADJust:LEVel

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring Transient Analysis > Adjusting Settings Automatically > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Capturing Data and Performing Sweeps

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps
Capturing Data and Performing Sweeps

When you activate a Realtime Spectrum measurement channel, a measurement is started immediately with the default settings. However, you can start and stop new measurements at any time.

Capturing data in MSRA/MSRT mode

In MSRA/MSRT mode, I/Q data from the input signal is captured and stored by the MSRA/MSRT Master.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

Useful commands for configuring and performing sweeps described elsewhere:
  • [SENSe:​]MTIMe
  • [SENSe:​]SWEep:​COUNt
  • [SENSe:​]SWEep:​COUNt:​CURRent?
  • [SENSe:​]MEASure:​POINts
Remote commands exclusive to configuring and performing sweeps:
List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:REFResh
INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SYNC
SYSTem:SEQuencer


ABORt

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the measurement mode.

Note that in single measurement mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous measurement mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous measurement mode in remote control, as results like trace data or markers are only valid after a single measurement end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the measurement mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous measurement

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the measurement mode to single measurement.

INIT:CONT ON

Switches the measurement mode to continuous measurement.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:REFResh

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA/MSRT mode, not the MSRA/MSRT Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event
Manual operation: | See "Refresh"


INITiate:SEQuencer:REFResh[:ALL]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:REFResh[:ALL]

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active MSRA/MSRT applications.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INIT:SEQ:REFR Refreshes the display for all channels.
Usage: | Event


INITiate:SEQuencer:ABORt

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


INITiate:SYNC

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > INITiate:SYNC
INITiate:SYNC

This remote control command requests the R&S FSW Transient Analysis application option to wait until any auto-refresh operation is finished. However, it does not initiate a refresh itself.

An auto-refresh is performed automatically after a configuration parameter is changed that requires the results (and displays) to be re-calculated. Note that hardware changes require a new sweep to be performed, not just an auto-refresh.

This command can be issued at any time but makes sense only in single sweep mode.

Example: INIT:IMM;*WAI

R&S FSW Transient Analysis application performs a sweep and program is synchronized (waits) on completion of the sweep.

CALC:AR:FREQ:BAND 10 MHZ

R&S FSW Transient Analysis application starts re-calculating results with a new analysis region bandwidth, but program does not wait until completion of the new calculation, it continues immediately

INIT:SYNC

The program now waits until any pending auto-refresh calculations are finished before continuing.

Usage: Event


SYSTem:SEQuencer

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Capturing Data and Performing Sweeps > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


Analyzing Transient Effects

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects
Analyzing Transient Effects

The following commands are required to analyze transient effects in a measured signal.

Contents
  • Configuring the Result Display
  • Defining the Evaluation Basis
  • Configuring the Result Range
  • Selecting the Hop/Chirp
  • Table Configuration
  • Configuring the Y-Axis Scaling and Units
  • Configuring Traces
  • Configuring Spectrograms
  • Configuring Color Maps
  • Working with Markers Remotely


Configuring the Result Display

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display
Configuring the Result Display

The commands required to configure the screen display in a remote environment are described here.

Contents
  • General Window Commands
  • Working with Windows in the Display


General Window Commands

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SELect


DISPlay:FORMat

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


DISPlay[:WINDow<n>]:SELect

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SELect
DISPlay[:WINDow<n>]:SELect

This command sets the focus on the selected result display window.

This window is then the active window.

Example: | DISP:WIND1:SEL Sets the window 1 active.
Usage: | Setting only


Working with Windows in the Display

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "RF Spectrum"
See "Spectrogram"
See "RF Power Time Domain"
See "FM Time Domain"
See "Frequency Deviation Time Domain"
See "PM Time Domain"
See "PM Time Domain (Wrapped)"
See "Marker Table"
See "Chirp Rate Time Domain"
See "Hop/Chirp Results Table"
See "Hop/Chirp Statistics Table"

For a detailed example see "Programming Examples".

<WindowType> parameter values for Transient Analysis application
Parameter value | Window type
SGR | Spectrogram
RFPTime | RF Power Time Domain
FMTime | FM Time Domain
FDEViation | Frequency Deviation Time Domain *)
PMTime | PM Time Domain
PMWRapped | PM Time Domain (Wrapped)
RFSPectrum | RF Spectrum
CRTime | Chirp Rate Time Domain*)
MTABle | Marker table
RTABle | Results table*)
STABle | Statistics table*)
*) requires additional option R&S FSW-K60C/-K60H


LAYout:CATalog[:WINDow]?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Defining the Evaluation Basis

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Defining the Evaluation Basis
Defining the Evaluation Basis

Depending on the measurement task, not all of the measured data in the capture buffer may be of interest. In some cases it may be useful to restrict analysis to a specific user-definable region, or to a selected individual chirp rate or hop.

Which measurement basis is available for which result display is indicated in table "Available evaluation methods and evaluation basis".

These commands are only available if the additional options R&S FSW-K60C/-K60H are installed.

List of Commands
DISPlay:[WINDow<n>:]EVAL


DISPlay:[WINDow<n>:]EVAL

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Defining the Evaluation Basis > DISPlay:[WINDow<n>:]EVAL
DISPlay:[WINDow<n>:]EVAL <Eval>

Determines the evaluation basis for the specified result display.

Which evaluation basis is available for which result display is indicated in table "Available evaluation methods and evaluation basis".

Parameters:
<Eval>
FULL | REGion | SIGNal
FULL

the full capture buffer

REGion

the selected analysis region (see "Selecting the Analysis Region")

SIGNal

an individual selected hop / chirp (see CALCulate:​HOPDetection:​SELected / CALCulate:​CHRDetection:​SELected)

*RST: depends on result display
Example: DISP:WIND1:EVAL SIGN
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Full Capture / Region Analysis / Hop / Chirp"


Configuring the Result Range

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Range
Configuring the Result Range

The result range determines which data is displayed on the screen (see also "Measurement range vs result range").

These settings are only available if the additional options R&S FSW-K60C/-K60H are installed.

List of Commands
CALCulate:RESult:ALIGnment
CALCulate:RESult:LENGth
CALCulate:RESult:OFFSet
CALCulate:RESult:RANGe:AUTO
CALCulate:RESult:REFerence


CALCulate:RESult:ALIGnment

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Range > CALCulate:RESult:ALIGnment
CALCulate:RESult:ALIGnment <Reference>

Defines the alignment of the result range in relation to the selected reference point (see CALCulate:​RESult:​REFerence).

Setting parameters:
<Reference>
LEFT | CENTer | RIGHt
LEFT

The result range starts at the pulse center or selected edge.

CENTer

The result range is centered around the pulse center or selected edge.

RIGHt

The result range ends at the pulse center or selected edge.

*RST: CENTer
Example: CALC:RES:ALIG LEFT
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Alignment"


CALCulate:RESult:LENGth

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Range > CALCulate:RESult:LENGth
CALCulate:RESult:LENGth <Time>

This command defines the length or duration of the result range.

Note this command is only available for manual range scaling (see CALCulate:​RESult:​RANGe:​AUTO).

Parameters:
<Time>
Default unit: S
Example: CALC:RES:LENG 1us
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Length"


CALCulate:RESult:OFFSet

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Range > CALCulate:RESult:OFFSet
CALCulate:RESult:OFFSet <Time>

The offset in seconds from the hop/chirp edge or center at which the result range reference point occurs.

Parameters:
<Time>
Default unit: S
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Offset"


CALCulate:RESult:RANGe:AUTO

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Range > CALCulate:RESult:RANGe:AUTO
CALCulate:RESult:RANGe:AUTO <ON|OFF>

Defines whether the result range length is determined automatically according to the width of the selected hop/chirp.

Parameters:
<State>
ON | OFF
*RST: ON
Example: CALC:RES:RANG:AUTO ON
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Automatic Range Scaling"


CALCulate:RESult:REFerence

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Result Range > CALCulate:RESult:REFerence
CALCulate:RESult:REFerence <Reference>

Defines the reference point for positioning the result range.

Setting parameters:
<Reference>
RISE | CENTer | FALL
RISE

The result range is defined in reference to the rising edge.

CENTer

The result range is defined in reference to the center of the pulse top.

FALL

The result range is defined in reference to the falling edge.

*RST: CENTer
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Result Range Reference Point"


Selecting the Hop/Chirp

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Selecting the Hop/Chirp
Selecting the Hop/Chirp

The selected hop/chirp determines which results are calculated and displayed.

These commands are only available if the additional options R&S FSW-K60C/-K60H are installed.

List of Commands
CALCulate:CHRDetection:SELected
CALCulate:HOPDetection:SELected


CALCulate:CHRDetection:SELected

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Selecting the Hop/Chirp > CALCulate:CHRDetection:SELected
CALCulate:CHRDetection:SELected <ChirpNo>

Defines the individual chirp for which results are calculated and displayed.

Parameters for setting and query:
<ChirpNo> |
Example: | CALC:CHRD:SEL 3
Example: | See "Programming Example: Performing a Chirp Detection Measurement".
Manual operation: | See "Select Hop / Select Chirp"


CALCulate:HOPDetection:SELected

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Selecting the Hop/Chirp > CALCulate:HOPDetection:SELected
CALCulate:HOPDetection:SELected <HopNo>

Defines the individual hop for which results are calculated and displayed.

Parameters for setting and query:
<HopNo> |
Example: | CALC:HOPD:SEL 3
Example: | See "Programming Example: Performing a Hop Detection Measurement".
Manual operation: | See "Select Hop / Select Chirp"


Table Configuration

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Table Configuration
Table Configuration

The following commands define which statistical and characteristic values are determined for measured hops.

These commands are only available if the additional options R&S FSW-K60C/-K60H are installed.

List of Commands
CALCulate:CHRDetection:TABLe:COLumn
CALCulate:HOPDetection:TABLe:COLumn


CALCulate:CHRDetection:TABLe:COLumn

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Table Configuration > CALCulate:CHRDetection:TABLe:COLumn
CALCulate:CHRDetection:TABLe:COLumn <State>, <Header>{,<Header>}

This command enables or disables columns in all chirp results and statistics tables.

Note that only the enabled columns are returned for the CALCulate:​CHRDetection:​TABLe:​RESults? query.

Setting parameters:
<State>
ON | OFF

Enables or disables all subsequently listed headers

ON

Provides results for the defined <Headers> only

OFF

Provides results for all table parameters except the specified <Headers>.

*RST: ON
<Headers>
ALL | STATe | BEGin | LENGth | RATe | CHERror | FREQuency | MAXFm | RMSFm | AVGFm | AVGPower

All listed parameters are displayed or hidden in the table results (depending on the <State> parameter).

ALL

See "Chirp Parameters".

STATe

Chirp state

BEGin

Chirp Begin

LENGth

Chirp length

RATe

Chirp rate

CHERror

Chirp state deviation

FREQuency

Average frequency

MAXFm

Maximum Frequency Deviation

RMSFm

RMS Frequency Deviation

AVGFm

Average Frequency Deviation

AVGPower

Average power

Example: CALC:CHRD:TABL:COL ON, CHRNo, STATe

Provides results for the chirp number and chirp state only.

Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Usage: Setting only


CALCulate:HOPDetection:TABLe:COLumn

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Table Configuration > CALCulate:HOPDetection:TABLe:COLumn
CALCulate:HOPDetection:TABLe:COLumn <State>, <Header>{,<Header>}

This command enables or disables columns in all hop results and statistics tables.

Note that only the enabled columns are returned for the CALCulate:​CHRDetection:​TABLe:​RESults? query.

Setting parameters:
<State>
ON | OFF

Enables or disables all subsequently listed headers

ON

Provides results for the defined <Headers> only

OFF

Provides results for all table parameters except the specified <Headers>.

*RST: ON
<Headers>
ALL | STATe | BEGin | DWELl | SWITching | FREQuency | FMERror | MAXFm | RMSFm | AVGFm | AVGPower

All listed parameters are displayed or hidden in the table results (depending on the <State> parameter).

ALL

See "Hop Parameters".

STATe

Hop state

BEGin

Hop Begin

DWELl

Hop dwell time

SWITching

Switching time

FREQuency

Average frequency

FMERror

Hop state deviation

MAXFm

Maximum Frequency Deviation

RMSFm

RMS Frequency Deviation

AVGFm

Average Frequency Deviation

AVGPower

Average power

Example: CALC:HOPD:TABL:COL ON, HOPNo, STATe

Provides results for the HOP number and HOP state only.

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Usage: Setting only


Configuring the Y-Axis Scaling and Units

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Y-Axis Scaling and Units
Configuring the Y-Axis Scaling and Units

The scaling for the vertical axis is highly configurable, using either absolute or relative values. These commands are described here.

Useful commands for configuring scaling described elsewhere:
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel
Remote commands exclusive to scaling the y-axis
List of Commands
CALCulate<n>:UNIT:ANGLe
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue


CALCulate<n>:UNIT:ANGLe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Y-Axis Scaling and Units > CALCulate<n>:UNIT:ANGLe
CALCulate<n>:UNIT:ANGLe <Unit>

This command selects the global unit for phase results.

Setting parameters:
<Unit>
DEG | RAD
*RST: RAD
Manual operation: See "Phase Unit"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe] <Range>

This command defines the display range of the y-axis.

Example: DISP:TRAC:Y 110dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Range"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO <State>

If enabled, the Y-axis is scaled automatically according to the current measurement.

Parameters for setting and query:
<State>
OFF

Switch the function off

ON

Switch the function on

*RST: ON
Manual operation: See "Automatic Grid Scaling"
See "Auto Scale Once"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum <Value>

This command defines the maximum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Absolute Scaling (Min/Max Values)"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum <Value>

This command defines the minimum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Absolute Scaling (Min/Max Values)"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision <Value>

This remote command determines the grid spacing on the Y-axis for all diagrams, where possible.

Parameters:
<Value>
numeric value WITHOUT UNIT (unit according to the result display)

Defines the range per division (total range = 10*<Value>)

*RST: depends on the result display
Example: DISP:TRAC:Y:PDIV 10

Sets the grid spacing to 10 units (e.g. dB) per division

Manual operation: See "Per Division"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

Parameters:
<Position>

0 PCT corresponds to the lower display border, 100% corresponds to the upper display border.

*RST: 100 PCT = frequency display; 50 PCT = time display
Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Ref Position"
See "Ref Level Position"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue <Value>

This command defines the reference value assigned to the reference position in the specified window. Separate reference values are maintained for the various displays.

Parameters:
<Value>
numeric value WITHOUT UNIT
Default unit: dBm
Example:

See "Programming Example: Pulse Measurement" .

Manual operation: See "Ref Value"


Configuring Traces

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Traces
Configuring Traces

The trace settings determine how the measured data is analyzed and displayed in the window. Depending on the result display, between 1 and 6 traces may be displayed.

List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:]MEASure:POINts
[SENSe:]STATistic:TYPE
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?


DISPlay[:WINDow<n>]:TRACe<t>:MODE

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

For more information see "Analyzing Several Traces - Trace Mode" .

Parameters:
<Mode>
WRITe

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

AVERage

The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

VIEW

The current contents of the trace memory are frozen and displayed.

BLANk

Hides the selected trace.

*RST: Trace 1: WRITe, Trace 2-6: BLANk
Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Mode"


DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous <State>

This command turns an automatic reset of a trace on and off after a parameter has changed.

The reset works for trace modes min hold, max hold and average.

Note that the command has no effect if critical parameters like the span have been changed to avoid invalid measurement results

Parameters:
<State>
ON

The automatic reset is off.

OFF

The automatic reset is on.

*RST: OFF
Example: DISP:WIND:TRAC3:MODE:HCON ON

Switches off the reset function.

Manual operation: See "Hold"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6"
See "Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)"


[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Traces > [SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion] <Detector>

Defines the trace detector to be used for trace analysis.

For details see "Mapping Samples to Sweep Points with the Trace Detector" .

Parameters:
<Detector>
APEak

Autopeak

NEGative

Negative peak

POSitive

Positive peak

SAMPle

First value detected per trace point

RMS

RMS value

AVERage

Average

*RST: APEak (I/Q Analyzer: RMS)

For more information see "Mapping Samples to Sweep Points with the Trace Detector" .

Example: DET POS

Sets the detector to "positive peak".

Example:

See "Programming Example: EMI Measurement" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .


[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Traces > [SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO <State>

This command couples and decouples the detector to the trace mode.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: DET:AUTO OFF

The selection of the detector is not coupled to the trace mode.

Manual operation: See "Detector"


[SENSe:]MEASure:POINts

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Traces > [SENSe:]MEASure:POINts
[SENSe:]MEASure:POINts <MeasurementPoints>

Defines the maximum number of trace points within a trace.

Parameters:
<MeasurementPoints> |
Manual operation: | See "Maximum number of trace points"


[SENSe:]STATistic:TYPE

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Traces > [SENSe:]STATistic:TYPE
[SENSe:]STATistic:TYPE <Statistic Type>

Defines which hops/chirps are included in the statistical evaluation.

Parameters:
<Statistic Type> | SELected | ALL SELected Only the selected hop/chirp from each sweep (capture) is included in the statistical evaluation. ALL All measured hops/chirps from each sweep (capture) are included in the statistical evaluation.
Manual operation: | See "Selected Hop / Selected Chirp vs All Hops / All Chirps"


[SENSe:]SWEep:COUNt

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Traces > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics" ).

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


[SENSe:]SWEep:COUNt:CURRent?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Traces > [SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:COUNt:CURRent?

This query returns the current number of started sweeps or measurements. This command is only available if a sweep count value is defined and the instrument is in single sweep mode.

Usage: Query only


Configuring Spectrograms

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms
Configuring Spectrograms

The remote commands required for the individual settings available for spectrogram displays are described here. For color mapping commands, see "Configuring Color Maps".

List of Commands
CALCulate<n>:SGRam:CLEar
CALCulate<n>:SGRam|SPECtrogram:FRAMe:SELect
CALCulate<n>:SGRam|SPECtrogram:HDEPth
CALCulate<n>:SGRam|SPECtrogram:TRESolution
CALCulate<n>:SGRam|SPECtrogram:TRESolution:AUTO
CALCulate<n>:SGRam|SPECtrogram:TSTamp:DATA?
CALCulate<n>:SGRam|SPECtrogram:TSTamp[:STATe]
[SENSe:][WINDow<n>:]SGRam|SPECtrogram:DETector:FUNCtion
[SENSe:]SWEep:FFT:WINDow:LENGth?
[SENSe:]SWEep:FFT:WINDow:TYPE


CALCulate<n>:SGRam:CLEar

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms > CALCulate<n>:SGRam:CLEar
CALCulate<n>:SGRam:CLEar

This command resets the spectrogram and clears the history buffer.

Usage: | Event
Manual operation: | See "Clear Spectrogram"


CALCulate<n>:SGRam|SPECtrogram:FRAMe:SELect

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms > CALCulate<n>:SGRam|SPECtrogram:FRAMe:SELect
CALCulate<n>:SGRam|SPECtrogram:FRAMe:SELect <Frame> | <Time>

This command selects a specific frame for further analysis.

The command is available if no measurement is running or after a single sweep has ended.

Parameters:
<Frame> | Selects a frame directly by the frame number. Valid if the time stamp is off. The range depends on the history depth.
<Time> | Selects a frame via its time stamp. Valid if the time stamp is on. The number is the distance to frame 0 in seconds. The range depends on the history depth.
Example: | INIT:CONT OFF Stop the continuous sweep. CALC:SGR:FRAM:SEL -25 Selects frame number -25.
Manual operation: | See "Selecting a frame to display"


CALCulate<n>:SGRam|SPECtrogram:HDEPth

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms > CALCulate<n>:SGRam|SPECtrogram:HDEPth
CALCulate<n>:SGRam|SPECtrogram:HDEPth <History>

This command defines the number of frames to be stored in the R&S FSW memory.

Parameters:
<Depth> |
Example: | CALC:SGR:SPEC 1500 Sets the history depth to 1500.
Manual operation: | See "History Depth"


CALCulate<n>:SGRam|SPECtrogram:TRESolution

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms > CALCulate<n>:SGRam|SPECtrogram:TRESolution
CALCulate<n>:SGRam|SPECtrogram:TRESolution <TimeRes>

This command sets the spectrogram time resolution for CALCulate<n>:​SGRam|SPECtrogram:​TRESolution:​AUTO OFF.

The time resolution determines the size of the bins used for each FFT calculation. The shorter the time span used for each FFT, the shorter the resulting span, and thus the higher the resolution in the spectrum becomes.

Parameters:
<TimeRes>

The values depend on the evaluation basis of the spectrogram (see DISPlay:​[WINDow<n>:​]EVAL)

Range: | full capture area: 1 / sample rate; analysis region or hop/chirp: (1 / sample rate) * (meas bw / analysis region bw); to full capture area: measurement time; analysis region: time gate length; hop/chirp: result range length
*RST: | 0
Manual operation: See "Time Resolution"


CALCulate<n>:SGRam|SPECtrogram:TRESolution:AUTO

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms > CALCulate<n>:SGRam|SPECtrogram:TRESolution:AUTO
CALCulate<n>:SGRam|SPECtrogram:TRESolution:AUTO <Reference>

This command switches the spectrogram time resolution from auto to manual.

Setting parameters:
<Reference> | AUTO | MANual AUTO The optimal resolution is determined automatically according to the data acquisition settings. MANual You must define the time resolution using CALCulate<n>:​SGRam|SPECtrogram:​TRESolution.
Manual operation: | See "Time Resolution"


CALCulate<n>:SGRam|SPECtrogram:TSTamp:DATA?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms > CALCulate<n>:SGRam|SPECtrogram:TSTamp:DATA?
CALCulate<n>:SGRam|SPECtrogram:TSTamp:DATA? <Frames>

This command queries the time stamp (starting time) of the frames.

The return values consist of four values for each frame. If the spectrogram is empty, the command returns '0,0,0,0'. The times are given as delta values, which simplifies evaluating relative results; however, you can also calculate the absolute date and time as displayed on the screen.

The frame results themselves are returned with TRAC:DATA? SGR

See TRACe<n>[:​DATA]?.

Parameters:
<Frames> | CURRent Returns the starting time of the current frame. ALL Returns the starting time for all frames. The results are sorted in descending order, beginning with the current frame.
Return values:
<Seconds> | Number of seconds that have passed since 01.01.1970 till the frame start
<Nanoseconds> | Number of nanoseconds that have passed in addition to the <Seconds> since 01.01.1970 till the frame start.
<Reserved> | The third and fourth value are reserved for future uses.
Example: | CALC:SGR:TST ON Activates the time stamp. CALC:SGR:TST:DATA? ALL Returns the starting times of all frames sorted in a descending order.
Usage: | Query only
Manual operation: | See "Timestamp"


CALCulate<n>:SGRam|SPECtrogram:TSTamp[:STATe]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms > CALCulate<n>:SGRam|SPECtrogram:TSTamp[:STATe]
CALCulate<n>:SGRam|SPECtrogram:TSTamp[:STATe] <State>

This command activates and deactivates the time stamp.

If the time stamp is active, some commands do not address frames as numbers, but as (relative) time values:
  • CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​FRAMe
  • CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​FRAMe
  • CALCulate<n>:​SGRam|SPECtrogram:​FRAMe:​SELect
Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:SGR:TST ON
CALC:SPEC:TST ON

Activates the time stamp.

Manual operation: See "Timestamp"


[SENSe:][WINDow<n>:]SGRam|SPECtrogram:DETector:FUNCtion

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms > [SENSe:][WINDow<n>:]SGRam|SPECtrogram:DETector:FUNCtion
[SENSe:][WINDow<n>:]SGRam|SPECtrogram:DETector:FUNCtion <Detector>

This command queries or sets the spectrogram detector type for the specified window.

Parameters:
<Detector>
SUM | AVERage | RMS | MAXimum | MINimum | SAMPle
SUM

Calculates the sum of all values in one sample point

AVERage

Calculates the linear average of all values in one sample point

RMS

Calculates the RMS of all values in one sample point

MAXimum

Determines the largest of all values in one sample point

MINimum

Determines the minimum of all values in one sample point

SAMPle

Selects the last measured value for each sample point

*RST: MAXimum
Example: SENS:SGR:DET:FUNC SUM
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "Detector"


[SENSe:]SWEep:FFT:WINDow:LENGth?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms > [SENSe:]SWEep:FFT:WINDow:LENGth?
[SENSe:]SWEep:FFT:WINDow:LENGth?

This commands queries the FFT window length

Return values:
<WindowLength>
1024 | 2048 | 4096
*RST: 1024
Example: SWE:FFT:WIND:LENG?
Example:

See "Programming Example: Performing a Hop Detection Measurement".

Usage: Query only


[SENSe:]SWEep:FFT:WINDow:TYPE

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Spectrograms > [SENSe:]SWEep:FFT:WINDow:TYPE
[SENSe:]SWEep:FFT:WINDow:TYPE <ColorScheme>

This command queries or sets the FFT windowing function.

Parameters:
<ColorScheme>
BLACkharris | CHEByshev | FLATtop | GAUSsian | HAMMing | HANNing | RECTangular
*RST: BLACkharris
Example: SWE:FFT:WIND:TYPE BLAC
Example:

See "Programming Example: Performing a Hop Detection Measurement".

Manual operation: See "FFT Window"


Configuring Color Maps

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Color Maps
Configuring Color Maps

The color display used in spectrograms is highly configurable to adapt the display to your needs.

For details see "Measurement Basics".

List of Commands
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe]


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Color Maps > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault

This command restores the original color map.

Usage: | Event
Manual operation: | See "Set to Default"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Color Maps > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer <Percentage>

This command defines the starting point of the color map.

Parameters:
<Percentage>

Statistical frequency percentage.

Range: | 0 to 66
*RST: | 0
Default unit: | %
Example: DISP:WIND:SGR:COL:LOW 10

Sets the start of the color map to 10%.

Manual operation: See "Start / Stop"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Color Maps > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe <Shape>

This command defines the shape and focus of the color curve for the spectrogram result display.

Parameters:
<Shape>

Shape of the color curve.

Range: | -1 to 1
*RST: | 0
Manual operation: See "Shape"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Color Maps > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer <Percentage>

This command defines the end point of the color map.

Parameters:
<Percentage>

Statistical frequency percentage.

Range: | 0 to 66
*RST: | 0
Default unit: | %
Example: DISP:WIND:SGR:COL:UPP 95

Sets the start of the color map to 95%.

Manual operation: See "Start / Stop"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Configuring Color Maps > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe]
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe] <ColorScheme>

This command selects the color scheme.

For details see "Color Maps" .

Parameters:
<ColorScheme>
HOT

Uses a color range from blue to red. Blue colors indicate low levels, red colors indicate high ones.

COLD

Uses a color range from red to blue. Red colors indicate low levels, blue colors indicate high ones.

RADar

Uses a color range from black over green to light turquoise with shades of green in between.

GRAYscale

Shows the results in shades of gray.

*RST: HOT
Example: DISP:WIND:SPEC:COL GRAY

Changes the color scheme of the spectrogram to black and white.

Manual operation: See "Hot/Cold/Radar/Grayscale"


Working with Markers Remotely

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely
Working with Markers Remotely

In the Transient Analysis application, up to 16 markers or delta markers can be activated for each window simultaneously.

Contents
  • Setting Up Individual Markers
  • General Marker Settings
  • Configuring and Performing a Marker Search
  • Positioning the Marker
  • Marker Search (Spectrograms)


Setting Up Individual Markers

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers
Setting Up Individual Markers

The following commands define the position of markers in the diagram.

List of Commands
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?


CALCulate<n>:MARKer<m>:AOFF

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2> <State>

This command links normal marker <m1> to any active normal marker <m2>.

If you change the horizontal position of marker <m2>, marker <m1> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK4:LINK:TO:MARK2 ON

Links marker 4 to marker 2.


CALCulate<n>:MARKer<m>[:STATe]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:TRACe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:TRACe <Trace>

This command selects the trace the marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> |
Example: | CALC:MARK3:TRAC 2 Assigns marker 3 to trace 2.
Manual operation: | See "Assigning the Marker to a Trace"


CALCulate<n>:MARKer<m>:X

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker Position (X-value)"


CALCulate<n>:MARKer<m>:Y?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table" See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:DELTamarker:AOFF

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:LINK

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:LINK <State>

This command links delta marker <m> to marker 1.

If you change the horizontal position (x-value) of marker 1, delta marker <m> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2:LINK ON


CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2> <State>

This command links delta marker <m1> to any active normal marker <m2>.

If you change the horizontal position of marker <m2>, delta marker <m1> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT4:LINK:TO:MARK2 ON

Links the delta marker 4 to the marker 2.


CALCulate<n>:DELTamarker<m>:MREF

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:MREF <Reference>

This command selects a reference marker for a delta marker other than marker 1.

Parameters:
<Reference> | 1 to 16 Selects markers 1 to 16 as the reference.
Example: | CALC:DELT3:MREF 2 Specifies that the values of delta marker 3 are relative to marker 2.
Manual operation: | See "Reference Marker"


CALCulate<n>:DELTamarker<m>[:STATe]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker<m>:TRACe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:TRACe <Trace>

This command selects the trace a delta marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | Trace number the marker is assigned to.
Example: | CALC:DELT2:TRAC 2 Positions delta marker 2 on trace 2.


CALCulate<n>:DELTamarker<m>:X

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Example: | CALC:DELT:X? Outputs the absolute x-value of delta marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta" See "Marker Position (X-value)"


CALCulate<n>:DELTamarker<m>:X:RELative?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:X:RELative?

This command queries the relative position of a delta marker on the x-axis.

If necessary, the command activates the delta marker first.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | CALC:DELT3:X:REL? Outputs the frequency of delta marker 3 relative to marker 1 or relative to the reference position.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:DELTamarker<m>:Y?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


General Marker Settings

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > General Marker Settings
General Marker Settings

The following commands control general marker functionality.

List of Commands
DISPlay:MTABle
CALCulate<n>:MARKer:LINK


DISPlay:MTABle

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

AUTO

Turns the marker table on if 3 or more markers are active.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


CALCulate<n>:MARKer:LINK

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > General Marker Settings > CALCulate<n>:MARKer:LINK
CALCulate<n>:MARKer:LINK <State>

This command defines whether all markers within the selected result display are linked. If enabled, and you move one marker along the x-axis, all other markers in the display are moved to the same x-axis position.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC2:MARK:LINK ON
Manual operation: See "Linked Markers"


Configuring and Performing a Marker Search

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Configuring and Performing a Marker Search
Configuring and Performing a Marker Search

The following commands control the marker search.

List of Commands
CALCulate<n>:MARKer:PEXCursion


CALCulate<n>:MARKer:PEXCursion

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:PEXCursion <Excursion>

This command defines the peak excursion.

The peak excursion sets the requirements for a peak to be detected during a peak search.

The unit depends on the measurement.

Manual operation: See "Peak Excursion"


Positioning the Marker

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker
Positioning the Marker

The following remote commands are required to position the marker on a trace.

Contents
  • Positioning Markers
  • Positioning Delta Markers


Positioning Markers

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Markers
Positioning Markers

The following commands position markers on the trace.

List of Commands
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:RIGHt


CALCulate<n>:MARKer<m>:MAXimum:LEFT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:NEXT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:LEFT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:NEXT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Positioning Delta Markers

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers
Positioning Delta Markers

The following commands position delta markers on the trace.

List of Commands
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Marker Search (Spectrograms)

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms)
Marker Search (Spectrograms)

The following commands automatically define the marker and delta marker position in the spectrogram.

Contents
  • Using Markers
  • Using Delta Markers


Using Markers

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers
Using Markers

The following commands control spectrogram markers.

Useful commands for spectrogram markers described elsewhere

The following commands define the horizontal position of the markers.

  • CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT
  • CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT
  • CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]
  • CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt
  • CALCulate<n>:​MARKer<m>:​MINimum:​LEFT
  • CALCulate<n>:​MARKer<m>:​MINimum:​NEXT
  • CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]
  • CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt
Remote commands exclusive to spectrogram markers
List of Commands
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe <Frame> | <Time>

This command positions a marker on a particular frame.

Parameters:
<Frame> | Selects a frame directly by the frame number. Valid if the time stamp is off. The range depends on the history depth.
<Time> | Selects a frame via its time stamp. Valid if the time stamp is on. The number is the (negative) distance to frame 0 in seconds. The range depends on the history depth.
Example: | CALC:MARK:SGR:FRAM -20 Sets the marker on the 20th frame before the present. CALC:MARK2:SGR:FRAM -2s Sets second marker on the frame 2 seconds ago.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta" See "Frame"


CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea
CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea <SearchArea>

This command defines the marker search area for all markers.

Parameters:
<SearchArea>
VISible

Performs a search within the visible frames.

Note that the command does not work if the spectrogram is not visible for any reason (e.g. if the display update is off).

MEMory

Performs a search within all frames in the memory.

*RST: VISible


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

This command moves a marker to the highest level of the spectrogram.

Usage: Event


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

This command moves a marker to the minimum level of the spectrogram.

Usage: Event


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

This command moves a marker vertically to the next lower peak level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

This command moves a marker vertically to the next lower peak level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

This command moves a marker vertically to the next lower peak level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

This command moves a marker vertically to the highest level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command looks for the peak level in the whole spectrogram.

Usage: Event


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

This command moves a marker vertically to the next higher minimum level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow

This command moves a marker vertically to the next higher minimum level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

This command moves a marker vertically to the next higher minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

This command moves a marker vertically to the minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command first looks for the peak level for all frequencies and moves the marker vertically to the minimum level.

Usage: Event


Using Delta Markers

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers
Using Delta Markers

The following commands control spectrogram delta markers.

Useful commands for spectrogram markers described elsewhere

The following commands define the horizontal position of the delta markers.

  • CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT
  • CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT
  • CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]
  • CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt
  • CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT
  • CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT
  • CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]
  • CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt
Remote commands exclusive to spectrogram markers
List of Commands
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe <Frame> | <Time>

This command positions a delta marker on a particular frame. The frame is relative to the position of marker 1.

The command is available for the spectrogram.

Parameters:
<Frame> | Selects a frame directly by the frame number. Valid if the time stamp is off. The range depends on the history depth.
<Time> | Selects a frame via its time stamp. Valid if the time stamp is on. The number is the distance to frame 0 in seconds. The range depends on the history depth.
Example: | CALC:DELT4:SGR:FRAM -20 Sets fourth deltamarker 20 frames below marker 1. CALC:DELT4:SGR:FRAM 2 s Sets fourth deltamarker 2 seconds above the position of marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea <SearchArea>

This command defines the delta marker search area.

Parameters:
<SearchArea>
VISible

Performs a search within the visible frames.

Note that the command does not work if the spectrogram is not visible for any reason (e.g. if the display update is off).

MEMory

Performs a search within all frames in the memory.

*RST: VISible


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

This command moves a marker to the highest level of the spectrogram over all frequencies.

Usage: Event


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

This command moves a delta marker to the minimum level of the spectrogram over all frequencies.

Usage: Event


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

This command moves a marker vertically to the next higher level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

This command moves a marker vertically to the next higher level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

This command moves a delta marker vertically to the next higher level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

This command moves a delta marker vertically to the highest level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command looks for the peak level in the whole spectrogram.

Usage: Event


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

This command moves a delta marker vertically to the next minimum level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow

This command moves a delta marker vertically to the next minimum level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

This command moves a delta marker vertically to the next minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: Event


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Analyzing Transient Effects > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

This command moves a delta marker vertically to the minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command first looks for the peak level in the whole spectrogram and moves the marker vertically to the minimum level.

Usage: Event


Configuring an Analysis Interval and Line (MSRA mode only)

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring an Analysis Interval and Line (MSRA mode only)
Configuring an Analysis Interval and Line (MSRA mode only)

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRA applications.

For the Transient Analysis application, the commands to define tha analysis interval are the same as those used to define the actual data acquisition (see "Data Acquisition". Be sure to select the correct measurement channel before executing these commands.

Useful commands related to MSRA mode described elsewhere:
  • INITiate:​REFResh
  • INITiate:​SEQuencer:​REFResh[:​ALL]
Remote commands exclusive to MSRA applications

The following commands are only available for MSRA application channels:

List of Commands
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
[SENSe:]MSRA:CAPTure:OFFSet


CALCulate:MSRA:ALINe:SHOW

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRA applications and the MSRA Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:MSRA:ALINe[:VALue]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRA applications and the MSRA Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time of the MSRA measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:MSRA:WINDow<n>:IVAL?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRA View or MSRA Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


[SENSe:]MSRA:CAPTure:OFFSet

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > [SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRA mode, not for the MSRA Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | 0 to <Record length>
*RST: | 0
Manual operation: See "Capture Offset"


Configuring an Analysis Interval and Line (MSRT mode only)

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring an Analysis Interval and Line (MSRT mode only)
Configuring an Analysis Interval and Line (MSRT mode only)

In MSRT operating mode, only the MSRT Master actually captures data; the MSRT applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRT applications.

For the Transient Analysis application, the commands to define the analysis interval are the same as those used to define the actual data acquisition (see "Data Acquisition". Be sure to select the correct measurement channel before executing these commands.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the Transient Analysis measurement.

Useful commands related to MSRT mode described elsewhere:
  • INITiate:​REFResh
  • INITiate:​SEQuencer:​REFResh[:​ALL]
Remote commands exclusive to MSRT applications

The following commands are only available for MSRT application channels:

List of Commands
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
[SENSe:]RTMS:CAPTure:OFFSet


CALCulate:RTMS:ALINe:SHOW

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRT applications and the MSRT Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:RTMS:ALINe[:VALue]

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRT applications and the MSRT Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time (pretrigger + posttrigger) of the MSRT measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:RTMS:WINDow<n>:IVAL?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate:RTMS:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRT View or MSRT Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


[SENSe:]RTMS:CAPTure:OFFSet

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > [SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]RTMS:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRT mode, not for the MSRT Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | - [pretrigger time] to min (posttrigger time; sweep time)
*RST: | 0
Manual operation: See "Capture Offset"


Retrieving Results

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results
Retrieving Results

The following commands are required to query the results of the transient analysis.

Note that for each hop/chirp result query you can specify for which hop/chirp(s) you require results:

  • ALL: for all hops/chirps detected in the entire measurement
  • CURRent: for all hops/chirps in the current capture buffer
  • SELected: only for the currently selected hop/chirp

For each hop/chirp result, you can query either the current value (default) or the following statistical values for the hops/chirps detected in the capture buffer or the entire measurement:

  • AVER: average of the results
  • MIN: minimum of the results
  • MAX: maximum of the results
  • SDEV: standard deviation of the results
Contents
  • Retrieving Information on Detected Hops
  • Retrieving Information on Detected Chirps
  • Retrieving Trace Data
  • Exporting Table Results to an ASCII File
  • Exporting Trace Results


Retrieving Information on Detected Hops

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops
Retrieving Information on Detected Hops

The following commands return information on the currently selected or all detected hops.

List of Commands
CALCulate:HOPDetection:TABLe:RESults?
CALCulate:HOPDetection:TOTal?
[SENSe:]HOP:FREQuency:AVGFm?
[SENSe:]HOP:FREQuency:AVGFm:AVERage?
[SENSe:]HOP:FREQuency:AVGFm:MAXimum?
[SENSe:]HOP:FREQuency:AVGFm:MINimum?
[SENSe:]HOP:FREQuency:AVGFm:SDEViation?
[SENSe:]HOP:FREQuency:FMERror?
[SENSe:]HOP:FREQuency:FMERror:AVERage?
[SENSe:]HOP:FREQuency:FMERror:MAXimum?
[SENSe:]HOP:FREQuency:FMERror:MINimum?
[SENSe:]HOP:FREQuency:FMERror:SDEViation?
[SENSe:]HOP:FREQuency:FREQuency?
[SENSe:]HOP:FREQuency:FREQuency:AVERage?
[SENSe:]HOP:FREQuency:FREQuency:MAXimum?
[SENSe:]HOP:FREQuency:FREQuency:MINimum?
[SENSe:]HOP:FREQuency:FREQuency:SDEViation?
[SENSe:]HOP:FREQuency:MAXFm?
[SENSe:]HOP:FREQuency:MAXFm:AVERage?
[SENSe:]HOP:FREQuency:MAXFm:MAXimum?
[SENSe:]HOP:FREQuency:MAXFm:MINimum?
[SENSe:]HOP:FREQuency:MAXFm:SDEViation?
[SENSe:]HOP:FREQuency:RMSFm?
[SENSe:]HOP:FREQuency:RMSFm:AVERage?
[SENSe:]HOP:FREQuency:RMSFm:MAXimum?
[SENSe:]HOP:FREQuency:RMSFm:MINimum?
[SENSe:]HOP:FREQuency:RMSFm:SDEViation?
[SENSe:]HOP:ID?
[SENSe:]HOP:NUMBer?
[SENSe:]HOP:POWer:AVEPower?
[SENSe:]HOP:POWer:AVEPower:AVERage?
[SENSe:]HOP:POWer:AVEPower:MAXimum?
[SENSe:]HOP:POWer:AVEPower:MINimum?
[SENSe:]HOP:POWer:AVEPower:SDEViation?
[SENSe:]HOP:STATe?
[SENSe:]HOP:STATe:AVERage?
[SENSe:]HOP:STATe:MAXimum?
[SENSe:]HOP:STATe:MINimum?
[SENSe:]HOP:STATe:SDEViation?
[SENSe:]HOP:TIMing:BEGin?
[SENSe:]HOP:TIMing:BEGin:AVERage?
[SENSe:]HOP:TIMing:BEGin:MAXimum?
[SENSe:]HOP:TIMing:BEGin:MINimum?
[SENSe:]HOP:TIMing:BEGin:SDEViation?
[SENSe:]HOP:TIMing:DWELl?
[SENSe:]HOP:TIMing:DWELl:AVERage?
[SENSe:]HOP:TIMing:DWELl:MAXimum?
[SENSe:]HOP:TIMing:DWELl:MINimum?
[SENSe:]HOP:TIMing:DWELl:SDEViation?
[SENSe:]HOP:TIMing:SWITching?
[SENSe:]HOP:TIMing:SWITching:AVERage?
[SENSe:]HOP:TIMing:SWITching:MAXimum?
[SENSe:]HOP:TIMing:SWITching:MINimum?
[SENSe:]HOP:TIMing:SWITching:SDEViation?


CALCulate:HOPDetection:TABLe:RESults?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > CALCulate:HOPDetection:TABLe:RESults?
CALCulate:HOPDetection:TABLe:RESults? [<Start>, <End>]

This command queries the hop results table. The result is a comma-separated list of value sets, one set for each hop.

If no query parameters are specified, the results for all detected hops are returned.

Which values are returned depends on the enabled parameters for the results tables (see CALCulate:​HOPDetection:​TABLe:​COLumn).

Query parameters:
<Start>
integer

The hop number of the first hop to be returned. Hop numbers start at 1.

<End>
integer

The hop number of the last hop to be returned.

Return values:
<ID>

timestamp which corresponds to the absolute time the beginning of the hop was detected

<HopNo>

consecutive number of detected hop, starts at 1 for each new measurement

<StateIndex>

consecutive number of corresponding nominal hop state as defined in the "hop States" table (see CALCulate:​HOPDetection:​STATes[:​DATA])

<Begin>

relative time (in ms) from the capture start at which the signal first enters the tolerance area of a nominal hop (within the analysis region)

Default unit: ms
<DwellTime>

The duration of a hop from begin to end, that is, the time the signal remains in the tolerance area of a nominal hop frequency.

Default unit: ms
<SwitchTime>

The time the signal requires to "hop" from one level to the next. It is defined as the time between a hop end and the following hop begin.

Default unit: ms
<FreqAvg>

Average frequency measured within the frequency measurement range of the hop

Default unit: kHz
<FreqDev>

Deviation of the hop frequency from the nominal hop state frequency

For details see "Hop State Deviation".

Default unit: kHz
<FMDevMax>

Maximum deviation of the hop frequency from the nominal hop frequency as defined in the "hop States" table. The deviation is calculated within the frequency measurement range of the hop.

For details see "Frequency Deviation (Peak)".

Default unit: kHz
<FMDevRMS>

RMS deviation of the hop frequency from the nominal (linear) hop frequency as defined in the "hop States" table. The deviation is calculated within the frequency measurement range of the hop.

For details see "Frequency Deviation (RMS)".

Default unit: kHz
<FMDevAvg>

Average deviation of the hop frequency from the nominal (linear) hop frequency as defined in the "hop States" table. The deviation is calculated within the frequency measurement range of the hop.

For details see "Frequency Deviation (Average)".

Default unit: kHz
<PowAvg>

Average power level measured during a hop. Which part of the hop precisely is used for calculation depends on the power parameters in the "Power" measurement range configuration.

Default unit: dBm
Example: CALC3:HOPD:TABLe? 1, 10

Result:

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Usage: Query only
Manual operation: See "State Index"
See "Hop Begin"
See "Dwell Time"
See "Switching Time"
See "Average Frequency"
See "Hop State Deviation"
See "Frequency Deviation (Peak)"
See "Frequency Deviation (RMS)"
See "Frequency Deviation (Average)"
See "Average Power"


CALCulate:HOPDetection:TOTal?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > CALCulate:HOPDetection:TOTal?
CALCulate:HOPDetection:TOTal?

This command returns the total number of hops found.

Return values:
<TotalHops> |
Usage: | Query only


[SENSe:]HOP:FREQuency:AVGFm?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:FREQuency:AVGFm?
[SENSe:]HOP:FREQuency:AVGFm? <QueryRange>

Returns the average Frequency Deviation from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected hop CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only
Manual operation: | See "Frequency Deviation (Average)"


[SENSe:]HOP:FREQuency:AVGFm:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:FREQuency:AVGFm:AVERage?
[SENSe:]HOP:FREQuency:AVGFm:AVERage? <QueryRange>
[SENSe:]HOP:FREQuency:AVGFm:MAXimum? <QueryRange>
[SENSe:]HOP:FREQuency:AVGFm:MINimum? <QueryRange>
[SENSe:]HOP:FREQuency:AVGFm:SDEViation? <QueryRange>

Returns the statistical value for the average Frequency Deviation from the statistics table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:FREQuency:FMERror?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:FREQuency:FMERror?
[SENSe:]HOP:FREQuency:FMERror? <QueryRange>

Returns the frequency deviation from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected hop CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only
Manual operation: | See "Hop State Deviation"


[SENSe:]HOP:FREQuency:FMERror:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:FREQuency:FMERror:AVERage?
[SENSe:]HOP:FREQuency:FMERror:AVERage? <QueryRange>
[SENSe:]HOP:FREQuency:FMERror:MAXimum? <QueryRange>
[SENSe:]HOP:FREQuency:FMERror:MINimum? <QueryRange>
[SENSe:]HOP:FREQuency:FMERror:SDEViation? <QueryRange>

Returns the statistical value for the frequency deviation from the statistics table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:FREQuency:FREQuency?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:FREQuency:FREQuency?
[SENSe:]HOP:FREQuency:FREQuency? <QueryRange>

Returns the average frequency from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected hop CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only
Manual operation: | See "Average Frequency"


[SENSe:]HOP:FREQuency:FREQuency:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:FREQuency:FREQuency:AVERage?
[SENSe:]HOP:FREQuency:FREQuency:AVERage? <QueryRange>
[SENSe:]HOP:FREQuency:FREQuency:MAXimum? <QueryRange>
[SENSe:]HOP:FREQuency:FREQuency:MINimum? <QueryRange>
[SENSe:]HOP:FREQuency:FREQuency:SDEViation? <QueryRange>

Returns the statistical value for the average frequency from the statistics table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:FREQuency:MAXFm?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:FREQuency:MAXFm?
[SENSe:]HOP:FREQuency:MAXFm? <QueryRange>

Returns the maximum Frequency Deviation from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected hop CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only
Manual operation: | See "Frequency Deviation (Peak)"


[SENSe:]HOP:FREQuency:MAXFm:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:FREQuency:MAXFm:AVERage?
[SENSe:]HOP:FREQuency:MAXFm:AVERage? <QueryRange>
[SENSe:]HOP:FREQuency:MAXFm:MAXimum? <QueryRange>
[SENSe:]HOP:FREQuency:MAXFm:MINimum? <QueryRange>
[SENSe:]HOP:FREQuency:MAXFm:SDEViation? <QueryRange>

Returns the statistical value for the maximum Frequency Deviation from the statistics table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:FREQuency:RMSFm?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:FREQuency:RMSFm?
[SENSe:]HOP:FREQuency:RMSFm? <QueryRange>

Returns the RMS Frequency Deviation from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected hop CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only
Manual operation: | See "Frequency Deviation (RMS)"


[SENSe:]HOP:FREQuency:RMSFm:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:FREQuency:RMSFm:AVERage?
[SENSe:]HOP:FREQuency:RMSFm:AVERage? <QueryRange>
[SENSe:]HOP:FREQuency:RMSFm:MAXimum? <QueryRange>
[SENSe:]HOP:FREQuency:RMSFm:MINimum? <QueryRange>
[SENSe:]HOP:FREQuency:RMSFm:SDEViation? <QueryRange>

Returns the statistical value for the RMS Frequency Deviation from the statistics table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:ID?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:ID?
[SENSe:]HOP:ID? <QueryRange>

Returns the hop IDs from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:NUMBer?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:NUMBer?
[SENSe:]HOP:NUMBer? <QueryRange>

Returns the hop numbers from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:POWer:AVEPower?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:POWer:AVEPower?
[SENSe:]HOP:POWer:AVEPower? <QueryRange>

Returns the average power from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected hop CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only
Manual operation: | See "Average Power"


[SENSe:]HOP:POWer:AVEPower:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:POWer:AVEPower:AVERage?
[SENSe:]HOP:POWer:AVEPower:AVERage? <QueryRange>
[SENSe:]HOP:POWer:AVEPower:MAXimum? <QueryRange>
[SENSe:]HOP:POWer:AVEPower:MINimum? <QueryRange>
[SENSe:]HOP:POWer:AVEPower:SDEViation? <QueryRange>

Returns the statistical value for the average power from the statistics table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:STATe?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:STATe?
[SENSe:]HOP:STATe? <QueryRange>

Returns the hop states from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected hop CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only
Manual operation: | See "State Index"


[SENSe:]HOP:STATe:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:STATe:AVERage?
[SENSe:]HOP:STATe:AVERage? <QueryRange>
[SENSe:]HOP:STATe:MAXimum? <QueryRange>
[SENSe:]HOP:STATe:MINimum? <QueryRange>
[SENSe:]HOP:STATe:SDEViation? <QueryRange>

Returns the statistical value for the hop states from the statistics table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:TIMing:BEGin?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:TIMing:BEGin?
[SENSe:]HOP:TIMing:BEGin? <QueryRange>

Returns the begin times from the Results table for the specified hop(s).

The begin time is the relative time (in ms) from the capture start at which the signal first enters the tolerance area of a nominal hop (within the analysis region).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected hop CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only
Manual operation: | See "Hop Begin"


[SENSe:]HOP:TIMing:BEGin:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:TIMing:BEGin:AVERage?
[SENSe:]HOP:TIMing:BEGin:AVERage? <QueryRange>
[SENSe:]HOP:TIMing:BEGin:MAXimum? <QueryRange>
[SENSe:]HOP:TIMing:BEGin:MINimum? <QueryRange>
[SENSe:]HOP:TIMing:BEGin:SDEViation? <QueryRange>

Returns the statistical value for the begin time from the statistics table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:TIMing:DWELl?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:TIMing:DWELl?
[SENSe:]HOP:TIMing:DWELl? <QueryRange>

Returns the dwell time from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected hop CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only
Manual operation: | See "Dwell Time"


[SENSe:]HOP:TIMing:DWELl:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:TIMing:DWELl:AVERage?
[SENSe:]HOP:TIMing:DWELl:AVERage? <QueryRange>
[SENSe:]HOP:TIMing:DWELl:MAXimum? <QueryRange>
[SENSe:]HOP:TIMing:DWELl:MINimum? <QueryRange>
[SENSe:]HOP:TIMing:DWELl:SDEViation? <QueryRange>

Returns the statistical value for the hop dwell time from the statistics table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


[SENSe:]HOP:TIMing:SWITching?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:TIMing:SWITching?
[SENSe:]HOP:TIMing:SWITching? <QueryRange>

Returns the switching time from the Results table for the specified hop(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected hop CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only
Manual operation: | See "Switching Time"


[SENSe:]HOP:TIMing:SWITching:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Hops > [SENSe:]HOP:TIMing:SWITching:AVERage?
[SENSe:]HOP:TIMing:SWITching:AVERage? <QueryRange>
[SENSe:]HOP:TIMing:SWITching:MAXimum? <QueryRange>
[SENSe:]HOP:TIMing:SWITching:MINimum? <QueryRange>
[SENSe:]HOP:TIMing:SWITching:SDEViation? <QueryRange>

Returns the statistical value for the hop switching time from the statistics table for the specified hop(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected hops in the current capture buffer ALL All hops detected in the entire measurement
Usage: | Query only


Retrieving Information on Detected Chirps

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps
Retrieving Information on Detected Chirps

The following commands return information on the currently selected or all detected chirps.

List of Commands
CALCulate:CHRDetection:TABLe:RESults?
CALCulate:CHRDetection:TOTal?
[SENSe:]CHIRp:FREQuency:AVGFm?
[SENSe:]CHIRp:FREQuency:AVGFm:AVERage?
[SENSe:]CHIRp:FREQuency:AVGFm:MAXimum?
[SENSe:]CHIRp:FREQuency:AVGFm:MINimum?
[SENSe:]CHIRp:FREQuency:AVGFm:SDEViation?
[SENSe:]CHIRp:FREQuency:CHERror?
[SENSe:]CHIRp:FREQuency:CHERror:AVERage?
[SENSe:]CHIRp:FREQuency:CHERror:MAXimum?
[SENSe:]CHIRp:FREQuency:CHERror:MINimum?
[SENSe:]CHIRp:FREQuency:CHERror:SDEViation?
[SENSe:]CHIRp:FREQuency:FREQuency?
[SENSe:]CHIRp:FREQuency:FREQuency:AVERage?
[SENSe:]CHIRp:FREQuency:FREQuency:MAXimum?
[SENSe:]CHIRp:FREQuency:FREQuency:MINimum?
[SENSe:]CHIRp:FREQuency:FREQuency:SDEViation?
[SENSe:]CHIRp:FREQuency:MAXFm?
[SENSe:]CHIRp:FREQuency:MAXFm:AVERage?
[SENSe:]CHIRp:FREQuency:MAXFm:MAXimum?
[SENSe:]CHIRp:FREQuency:MAXFm:MINimum?
[SENSe:]CHIRp:FREQuency:MAXFm:SDEViation?
[SENSe:]CHIRp:FREQuency:RMSFm?
[SENSe:]CHIRp:FREQuency:RMSFm:AVERage?
[SENSe:]CHIRp:FREQuency:RMSFm:MAXimum?
[SENSe:]CHIRp:FREQuency:RMSFm:MINimum?
[SENSe:]CHIRp:FREQuency:RMSFm:SDEViation?
[SENSe:]CHIRp:ID?
[SENSe:]CHIRp:NUMBer?
[SENSe:]CHIRp:POWer:AVEPower?
[SENSe:]CHIRp:POWer:AVEPower:AVERage?
[SENSe:]CHIRp:POWer:AVEPower:MAXimum?
[SENSe:]CHIRp:POWer:AVEPower:MINimum?
[SENSe:]CHIRp:POWer:AVEPower:SDEViation?
[SENSe:]CHIRp:STATe?
[SENSe:]CHIRp:STATe:AVERage?
[SENSe:]CHIRp:STATe:MAXimum?
[SENSe:]CHIRp:STATe:MINimum?
[SENSe:]CHIRp:STATe:SDEViation?
[SENSe:]CHIRp:TIMing:BEGin?
[SENSe:]CHIRp:TIMing:BEGin:AVERage?
[SENSe:]CHIRp:TIMing:BEGin:MAXimum?
[SENSe:]CHIRp:TIMing:BEGin:MINimum?
[SENSe:]CHIRp:TIMing:BEGin:SDEViation?
[SENSe:]CHIRp:TIMing:LENGth?
[SENSe:]CHIRp:TIMing:LENGth:AVERage?
[SENSe:]CHIRp:TIMing:LENGth:MAXimum?
[SENSe:]CHIRp:TIMing:LENGth:MINimum?
[SENSe:]CHIRp:TIMing:LENGth:SDEViation?
[SENSe:]CHIRp:TIMing:RATE?
[SENSe:]CHIRp:TIMing:RATE:AVERage?
[SENSe:]CHIRp:TIMing:RATE:MAXimum?
[SENSe:]CHIRp:TIMing:RATE:MINimum?
[SENSe:]CHIRp:TIMing:RATE:SDEViation?


CALCulate:CHRDetection:TABLe:RESults?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > CALCulate:CHRDetection:TABLe:RESults?
CALCulate:CHRDetection:TABLe:RESults? [<Start>, <End>]

This command queries the chirp results table. The result is a comma-separated list of value sets, one set for each chirp.

If no query parameters are specified, the results for all detected chirps are returned.

Which values are returned depends on the enabled parameters for the results tables (see CALCulate:​CHRDetection:​TABLe:​COLumn).

Query parameters:
<Start>
integer

The chirp number of the first chirp to be returned. Chirp numbers start at 1.

<End>
integer

The chirp number of the last chirp to be returned.

Return values:
<ID>

Timestamp which corresponds to the absolute time the beginning of the chirp was detected

<ChirpNo>

Consecutive number of detected chirp, starts at 1 for each new measurement

<StateIndex>

Consecutive number of corresponding nominal chirp state as defined in the "Chirp States" table (see CALCulate:​CHRDetection:​STATes[:​DATA])

<Begin>

Time offset from the analyis region start at which the signal first enters the tolerance area of a nominal chirp

Default unit: ms
<Length>

The duration of a chirp from begin to end, that is, the time the signal remains in the tolerance area of a nominal chirp.

Default unit: ms
<CRate>

Derivative of the FM vs time trace within the frequency measurement range

Default unit: kHz/μs
<CRateDev>

Deviation of the detected chirp rate from the nominal chirp state (in kHz/us).

For details see "Chirp State Deviation".

Default unit: kHz/μs
<FreqAvg>

Average frequency measured within the frequency measurement range of the chirp

Default unit: kHz
<FMDevMax>

Maximum deviation of the chirp frequency from the nominal chirp frequency as defined in the "Chirp States" table. The deviation is calculated within the frequency measurement range of the chirp.

For details see "Frequency Deviation (Peak)".

Default unit: kHz
<FMDevRMS>

RMS deviation of the chirp frequency from the nominal (linear) chirp frequency as defined in the "Chirp States" table. The deviation is calculated within the frequency measurement range of the chirp.

For details see "Frequency Deviation (RMS)".

Default unit: kHz
<FMDevAvg>

Average deviation of the chirp frequency from the nominal (linear) chirp frequency as defined in the "Chirp States" table. The deviation is calculated within the frequency measurement range of the chirp.

For details see "Frequency Deviation (Average)".

Default unit: kHz
<PowAvg>

Average power level measured during a chirp. Which part of the chirp precisely is used for calculation depends on the power parameters in the "Power" measurement range configuration.

Default unit: dBm
Example: CALC3:CHRD:TABLe? 1, 10

Result:

Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Usage: Query only
Manual operation: See "State Index"
See "Chirp Begin"
See "Chirp Length"
See "Chirp Rate"
See "Chirp State Deviation"
See "Average Frequency"
See "Frequency Deviation (Peak)"
See "Frequency Deviation (RMS)"
See "Frequency Deviation (Average)"
See "Average Power"


CALCulate:CHRDetection:TOTal?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > CALCulate:CHRDetection:TOTal?
CALCulate:CHRDetection:TOTal?

This command returns the total number of chirps found.

Return values:
<TotalChirps> |
Usage: | Query only


[SENSe:]CHIRp:FREQuency:AVGFm?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:FREQuency:AVGFm?
[SENSe:]CHIRp:FREQuency:AVGFm? <QueryRange>

Returns the average Frequency Deviation from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected chirp CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only
Manual operation: | See "Frequency Deviation (Average)"


[SENSe:]CHIRp:FREQuency:AVGFm:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:FREQuency:AVGFm:AVERage?
[SENSe:]CHIRp:FREQuency:AVGFm:AVERage? <QueryRange>
[SENSe:]CHIRp:FREQuency:AVGFm:MAXimum? <QueryRange>
[SENSe:]CHIRp:FREQuency:AVGFm:MINimum? <QueryRange>
[SENSe:]CHIRp:FREQuency:AVGFm:SDEViation? <QueryRange>

Returns the statistical value for the average Frequency Deviation from the statistics table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:FREQuency:CHERror?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:FREQuency:CHERror?
[SENSe:]CHIRp:FREQuency:CHERror? <QueryRange>

Returns the chirp rate deviation from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected chirp CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only
Manual operation: | See "Chirp State Deviation"


[SENSe:]CHIRp:FREQuency:CHERror:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:FREQuency:CHERror:AVERage?
[SENSe:]CHIRp:FREQuency:CHERror:AVERage? <QueryRange>
[SENSe:]CHIRp:FREQuency:CHERror:MAXimum? <QueryRange>
[SENSe:]CHIRp:FREQuency:CHERror:MINimum? <QueryRange>
[SENSe:]CHIRp:FREQuency:CHERror:SDEViation? <QueryRange>

Returns the statistical value for the chirp rate deviation from the statistics table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:FREQuency:FREQuency?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:FREQuency:FREQuency?
[SENSe:]CHIRp:FREQuency:FREQuency? <QueryRange>

Returns theaverage frequency from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected chirp CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only
Manual operation: | See "Average Frequency"


[SENSe:]CHIRp:FREQuency:FREQuency:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:FREQuency:FREQuency:AVERage?
[SENSe:]CHIRp:FREQuency:FREQuency:AVERage? <QueryRange>
[SENSe:]CHIRp:FREQuency:FREQuency:MAXimum? <QueryRange>
[SENSe:]CHIRp:FREQuency:FREQuency:MINimum? <QueryRange>
[SENSe:]CHIRp:FREQuency:FREQuency:SDEViation? <QueryRange>

Returns the statistical value for the average frequency from the statistics table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:FREQuency:MAXFm?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:FREQuency:MAXFm?
[SENSe:]CHIRp:FREQuency:MAXFm? <QueryRange>

Returns the maximum Frequency Deviation from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected chirp CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only
Manual operation: | See "Frequency Deviation (Peak)"


[SENSe:]CHIRp:FREQuency:MAXFm:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:FREQuency:MAXFm:AVERage?
[SENSe:]CHIRp:FREQuency:MAXFm:AVERage? <QueryRange>
[SENSe:]CHIRp:FREQuency:MAXFm:MAXimum? <QueryRange>
[SENSe:]CHIRp:FREQuency:MAXFm:MINimum? <QueryRange>
[SENSe:]CHIRp:FREQuency:MAXFm:SDEViation? <QueryRange>

Returns the statistical value for the maximum Frequency Deviation from the statistics table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:FREQuency:RMSFm?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:FREQuency:RMSFm?
[SENSe:]CHIRp:FREQuency:RMSFm? <QueryRange>

Returns the RMS Frequency Deviation from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected chirp CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only
Manual operation: | See "Frequency Deviation (RMS)"


[SENSe:]CHIRp:FREQuency:RMSFm:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:FREQuency:RMSFm:AVERage?
[SENSe:]CHIRp:FREQuency:RMSFm:AVERage? <QueryRange>
[SENSe:]CHIRp:FREQuency:RMSFm:MAXimum? <QueryRange>
[SENSe:]CHIRp:FREQuency:RMSFm:MINimum? <QueryRange>
[SENSe:]CHIRp:FREQuency:RMSFm:SDEViation? <QueryRange>

Returns the statistical value for the RMS Frequency Deviation from the statistics table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:ID?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:ID?
[SENSe:]CHIRp:ID? <QueryRange>

Returns the chirp IDs from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:NUMBer?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:NUMBer?
[SENSe:]CHIRp:NUMBer? <QueryRange>

Returns the chirp numbers from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:POWer:AVEPower?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:POWer:AVEPower?
[SENSe:]CHIRp:POWer:AVEPower? <QueryRange>

Returns the average power from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected chirp CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only
Manual operation: | See "Average Power"


[SENSe:]CHIRp:POWer:AVEPower:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:POWer:AVEPower:AVERage?
[SENSe:]CHIRp:POWer:AVEPower:AVERage? <QueryRange>
[SENSe:]CHIRp:POWer:AVEPower:MAXimum? <QueryRange>
[SENSe:]CHIRp:POWer:AVEPower:MINimum? <QueryRange>
[SENSe:]CHIRp:POWer:AVEPower:SDEViation? <QueryRange>

Returns the statistical value for the average power from the statistics table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:STATe?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:STATe?
[SENSe:]CHIRp:STATe? <QueryRange>

Returns the chirp states from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected chirp CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only
Manual operation: | See "State Index"


[SENSe:]CHIRp:STATe:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:STATe:AVERage?
[SENSe:]CHIRp:STATe:AVERage? <QueryRange>
[SENSe:]CHIRp:STATe:MAXimum? <QueryRange>
[SENSe:]CHIRp:STATe:MINimum? <QueryRange>
[SENSe:]CHIRp:STATe:SDEViation? <QueryRange>

Returns the statistical value for the chirp states from the statistics table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:TIMing:BEGin?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:TIMing:BEGin?
[SENSe:]CHIRp:TIMing:BEGin? <QueryRange>

Returns the chirp begin time from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected chirp CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only
Manual operation: | See "Chirp Begin"


[SENSe:]CHIRp:TIMing:BEGin:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:TIMing:BEGin:AVERage?
[SENSe:]CHIRp:TIMing:BEGin:AVERage? <QueryRange>
[SENSe:]CHIRp:TIMing:BEGin:MAXimum? <QueryRange>
[SENSe:]CHIRp:TIMing:BEGin:MINimum? <QueryRange>
[SENSe:]CHIRp:TIMing:BEGin:SDEViation? <QueryRange>

Returns the statistical value for the chirp begin from the statistics table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:TIMing:LENGth?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:TIMing:LENGth?
[SENSe:]CHIRp:TIMing:LENGth? <QueryRange>

Returns the chirp length from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected chirp CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only
Manual operation: | See "Chirp Length"


[SENSe:]CHIRp:TIMing:LENGth:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:TIMing:LENGth:AVERage?
[SENSe:]CHIRp:TIMing:LENGth:AVERage? <QueryRange>
[SENSe:]CHIRp:TIMing:LENGth:MAXimum? <QueryRange>
[SENSe:]CHIRp:TIMing:LENGth:MINimum? <QueryRange>
[SENSe:]CHIRp:TIMing:LENGth:SDEViation? <QueryRange>

Returns the statistical value for the chirp begin from the statistics table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


[SENSe:]CHIRp:TIMing:RATE?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:TIMing:RATE?
[SENSe:]CHIRp:TIMing:RATE? <QueryRange>

Returns the chirp rate from the Results table for the specified chirp(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Selected chirp CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only
Manual operation: | See "Chirp Rate"


[SENSe:]CHIRp:TIMing:RATE:AVERage?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Information on Detected Chirps > [SENSe:]CHIRp:TIMing:RATE:AVERage?
[SENSe:]CHIRp:TIMing:RATE:AVERage? <QueryRange>
[SENSe:]CHIRp:TIMing:RATE:MAXimum? <QueryRange>
[SENSe:]CHIRp:TIMing:RATE:MINimum? <QueryRange>
[SENSe:]CHIRp:TIMing:RATE:SDEViation? <QueryRange>

Returns the statistical value for the chirp rate from the statistics table for the specified chirp(s).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected chirps in the current capture buffer ALL All chirps detected in the entire measurement
Usage: | Query only


Retrieving Trace Data

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Trace Data
Retrieving Trace Data

In order to retrieve the trace results in a remote environment, use the following command:

List of Commands
CALCulate<n>:SGRam|SPECtrogram:FRAMe:COUNt?
DISPlay:[WINDow<n>:]TRACe<t>:LENGth?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]:X?


CALCulate<n>:SGRam|SPECtrogram:FRAMe:COUNt?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Trace Data > CALCulate<n>:SGRam|SPECtrogram:FRAMe:COUNt?
CALCulate<n>:SGRam|SPECtrogram:FRAMe:COUNt?

This command queries the number of frames that are contained in the selected result display (depends on the evaluation basis).

Return values:
<Frames>

The maximum number of frames depends on the history depth.

Range: | 1 to history depth
Increment: | 1
Example: INIT:CONT OFF

Selects single sweep mode.

LAY:REPL 2,SGR

Replaces the result display in window 2 by a spectrogram.

DISP:WIND2:EVAL REG

Defines the analysis region as the evaluation basis for the spectrogram in window 2.

CALC:SGR:FRAM:COUN?

Queries the number of frames in the spectrogram based on the analysis region.

Usage: Query only


DISPlay:[WINDow<n>:]TRACe<t>:LENGth?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Trace Data > DISPlay:[WINDow<n>:]TRACe<t>:LENGth?
DISPlay:[WINDow<n>:]TRACe<t>:LENGth?

Queries the trace length for the specified trace in the specified window.

Return values:
<TraceLength> | Number of measurement points for the trace.
Example: | DISP:WIND:TRAC:LENG?
Usage: | Query only


TRACe<n>[:DATA]?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Trace Data > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? <Trace>

This command queries current trace data and measurement results.

Query parameters:
<Trace>
TRACe1 | TRACe2 | TRACe3 | TRACe4 | TRACe5 | TRACe6 | SGRam | SPECtrogram

Determines which trace results are returned.

If no trace parameter is provided with the query, trace 1 is assumed.

*RST: TRACe1
Example: TRAC:DATA? TRACe2
Example:

See "Programming Example: Performing a Chirp Detection Measurement".

Example:

See "Programming Example: Performing a Hop Detection Measurement".

Usage: Query only


TRACe<n>[:DATA]:X?

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Retrieving Trace Data > TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]:X? <Trace>

This remote control command returns the X values only for the trace in the selected result display. Depending on the type of result display and the scaling of the x-axis, this can be either the pulse number or a timestamp for each detected pulse in the capture buffer.

This command is only available for graphical displays, except for the Magnitude Capture display.

Query parameters:
<Trace> | TRACe1 The trace number whose values are to be returned. Currently only one trace is available.
Usage: | Query only


Exporting Table Results to an ASCII File

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Exporting Table Results to an ASCII File
Exporting Table Results to an ASCII File

Table results can be exported to an ASCII file for further evaluation in other (external) applications.

Useful commands for exporting table results described elsewhere:
  • FORMat:​DEXPort:​DSEParator
Remote commands exclusive to exporting table results:
List of Commands
MMEMory:STORe<n>:TABLe


MMEMory:STORe<n>:TABLe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Exporting Table Results to an ASCII File > MMEMory:STORe<n>:TABLe
MMEMory:STORe<n>:TABLe <Columns>, <FileName>

This command exports result table data from the specified window to an ASCii file (.DAT).

For details on the file format see "Reference: ASCII File Export Format".

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<Columns>

Columns to be stored in file

SELected

Export only the selected (visible) table columns

ALL

Export all table columns (all possible measured parameters)

*RST: SEL
<FileName>

String containing the path and name of the target file.

Example: MMEM:STOR1:TABL SEL,'TEST.DAT'

Stores the selected columns from the result table in window 1 in the file TEST.DAT.

Example:

See "Programming Example: Pulse Measurement" .

Usage: SCPI confirmed
Manual operation: See "Columns to Export"
See "Export Table to ASCII File"
See "Columns to Export"


Exporting Trace Results

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Exporting Trace Results
Exporting Trace Results

Trace results can be exported to a file.

For more commands concerning data and results storage see the R&S FSW User Manual.

List of Commands
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes
MMEMory:STORe:TA:MEAS
MMEMory:STORe<n>:TRACe


FORMat:DEXPort:DSEParator

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Exporting Trace Results > FORMat:DEXPort:DSEParator
FORMat:DEXPort:DSEParator <Separator>

This command selects the decimal separator for data exported in ASCII format.

Parameters:
<Separator>
COMMa

Uses a comma as decimal separator, e.g. 4,05.

POINt

Uses a point as decimal separator, e.g. 4.05.

*RST: *RST has no effect on the decimal separator. Default is POINt.
Example: FORM:DEXP:DSEP POIN

Sets the decimal point as separator.

Manual operation: See "Decimal Separator"


FORMat:DEXPort:HEADer

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Exporting Trace Results > FORMat:DEXPort:HEADer
FORMat:DEXPort:HEADer <State>

If enabled, additional instrument and measurement settings are included in the header of the export file for result data. If disabled, only the pure result data from the selected traces and tables is exported.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Usage: SCPI confirmed
Manual operation: See "Include Instrument Measurement Settings"


FORMat:DEXPort:TRACes

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Exporting Trace Results > FORMat:DEXPort:TRACes
FORMat:DEXPort:TRACes <Selection>

This command selects the data to be included in a data export file (see MMEMory:​STORe<n>:​TRACe).

Parameters:
<Selection>
SINGle

Only a single trace is selected for export, namely the one specified by the MMEMory:​STORe<n>:​TRACe command.

ALL

Selects all active traces and result tables (e.g. Result Summary, marker peak list etc.) in the current application for export to an ASCII file.

The <trace> parameter for the MMEMory:​STORe<n>:​TRACe command is ignored.

*RST: SINGle
Usage: SCPI confirmed
Manual operation: See "Export all Traces and all Table Results"


MMEMory:STORe:TA:MEAS

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Exporting Trace Results > MMEMory:STORe:TA:MEAS
MMEMory:STORe:TA:MEAS <File>

This command stores the current measurement results (all enabled traces of all windows) into the specified .csv file.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Setting parameters:
<File> | path and file name
Example: | MMEM:STOR:TA:MEAS 'C:\R_S\userdata\MyMeas.csv'
Example: | See "Programming Example: Performing a Hop Detection Measurement".
Usage: | Setting only


MMEMory:STORe<n>:TRACe

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Retrieving Results > Exporting Trace Results > MMEMory:STORe<n>:TRACe
MMEMory:STORe<n>:TRACe <Trace>, <FileName>

This command exports trace data from the specified window to an ASCII file.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<Trace> | Number of the trace to be stored
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR1:TRAC 3,'C:\TEST.ASC' Stores trace 3 from window 1 in the file TEST.ASC.
Usage: | SCPI confirmed
Manual operation: | See "Export Trace to ASCII File"


Status Reporting System

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Status Reporting System
Status Reporting System

The status reporting system stores all information on the current operating state of the instrument, e.g. information on errors or limit violations which have occurred. This information is stored in the status registers and in the error queue. The status registers and the error queue can be queried via IEC bus.

The R&S FSW Transient Analysis application uses only the registers provided by the base system.

For details and a description of the common R&S FSW status registers see "Status Reporting System" .


Programming Examples

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Programming Examples
Programming Examples

The following examples demonstrate how to perform transient analysis in a remote environment.

Note that some of the used commands may not be necessary as they define default values, but are included to demonstrate their use.

Contents
  • Programming Example: Performing a Basic Transient Analysis Measurement
  • Programming Example: Performing a Chirp Detection Measurement
  • Programming Example: Performing a Hop Detection Measurement


Programming Example: Performing a Basic Transient Analysis Measurement

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Programming Examples > Programming Example: Performing a Basic Transient Analysis Measurement
Programming Example: Performing a Basic Transient Analysis Measurement

This example demonstrates how to perform a basic transient analysis measurement for an unknown signal in a remote environment.

//----------- Preparing the measurement ------------
//Reset the instrument
*RST
//Activate the transient analysis application
INST:SEL 'TA'

//-----------Configuring the measurement ------------
//Set the center frequency
FREQ:CENT 1GHz

// Configure a power trigger to detect transient power effects
TRIG:SEQ:SOUR IFP
TRIG:SEQ:LEV:IFP -130dBm

//Configure data acquisition for 5 ms in a 80 MHz bandwidth
BAND:DEM 80MHz
MTIM 5ms

//------------- Configuring the results -------------------------------
//Result displays (default):
//upper row: (1)RF Spectrum (2)FM Time Domain
//bottom row: (3)Spectrogram (4)RF Power Time Domain

//Configure RF Power Time Domain: automatic scaling
DISP:WIND4:TRAC:Y:SCAL:AUTO ON

//Configure Spectrogram. MAX detector, GAUSS window function; Query number of bins
SENS:WIND3:SGR:DET:FUNC MAX
SWE:FFT:WIND3:TYPE GAUS
SWE:FFT:WIND3:LENG?

//--------------Performing the Measurement-----
INIT:CONT OFF
//Selects single sweep mode.
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Retrieving Results-------------
//Retrieve trace data for RF Power Time Domain
//TRAC4:DATA? TRACe1
//TRAC4:DATA:X? TRACe1


Programming Example: Performing a Chirp Detection Measurement

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Programming Examples > Programming Example: Performing a Chirp Detection Measurement
Programming Example: Performing a Chirp Detection Measurement

This example demonstrates how to perform transient analysis on a chirped signal in a remote environment.

//----------- Preparing the measurement ------------
//Reset the instrument
*RST
//Activate the transient analysis application
INST:SEL 'TA'

//-----------Configuring the measurement ------------
//Set the center frequency
FREQ:CENT 1GHz

// Configure a power trigger to detect transient power effects
TRIG:SEQ:SOUR IFP
TRIG:SEQ:LEV:IFP -50dBm

//Configure data acquisition for 5 ms in a 80 MHz bandwidth
BAND:DEM 80MHz
MTIM 5ms

//Configure the expected chirp signal manually
SIGN:MOD CHIR
CALC:CHRD:STAT:AUTO OFF
CALC:CHRD:STAT 1e6, 0.3e6, 1e5, 0.4e5
CALC:CHRD:LENG:AUTO OFF
CALC:CHRD:LENG:MIN 0.0001
CALC:CHRD:LENG:MAX 0.000350

//Configure the measurement range
//Frequency calc: cut off 5us at beginning and end of chirp
CALC:CHRD:FREQ:REF EDGE
CALC:CHRD:FREQ:OFFS:BEG 0.000005
CALC:CHRD:FREQ:OFFS:END 0.000005
//Power calc. : cut off 5% at each end of chirp
CALC:CHRD:POW:REF CENT
CALC:CHRD:POW:LENG 90

//Configure the analysis region: analyze 1 ms in 20MHz bandwidth in center
CALC:AR:FREQ:BAND 40MHz
CALC:AR:FREQ:DELT -20MHz
CALC:AR:TIME:LENG 1ms
CALC:AR:TIME:STAR 2 ms

//Configure the result range manually: display 50us at beginning of each chirp,
//but cut off first 5us
CALC:RES:RANG:AUTO OFF
CALC:RES:REF RISE
CALC:RES:OFFS 0.000005
CALC:RES:ALIG LEFT
CALC:RES:LENG 0.00005

//------------- Configuring the results -------------------------------
//Result displays:
//upper row: (1) RF Spectrum (A.Region) (2)RF Spectrum (chirp1)
//middle row: (3)Spectrogram (full capture), default (4)RF Power Time Domain (full capture)
//bottom row: (5) Chirp Results table (default), (6) Chirp Statistics table
DISP:WIND1:EVAL REG
LAY:ADD:WIND? '1',RIGH,RFSP
DISP:WIND2:EVAL SIGN
CALC:CHRD:SEL 1
LAY:REPL:WIND '4',RFPT
DISP:WIND4:EVAL FULL
LAY:ADD:WIND? '5',RIGH,STAB

//Configure RF Power Time Domain: automatic scaling
DISP:WIND4:TRAC:Y:SCAL:AUTO ON

//Configure range for (1)RF Spectrum (A.Region)
DISP:WIND1:TRAC:Y:SCAL:AUTO OFF
DISP:WIND1:TRAC:Y:SCAL:MAX -80 dBM
DISP:WIND1:TRAC:Y:SCAL:MIN -130 dBM

//Configure table results: show state,begin, length, frequency, max fm, average power
CALC:CHRD:TABL:COL ON, STAT, BEG, LENG, FREQ, MAXF, AVGP

//Configure Spectrogram. MAX detector, GAUSS window function, query number of bins
SENS:WIND3:SGR:DET:FUNC MAX
SWE:FFT:WIND:TYPE GAUS
SWE:FFT:WIND:LENG?

//--------------Performing the Measurement-----
INIT:CONT OFF
//Selects single sweep mode.
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Retrieving Results-------------
//Retrieve trace data for RF Power Time Domain
//TRAC4:DATA? TRACe1
//TRAC4:DATA:X? TRACe1

//Retrieve table results for first 10 chirps
CALC5:CHRD:TABL:RES? 1,10

//Export entire statistics result table (all params) to an ASCII file
MMEM:STOR6:TABL ALL,'C:\R_S\Instr\user\AllStatResults.dat'


Programming Example: Performing a Hop Detection Measurement

Transient Analysis (R&S FSW-K60) > Remote Commands to Perform Transient Analysis > Programming Examples > Programming Example: Performing a Hop Detection Measurement
Programming Example: Performing a Hop Detection Measurement

This example demonstrates how to perform transient analysis on a hopped signal in a remote environment.

//----------- Preparing the measurement ------------
//Reset the instrument
*RST
//Activate the transient analysis application
INST:SEL 'TA'

//-----------Configuring the measurement ------------
//Set the center frequency
FREQ:CENT 1GHz

// Configure a power trigger to detect transient power effects
TRIG:SEQ:SOUR IFP
TRIG:SEQ:LEV:IFP -50dBm

//Configure data acquisition for 5 ms in a 80 MHz bandwidth
BAND:DEM 80MHz
MTIM 5ms

//Configure the expected hop signal manually
SIGN:MOD HOP
CALC:HOPD:STAT:AUTO OFF
CALC:HOPD:STAT 1e6, 0.3e6, 1e5, 0.4e5
CALC:HOPD:DWEL:AUTO OFF
CALC:HOPD:DWEL:MIN 0.0001
CALC:HOPD:DWEL:MAX 0.000350

//Configure the measurement range
//Frequency calc: cut off 5us at beginning and end of hop
CALC:HOPD:FREQ:REF EDGE
CALC:HOPD:FREQ:OFFS:BEG 0.000005
CALC:HOPD:FREQ:OFFS:END 0.000005
//Power calc. : cut off 5% at each end of hop
CALC:HOPD:POW:REF CENT
CALC:HOPD:POW:LENG 90

//Configure the analysis region: analyze 1 ms in 20MHz bandwidth in center
CALC:AR:FREQ:BAND 40MHz
CALC:AR:FREQ:DELT -20MHz
CALC:AR:TIME:LENG 1ms
CALC:AR:TIME:STAR 2 ms

//Configure the result range manually: display 50us at beginning of each hop,
//but cut off first 5us
CALC:RES:RANG:AUTO OFF
CALC:RES:REF RISE
CALC:RES:OFFS 0.000005
CALC:RES:ALIG LEFT
CALC:RES:LENG 0.00005

//------------- Configuring the results -------------------------------
//Result displays:
//upper row: (1)RF Power Time Domain (full capture), default (2)RF Spectrum (hop1)
//middle row: (3)Spectrogram (full capture), default (4)RF Spectrum (A.Region)
//bottom row: (5)Hop Results table, default (6)Hop Statistics table
LAY:ADD:WIND? '1',RIGH,RFSP
DISP:WIND5:EVAL SIGN
CALC:HOPD:SEL 1
LAY:REPL:WIND '4',RFSP
DISP:WIND3:EVAL REG
LAY:ADD:WIND? '6',RIGH,STAB

//Configure RF Power Time Domain: automatic scaling
DISP:WIND1:TRAC:Y:SCAL:AUTO ON

//Configure range for (4)RF Spectrum (A.Region)
DISP:WIND4:TRAC:Y:SCAL:AUTO OFF
DISP:WIND4:TRAC:Y:SCAL:MAX -80 dBM
DISP:WIND4:TRAC:Y:SCAL:MIN -130 dBM

//Configure table results: show state,begin, length, frequency, max fm, average power
CALC:HOPD:TABL:COL ON, STAT, BEG, DWEL, FREQ, MAXF, AVGP

//Configure Spectrogram. MAX detector, largeR no. of bins, GAUSS window function, query number of bins
SENS:WIND3:SGR:DET:FUNC MAX
SWE:FFT:WIND:TYPE GAUS
SWE:FFT:WIND:LENG?

//--------------Performing the Measurement-----
INIT:CONT OFF
//Selects single sweep mode.
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Retrieving Results-------------
//Retrieve trace data for RF Power Time Domain
//TRAC1:DATA? TRACe1
//TRAC1:DATA:X? TRACe1

//Retrieve table results for first 10 hops
CALC5:HOPD:TABL:RES? 1,10

//Store all enabled traces in all windows to a CSV file
MMEM:STOR:TA:MEAS 'C:\R_S\userdata\MyMeas.csv'


Reference: ASCII File Export Format

Transient Analysis (R&S FSW-K60) > Reference: ASCII File Export Format
Reference: ASCII File Export Format

Trace data can be exported to a file in ASCII format for further evaluation in other applications

The file consists of the header containing important scaling parameters and a data section containing the trace data.

Generally, the format of this ASCII file can be processed by spreadsheet calculation programs, e.g. MS-Excel. Different language versions of evaluation programs may require a different handling of the decimal point. Thus you can define the decimal separator to be used (decimal point or comma, see "Decimal Separator").

The data of the file header consist of three columns, each separated by a semicolon: parameter name; numeric value; basic unit. The data section starts with the two lines containing the measured parameter names and units, followed by the measured data in multiple columns (depending on measurement) which are also separated by a semicolon.

If the spectrogram display is selected when you select the "ASCII Trace Export" softkey, the entire histogram buffer with all frames is exported to a file. The data corresponding to a particular frame begins with information about the frame number and the time that frame was recorded.

ASCII file format for table export
File contents | Description
Header data
Type;R&S FSW; | Instrument model
Version;5.00; | Firmware version
Date;01.Oct 2013; | Date of data set storage
Mode;Ta; | Application
Ref Level;-30;dBm | Reference level
Level Offset;0;dB | Level offset
Rf Att;20;dB | Input attenuation
El Att;2.0;dB | Electrical attenuation
Center Freq;55000;Hz | Center frequency
Freq Offset;0;Hz | Frequency offset
Meas BW;10000000,Hz | Measurement Bandwidth
Meas Time;0.000350000;s | Measurment time
Sweep Count;20; | Number of sweeps set
Preamplifier;OFF | Preamplifier status
Number of Windows;6; | Number of result displays
Window section
Window;1;Full RF Time Domain; | Window number and type
Trace section
Trace 1;; | Trace number
Trace Mode;Clear Write; | Trace mode
x-Axis;Linear; | x-axis scaling mode
Start Freq;0;s | x-axis start value
Stop Freq;0.00035;s | x-axis stop value
x-Unit;s; | x-axis unit
y-Axis;Linear; | y-axis scaling mode
Level Range;0.0010;dBm | y-axis range per division
Ref Position;100.0000;% | y-axis reference position
Ref Value;-113.97900;dBm | y-axis reference value
y-Unit;dBm; | y-axis unit
Data section
Values; 1001; | Number of rows of measured values in the table
0;-113.97937774658203125 0;-113.97937774658203125 …;… | Measured values: <x-value>;<y-value>


List of Commands

Transient Analysis (R&S FSW-K60) > List of Commands
List of Commands
[SENSe:][DEMod:]FMVF:TYPE
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]SGRam|SPECtrogram:DETector:FUNCtion
[SENSe:]ADJust:LEVel
[SENSe:]BANDwidth|BWIDth:DEMod
[SENSe:]BANDwidth|BWIDth[:WINDow<n>]:RATio
[SENSe:]BANDwidth|BWIDth[:WINDow<n>]:RESolution
[SENSe:]CHIRp:FREQuency:AVGFm:AVERage?
[SENSe:]CHIRp:FREQuency:AVGFm:MAXimum?
[SENSe:]CHIRp:FREQuency:AVGFm:MINimum?
[SENSe:]CHIRp:FREQuency:AVGFm:SDEViation?
[SENSe:]CHIRp:FREQuency:AVGFm?
[SENSe:]CHIRp:FREQuency:CHERror:AVERage?
[SENSe:]CHIRp:FREQuency:CHERror:MAXimum?
[SENSe:]CHIRp:FREQuency:CHERror:MINimum?
[SENSe:]CHIRp:FREQuency:CHERror:SDEViation?
[SENSe:]CHIRp:FREQuency:CHERror?
[SENSe:]CHIRp:FREQuency:FREQuency:AVERage?
[SENSe:]CHIRp:FREQuency:FREQuency:MAXimum?
[SENSe:]CHIRp:FREQuency:FREQuency:MINimum?
[SENSe:]CHIRp:FREQuency:FREQuency:SDEViation?
[SENSe:]CHIRp:FREQuency:FREQuency?
[SENSe:]CHIRp:FREQuency:MAXFm:AVERage?
[SENSe:]CHIRp:FREQuency:MAXFm:MAXimum?
[SENSe:]CHIRp:FREQuency:MAXFm:MINimum?
[SENSe:]CHIRp:FREQuency:MAXFm:SDEViation?
[SENSe:]CHIRp:FREQuency:MAXFm?
[SENSe:]CHIRp:FREQuency:RMSFm:AVERage?
[SENSe:]CHIRp:FREQuency:RMSFm:MAXimum?
[SENSe:]CHIRp:FREQuency:RMSFm:MINimum?
[SENSe:]CHIRp:FREQuency:RMSFm:SDEViation?
[SENSe:]CHIRp:FREQuency:RMSFm?
[SENSe:]CHIRp:ID?
[SENSe:]CHIRp:NUMBer?
[SENSe:]CHIRp:POWer:AVEPower:AVERage?
[SENSe:]CHIRp:POWer:AVEPower:MAXimum?
[SENSe:]CHIRp:POWer:AVEPower:MINimum?
[SENSe:]CHIRp:POWer:AVEPower:SDEViation?
[SENSe:]CHIRp:POWer:AVEPower?
[SENSe:]CHIRp:STATe:AVERage?
[SENSe:]CHIRp:STATe:MAXimum?
[SENSe:]CHIRp:STATe:MINimum?
[SENSe:]CHIRp:STATe:SDEViation?
[SENSe:]CHIRp:STATe?
[SENSe:]CHIRp:TIMing:BEGin:AVERage?
[SENSe:]CHIRp:TIMing:BEGin:MAXimum?
[SENSe:]CHIRp:TIMing:BEGin:MINimum?
[SENSe:]CHIRp:TIMing:BEGin:SDEViation?
[SENSe:]CHIRp:TIMing:BEGin?
[SENSe:]CHIRp:TIMing:LENGth:AVERage?
[SENSe:]CHIRp:TIMing:LENGth:MAXimum?
[SENSe:]CHIRp:TIMing:LENGth:MINimum?
[SENSe:]CHIRp:TIMing:LENGth:SDEViation?
[SENSe:]CHIRp:TIMing:LENGth?
[SENSe:]CHIRp:TIMing:RATE:AVERage?
[SENSe:]CHIRp:TIMing:RATE:MAXimum?
[SENSe:]CHIRp:TIMing:RATE:MINimum?
[SENSe:]CHIRp:TIMing:RATE:SDEViation?
[SENSe:]CHIRp:TIMing:RATE?
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:OFFSet
[SENSe:]HOP:FREQuency:AVGFm:AVERage?
[SENSe:]HOP:FREQuency:AVGFm:MAXimum?
[SENSe:]HOP:FREQuency:AVGFm:MINimum?
[SENSe:]HOP:FREQuency:AVGFm:SDEViation?
[SENSe:]HOP:FREQuency:AVGFm?
[SENSe:]HOP:FREQuency:FMERror:AVERage?
[SENSe:]HOP:FREQuency:FMERror:MAXimum?
[SENSe:]HOP:FREQuency:FMERror:MINimum?
[SENSe:]HOP:FREQuency:FMERror:SDEViation?
[SENSe:]HOP:FREQuency:FMERror?
[SENSe:]HOP:FREQuency:FREQuency:AVERage?
[SENSe:]HOP:FREQuency:FREQuency:MAXimum?
[SENSe:]HOP:FREQuency:FREQuency:MINimum?
[SENSe:]HOP:FREQuency:FREQuency:SDEViation?
[SENSe:]HOP:FREQuency:FREQuency?
[SENSe:]HOP:FREQuency:MAXFm:AVERage?
[SENSe:]HOP:FREQuency:MAXFm:MAXimum?
[SENSe:]HOP:FREQuency:MAXFm:MINimum?
[SENSe:]HOP:FREQuency:MAXFm:SDEViation?
[SENSe:]HOP:FREQuency:MAXFm?
[SENSe:]HOP:FREQuency:RMSFm:AVERage?
[SENSe:]HOP:FREQuency:RMSFm:MAXimum?
[SENSe:]HOP:FREQuency:RMSFm:MINimum?
[SENSe:]HOP:FREQuency:RMSFm:SDEViation?
[SENSe:]HOP:FREQuency:RMSFm?
[SENSe:]HOP:ID?
[SENSe:]HOP:NUMBer?
[SENSe:]HOP:POWer:AVEPower:AVERage?
[SENSe:]HOP:POWer:AVEPower:MAXimum?
[SENSe:]HOP:POWer:AVEPower:MINimum?
[SENSe:]HOP:POWer:AVEPower:SDEViation?
[SENSe:]HOP:POWer:AVEPower?
[SENSe:]HOP:STATe:AVERage?
[SENSe:]HOP:STATe:MAXimum?
[SENSe:]HOP:STATe:MINimum?
[SENSe:]HOP:STATe:SDEViation?
[SENSe:]HOP:STATe?
[SENSe:]HOP:TIMing:BEGin:AVERage?
[SENSe:]HOP:TIMing:BEGin:MAXimum?
[SENSe:]HOP:TIMing:BEGin:MINimum?
[SENSe:]HOP:TIMing:BEGin:SDEViation?
[SENSe:]HOP:TIMing:BEGin?
[SENSe:]HOP:TIMing:DWELl:AVERage?
[SENSe:]HOP:TIMing:DWELl:MAXimum?
[SENSe:]HOP:TIMing:DWELl:MINimum?
[SENSe:]HOP:TIMing:DWELl:SDEViation?
[SENSe:]HOP:TIMing:DWELl?
[SENSe:]HOP:TIMing:SWITching:AVERage?
[SENSe:]HOP:TIMing:SWITching:MAXimum?
[SENSe:]HOP:TIMing:SWITching:MINimum?
[SENSe:]HOP:TIMing:SWITching:SDEViation?
[SENSe:]HOP:TIMing:SWITching?
[SENSe:]MEASure:POINts
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold
[SENSe:]MIXer[:STATe]
[SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MTIMe
[SENSe:]RLENgth
[SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]SIGNal:MODel
[SENSe:]SRATe
[SENSe:]STATistic:TYPE
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:FFT:WINDow:LENGth?
[SENSe:]SWEep:FFT:WINDow:TYPE
ABORt
CALCulate:AR:FREQuency:BANDwidth
CALCulate:AR:FREQuency:DELTa
CALCulate:AR:FREQuency:PERCent
CALCulate:AR:FREQuency:PERCent:STATe
CALCulate:AR:TIME:LENGth
CALCulate:AR:TIME:PERCent
CALCulate:AR:TIME:PERCent:STATe
CALCulate:AR:TIME:STARt
CALCulate:CHRDetection:FREQuency:LENGth
CALCulate:CHRDetection:FREQuency:OFFSet:BEGin
CALCulate:CHRDetection:FREQuency:OFFSet:END
CALCulate:CHRDetection:FREQuency:REFerence
CALCulate:CHRDetection:LENGth:AUTO
CALCulate:CHRDetection:LENGth:MAXimum
CALCulate:CHRDetection:LENGth:MINimum
CALCulate:CHRDetection:POWer:LENGth
CALCulate:CHRDetection:POWer:OFFSet:BEGin
CALCulate:CHRDetection:POWer:OFFSet:END
CALCulate:CHRDetection:POWer:REFerence
CALCulate:CHRDetection:SELected
CALCulate:CHRDetection:STATes:AUTO
CALCulate:CHRDetection:STATes[:DATA]
CALCulate:CHRDetection:TABLe:COLumn
CALCulate:CHRDetection:TABLe:RESults?
CALCulate:CHRDetection:TOTal?
CALCulate:HOPDetection:DWELl:AUTO
CALCulate:HOPDetection:DWELl:MAXimum
CALCulate:HOPDetection:DWELl:MINimum
CALCulate:HOPDetection:FREQuency:LENGth
CALCulate:HOPDetection:FREQuency:OFFSet:BEGin
CALCulate:HOPDetection:FREQuency:OFFSet:END
CALCulate:HOPDetection:FREQuency:REFerence
CALCulate:HOPDetection:POWer:LENGth
CALCulate:HOPDetection:POWer:OFFSet:BEGin
CALCulate:HOPDetection:POWer:OFFSet:END
CALCulate:HOPDetection:POWer:REFerence
CALCulate:HOPDetection:SELected
CALCulate:HOPDetection:STATes:AUTO
CALCulate:HOPDetection:STATes[:DATA]
CALCulate:HOPDetection:TABLe:COLumn
CALCulate:HOPDetection:TABLe:RESults?
CALCulate:HOPDetection:TOTal?
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:RESult:ALIGnment
CALCulate:RESult:LENGth
CALCulate:RESult:OFFSet
CALCulate:RESult:RANGe:AUTO
CALCulate:RESult:REFerence
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer:LINK
CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:SGRam:CLEar
CALCulate<n>:SGRam|SPECtrogram:FRAMe:COUNt?
CALCulate<n>:SGRam|SPECtrogram:FRAMe:SELect
CALCulate<n>:SGRam|SPECtrogram:HDEPth
CALCulate<n>:SGRam|SPECtrogram:TRESolution
CALCulate<n>:SGRam|SPECtrogram:TRESolution:AUTO
CALCulate<n>:SGRam|SPECtrogram:TSTamp:DATA?
CALCulate<n>:SGRam|SPECtrogram:TSTamp[:STATe]
CALCulate<n>:UNIT:ANGLe
DIAGnostic:SERVice:NSOurce
DISPlay:[WINDow<n>:]EVAL
DISPlay:[WINDow<n>:]TRACe<t>:LENGth?
DISPlay:FORMat
DISPlay:MTABle
DISPlay[:WINDow<n>]:SELect
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe]
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes
INITiate:CONMeas
INITiate:CONTinuous
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
INITiate:SYNC
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:COUPling
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:SELect
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:STORe:TA:MEAS
MMEMory:STORe<n>:TABLe
MMEMory:STORe<n>:TRACe
OUTPut:IF:IFFRequency
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]?
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce


Legal Notice

R&S®FSW-K60
Transient Analysis

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.